Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I am composing a message Thunderbird doublespaces every time I hit the Enter key, and I can't find an option for single spacing, which I sometimes want

  • 22 replies
  • 152 have this problem
  • 21065 views
  • Last reply by gmeades

more options

I think that this problem arose only with the most recent update to Thunderbird, which I installed yesterday or today (April 22). When I hit the Enter key Thunderbird automatically doublespaces, which is fine for text as it separates paragraphs. However, I also will sometimes type my name, address, and telephone number at the end of the message, using Enter for each to line, and I cannot find a way to make Thunderbird singlespace at that time. Word processors usually have a "line" option that allows for this (at least WordPerfect, which is still the best word processor, does). I'd much rather have Enter do only a single space; I can always hit it twice to double space between paragraphs (I've been doing that since I first used an electric rather than manual typewriter).

Chosen solution

If you keep the default setting for Enter to start a new paragraph (under Tools/Options/Composition/General/HTML), then Shift-Enter will create a single space. Or, change the style in the Write window from Paragraph to Body Text.

Read this answer in context 👍 52

All Replies (20)

more options

Chosen Solution

If you keep the default setting for Enter to start a new paragraph (under Tools/Options/Composition/General/HTML), then Shift-Enter will create a single space. Or, change the style in the Write window from Paragraph to Body Text.

more options

The switch to Body Text seems to work; however, I can't find a way to make that change permanent--I have to do it every time I open a new Write window.

I can't get shift-enter to produce any changes

more options

Hi,

What I really want to do is to have the default style be "body text" instead of "Paragraph." Is it possible to make this change via the UI, or do I need to use about:config? I'm guessing that the Thunderbird team had a good reason for pushing us to use "Paragraph" style by default, and I hope someone from the team can help us understand here why they made this change.

Thanks, dwarfplanet9 - fighting to reinstate Pluto as our ninth planet.

more options

rdbulkley said

I think that this problem arose only with the most recent update to Thunderbird, which I installed yesterday or today (April 22). When I hit the Enter key Thunderbird automatically doublespaces, which is fine for text as it separates paragraphs. However, I also will sometimes type my name, address, and telephone number at the end of the message, using Enter for each to line, and I cannot find a way to make Thunderbird singlespace at that time. Word processors usually have a "line" option that allows for this (at least WordPerfect, which is still the best word processor, does). I'd much rather have Enter do only a single space; I can always hit it twice to double space between paragraphs (I've been doing that since I first used an electric rather than manual typewriter).
more options

I found the reply which said "....then Shift-Enter will create a single space." confusing. In order to obtain a single space instead of double space for a new line , it is far more easy to say , for Thunderbird 45.0 , go to Tools/Options/Composition/General and , at the bottom of the box entitled 'HTML' , uncheck the sentence "When using paragraph format , the enter key creates a new paragraph."

more options

Thanks. These random changes are frustrating. Anyone know how to get my default color back to black? The text is now blue (apparently taken from the color of my signature)

more options

Thank you!

more options

terrydennis said

I found the reply which said "....then Shift-Enter will create a single space." confusing. In order to obtain a single space instead of double space for a new line , it is far more easy to say , for Thunderbird 45.0 , go to Tools/Options/Composition/General and , at the bottom of the box entitled 'HTML' , uncheck the sentence "When using paragraph format , the enter key creates a new paragraph."

Where exactly Is Tools/Options/Composition/General? There is a Tools menu but no Options choice. I must be looking in wrong place but only see the Tools menu in the main Thunderbird 45.1.1 window...

more options

dharma52 said

terrydennis said
I found the reply which said "....then Shift-Enter will create a single space." confusing. In order to obtain a single space instead of double space for a new line , it is far more easy to say , for Thunderbird 45.0 , go to Tools/Options/Composition/General and , at the bottom of the box entitled 'HTML' , uncheck the sentence "When using paragraph format , the enter key creates a new paragraph."

Where exactly Is Tools/Options/Composition/General? There is a Tools menu but no Options choice. I must be looking in wrong place but only see the Tools menu in the main Thunderbird 45.1.1 window...

Figured it out. Version 45.1.1 have to go to Tools/Account Settings/Composition& Addressing/Global Composing Preferences/ uncheck paragraph format option. Done!

more options

Okay, I've been suffering with having 'paragraph' mode and manually switching to 'body text' so that I would have control. Sometimes I like paragraphs, but often I will put sentences on separate lines but still want them against each other.

While composing a message, there is a drop box (only active when the email body area is selected) that will either be set to 'paragraph' or 'body text' by default and also has other options.

I searched all of the settings, looking for something that would allow changing the default composition formatting. I was particularly looking for 'composition' in the setting. Giving up, I have finally come to support to look for answers. Reading them over, it sounded like plenty of people had the issue but there weren't any clear solutions. The one solution that seemed to be provided implies that it changes how 'paragraph' setting behaves.

[check box] "When using paragraph format, the enter key creates a new paragraph"

I finally gave in and tried this 'solution' thinking, "this probably makes paragraph behave like body text for me but will still look like paragraph to the one receiving it. I'll just test by emailing myself using it."

So, I unchecked it and went to write an email... and it was in 'body text'. So turning it back on and composing new, default 'paragraph'. Uncheck compose fresh again, default 'body text'.

So, that option is actually: [check box] "Composition default as paragraph. Uncheck for body text."

Now that I have clarified what setting is needed to get 'body text' as default, what is the quickest way to get it active?

1) Click 'Write' to start composing a new email.

2) In the window for writing the email, click the 'Tools' menu.

3) Select 'Options'.

4) This should have 'Composition' selected (highlighted) with 'General', 'Addressing' and 'Spelling' tabs available. If not, select 'Composition'.

5) Make sure the 'General' tab is selected.

6) In the 'HTML' section located the "When using paragraph format, the enter key creates a new paragraph" check box. To default to 'body text' clear the check box, to default to 'paragraph' check the box.

7) Click 'OK' at the bottom of the option window.

8) Close the window for writing a new email.

9) Click 'Write' to compose a fresh email, the default should be as set in step 6 by that check box. (Make sure the email body are is selected to confirm.)

Hopefully this helps with anyone else still having trouble with this and looking for a solution.

more options

TO CHANGE THE DEFAULT COMPOSITION TYPE BACK TO "BODY TEXT"

'1. Go to the main Thunderbird window and select the following from the menu bar -Tools > Options > Composition > General tab,

2. Uncheck the box that says "when using paragraph format, pressing the enter key creates a new paragraph'.

Doing this will change the default composition type from "paragraph" back to "body text", and make the enter key to provide single spacing rather than double spacing again.

more options

rdbulkley said

I think that this problem arose only with the most recent update to Thunderbird, which I installed yesterday or today (April 22). When I hit the Enter key Thunderbird automatically doublespaces, which is fine for text as it separates paragraphs. However, I also will sometimes type my name, address, and telephone number at the end of the message, using Enter for each to line, and I cannot find a way to make Thunderbird singlespace at that time. Word processors usually have a "line" option that allows for this (at least WordPerfect, which is still the best word processor, does). I'd much rather have Enter do only a single space; I can always hit it twice to double space between paragraphs (I've been doing that since I first used an electric rather than manual typewriter).

An "HTML" option DOES NOT EXIST under the tools/options/general tab. There is NO menu option "Tools" on the mail Thunderbird window - "Tools" menu option only appears if I try to start a new email message.

more options

gmeades said

TO CHANGE THE DEFAULT COMPOSITION TYPE BACK TO "BODY TEXT" '1. Go to the main Thunderbird window and select the following from the menu bar -Tools > Options > Composition > General tab, 2. Uncheck the box that says "when using paragraph format, pressing the enter key creates a new paragraph'. Doing this will change the default composition type from "paragraph" back to "body text", and make the enter key to provide single spacing rather than double spacing again.

There is NO "Tools" option on the menu bar - the only options are: "Get Messages". "Write", "Chat", "Address Book", "Tag" and "Quick Filter".

more options

Here are the direction I previously posted, but removing the story around it. The important thing, it is easiest to find and change the setting from the window for writing an email. Step by step instructions.

Esperologist said 1) Click 'Write' to start composing a new email. 2) In the window for writing the email, click the 'Tools' menu. 3) Select 'Options'. 4) This should have 'Composition' selected (highlighted) with 'General', 'Addressing' and 'Spelling' tabs available. If not, select 'Composition'. 5) Make sure the 'General' tab is selected. 6) In the 'HTML' section located the "When using paragraph format, the enter key creates a new paragraph" check box. To default to 'body text' clear the check box, to default to 'paragraph' check the box. 7) Click 'OK' at the bottom of the option window. 8) Close the window for writing a new email. 9) Click 'Write' to compose a fresh email, the default should be as set in step 6 by that check box. (Make sure the email body are is selected to confirm.)

Modified by Esperologist

more options

@F5Loar - You're on the wrong screen. You cannot make configuration changes in a new message window.

As indicated in the provided instructions, you will find the "Tools" item on the menu of the MAIN Thunderbird window. That is, the window you're looking at when you first open Thunderbird; the window that shows your inbox. THAT's the main Thunderbird window, and the window you need to be looking at to change Thunderbird configuration. You'll find the "Tools" item in the menu at the top of the page, if your menu bar is showing.

On some OS's, the menu bar is hidden by default on the Main screen. You need to show the menu bar before you can change the apps configuration. Instructions on how to do that can be found here - https://support.mozilla.org/en-US/kb/how-customize-toolbars

Modified by gmeades

more options

gmeades said

TO CHANGE THE DEFAULT COMPOSITION TYPE BACK TO "BODY TEXT" '1. Go to the main Thunderbird window and select the following from the menu bar -Tools > Options > Composition > General tab, 2. Uncheck the box that says "when using paragraph format, pressing the enter key creates a new paragraph'. Doing this will change the default composition type from "paragraph" back to "body text", and make the enter key to provide single spacing rather than double spacing again.

Okay, here are my results following your instructions:

A) Open Thunderbird Results: on the left I see all the email accounts I've linked and their folders (inbox, sent, junk, etc). I see the email list panel. I see the preview panel for reading an email without opening it.

B) From the menu bar, go to Tools -> Options -> Composition -> General Results: the menu bar has... wait... I know this one.

  • Presses the Alt key once* There it is!

Unless someone knows that pressing Alt will reveal the menu bar or has set their options to always show the menu bar, they will not see it.

@F5Loar Please look at my directions above and follow them to see if it works. Ammendment: Previously posted - twice.

Or, follow his directions but press the Alt key once to reveal the menu.

The menu that gmeades refers to has File, Edit, View, Go, Message, Tools, Help.

Modified by Esperologist

more options

Gmeades instructions are completely clear and I thank him for them.

Unfortunately , the instructions from Esperologist do not make sense. I have tried pressing the Alt key and nothing happens. I cannot see what he is trying to achieve when the instructions from Gmeades are so clear and simple. I would respectfully suggest that Esperologist sends no more emails when the problem has been clearly resolved.

more options

Expertologist wrote: Okay, here are my results following your instructions:

A) Open Thunderbird Results: on the left I see all the email accounts I've linked and their folders (inbox, sent, junk, etc). I see the email list panel. I see the preview panel for reading an email without opening it.

B) From the menu bar, go to Tools -> Options -> Composition -> General Results: the menu bar has... wait... I know this one.

   Presses the Alt key once* There it is! 

Unless someone knows that pressing Alt will reveal the menu bar or has set their options to always show the menu bar, they will not see it.

My response: First of all --> there is NO (zero) "TOOLS" option on the menu bar of the main Thunderbird window whatsoever!! I've said this a countless number of times. Second --> the ONLY place I can see "Tools" on ANY menu bar, is when I start a new message or reply to a message (The "Write" option). Third --> pressing the "Alt" key does absolutely NOTHING after following the path you mentioned. As mentioned above, these instructions make no sense to me either. FINALLY --> Programmers are IDIOTS at Mozilla for not making such a common and simple task, such as the ability to single space composition, EASY to accomplish !! NO!! They gotta make it nearly IMPOSSIBLE !! Thanks a lot! That's my story and I'm sticking to it. I appreciate the attempts to help, but the only method working for me is to uncheck that box in the HTML section. Thanks to all (except the dummies at Mozilla).

Modified by F5Loar

more options

@F5Loar - Sorry to hear you're still having troubles accessing "Tools" from your menu bar... and I can certainly understand your frustration when all of the solutions which have worked for others haven't worked for you... I'd probably be pretty steamed myself if none of the solutions that everyone else was so happy with didn't work for me... so, being a bit upset at this point is totally understandable....

Clearly, there must be something unique about how Thunderbird displays on your particular operating system that requires a different method to access the setting. I was going to do a bit of research and try to find a solution for you, but I don't see that you've ever mentioned what operating system or what version of Thunderbird you were running on your machine.

If you'd be willing to provide that information, I or someone else here, I'm sure, would be more than happy to do a bit more research and see if we can't find a solution that will work for you...

(Attached is a screen shot of the menu bar on the main Thunderbird window that everyone else is seeing, once they've taken the steps necessary to access it. The method of accessing it will vary, depending on which OS is on the machine).

Modified by gmeades

more options

My mistake, I forgot that it looks different in every seperate OS. Looking at gmeades' picture I'm a little confused as he is in Win7 Pro and I'm looking at it in Win7 Home and Pro (have two computers available to check) and mine look like what I attached. Actually, I'm going to be really annoying and break my instructions down using the images.


Image 1 - The main Thunderbird window, get the menu visible (Win7 Alt key works). Under tools, select options. Otherwise, click on the 'Write' button (also visible in the image). Image 2 - If you chose to click to compose a new email, there should be a tools menu at the top, select options there. Image 3 - However you get to this window (using the above or any other), find the option pointed to and circled. Make sure that check box is empty.


I find it funny that mine looks so much different from gmeades' - must really be an OS setting. However, if the menu isn't visible then Win7 (and WinXP) allowed pressing the Alt key to reveal it. I'm guessing that Win8 and Win10 have caused such things to be hidden away like they hide so many other things I use. (I am heavily biased against Win8 and Win10 after trying to fix/optimize several and forcing myself to use Win10 for a few months.)


Anyway, if you can find the option indicated in my third picture, that is what you are looking for. As gmeades' said, tell us your OS and maybe someone that has found the solution in it can help you out. If it is Win10, I'll even boot to my Win10 and install Thunderbird just to search for the solution myself.

  1. 1
  2. 2