Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Each time Firefox starts it asks to re-load add-ons. How can I stop this?

  • 9 replies
  • 5 have this problem
  • 57 views
  • Last reply by sheilach

more options

Every time I open Firefox, there is a tab for each add-on and I have to check a box to allow the add-on to be installed. How can these be set to load automatically?

All Replies (9)

more options

It is possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":


You will have to approve the updating one last time.

more options

You can also check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use this button to go to the current Firefox profile folder:

more options

FredMcD said

It is possible that there is a problem with the file(s) that store the extensions registry. Type about:support in the address bar and press enter. Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. New files will be created when required. After, restart Firefox. See "Corrupt extension files":

You will have to approve the updating one last time.

more options

This worked for 1 day. The file EXTENSIONS.SQLITE was not in the folder to delete and when I restarted it was not created. Any suggestions?

Thank you.

more options

Current Firefox releases only use extensions.json and possibly extensions.ini for the extensions registry. The other mentioned files were used in older Firefox versions.

What security software and possible cleanup software do you have?

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

I have the same dam problem for MONTHS now. I have been through changing my "profile", deleting those extensions.json, & ini, compatibility.ini, over & over & over again but extensions .sqlite was not there.

I have even uninstalled Firefox completely, rebooted, ran a registry cleaner, reinstalled firefox & FEBE restored my extensions & theme.

That worked for one day too & it's back to NO ADD-ONS AGAIN and a row of tabs that each have to be checked so the add-ons can AGAIN be installed & again I have to restart Firefox . Could not find my pop up blocker, it was enabled but not on the toolbar so I could not disable so I could add a image here, so I had to go to Modzilla & reinstall it AGAIN! I expect to have to go though this CRAP each time FireCRAP is started.

DAM, I discovered my add-ons are DISABLED AGAIN!!! I WILL HAVE TO RESTART FIRECRAP AGAIN!!!! I see I'm not the only frustrated user with this problem.

I did have "Advanced system care" which is suspected of causing this problem so I have uninstalled it to see if that makes any difference, so for nothing else I have done has solved this problem. One of my error messages in the "event viewer" listed "mozglue.dll as a faulting application, I would have thought that uninstalling & reinstalling Firefox would have fixed that problem, it didn't.

Modified by sheilach

more options

Once again Firefox crashed, and again when restarted I had to reinstall all the dam add-ons & restart firefox, then I had to go back AGAIN to the add-on window to enable some of them AGAIN & AGAIN RESTART FIREFOX!

There are STILL add-ons that are STILL DISABLED even after three restarts of firefox!!!! Will this EVER GET FIXED! I sure hope the developers can find what is causing this because this is a royal pain where the sun never shines!

Today (07--9-16 ) when I checked the "add-ons" it was again BLANK with a message that "You don't have any add-ons of this type installed" - as usual WRONG! The "theme" is still showing but the "default" theme is now gone.

I have had this anti virus software for some time now, this problem cropped up well after it had been running. I suspect that windows is corrupted but since I don't have the installation disk, I cannot reinstall it. My thumbnails for my videos no longer show a preview, just the icon. I guess another trip to the computer shop is called for, perhaps they can uninstall then reinstall windows.

Modified by sheilach

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

I'm in "safe mode" now with networking, SAME DAM PROBLEM!!!! "INSTALL ADD-ONS" ALL ACROSS THE TOP OF FIREFOX AGAIN AND AGAIN & AGAIN ENDLESSLY BUT WHEN I CHECKED THE "Tools" = "ADD-ONS" WINDOW, THEY WERE INSTALLED & WHEN I CLICKED ON ONE TO "INSTALL" IT YET AGAIN, THEY ALL WENT AWAY. WTF?

Now I'm back in normal mode & the "Add-ons" page once again displays "you don't have any add-ons of this type installed" AGAIN!!!!! What the "F" is going on? Now what? do I have to uninstall the "security software" & install another one? I have had this software long before this problem cropped up, I think it's from the last "update" of Firefox or another software problem or?