Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

"Remember Logins for Sites" unchecked every restart.

  • 12 replies
  • 7 have this problem
  • 3608 views
  • Last reply by mikwilfly

more options

Hello.

I believe one of the recent updates is causing the "Remember Logins for Sites" to be disabled every time I restart my computer. I'll test if it's also when I restart FF, (I restated FF on my laptop and RLFS was left on) . I noticed it because passwords were not being populated automatically (like usual). I found this option off, and turning it back on, allowed the pw fields to be auto populated again. However, after every restart, "Remember Logins for Sites" is off again. It is also happening on my wife's laptop.

Thank you team FF.

Chosen solution

hi, other users of trend micro security software have reported similar issues - the trend micro password manager that might be automatically installed as a separate application on your system might responsible for that behaviour. please uninstall it through your system control panel in case you're not using it.

Read this answer in context 👍 5

All Replies (12)

more options

Hello FFuser25, be sure you are NOT in permanent Private Browsing mode.

(if you are set firefox to "Never remember history" in privacy panel is like you are in permanent private browsing mode)

thank you

more options

Thank you ideato!

"Always use private browsing mode" is off.

more options

Any luck if you delete the prefs.js file in your profile folder ?

thanks again

more options

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

If you do not keep changes after a restart or otherwise have problems with preferences, see:

more options

ideato,

I deleted the prefs.js and other associated js files from the help doc. Restarted windows and opened FF. The "Remember Logins for Sites" is again unchecked. I checked the box, rebooted again, and it's again unchecked.

cor-el, that could be a possibility in the future. At the moment, I'd prefer to not have more software.


Thank you!

more options

Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.


You can copy files like these to the current Firefox profile folder to recover specific data.

  • bookmarks and history: places.sqlite
  • bookmark backups: JSON backups in the bookmarkbackups folder
  • SQLite files like cookies.sqlite (cookies) and formhistory.sqlite (saved form data)
  • logins.json and key3.db (decryption key) for Passwords saved in the Password Manager
  • cert8.db and possibly cert_override.txt for (intermediate) certificates stored in the Certificate Manager
  • persdict.dat for words you added to the spelling checker dictionary
  • permissions.sqlite for Permissions and possibly content-prefs.sqlite for other Site Preferences
  • sessionstore.js for open tabs and pinned tabs and tab groups

You can use this button to go to the current Firefox profile folder:

more options

Chosen Solution

hi, other users of trend micro security software have reported similar issues - the trend micro password manager that might be automatically installed as a separate application on your system might responsible for that behaviour. please uninstall it through your system control panel in case you're not using it.

more options

Philipp,

You are correct! Nice job! Removed Trend Micro pw manager and the "Remember Logins for Sites" box remains checked after restarts!

Thank you.

more options

Hi FFuser25, by mistake you mark as solved my reply :-),

please take a moment and mark philipp's reply as chosen solution to help others with the same problem. :-)

cheers :-)

more options

ideato said

Hi FFuser25, by mistake you mark as solved my reply :-), please take a moment and mark philipp's reply as chosen solution to help others with the same problem. :-) cheers :-)

Yes you are right! Didn't know how to Mark or unmark. Figured it out now! I thank you and everyone else for your help!

more options

philipp said

hi, other users of trend micro security software have reported similar issues - the trend micro password manager that might be automatically installed as a separate application on your system might responsible for that behaviour. please uninstall it through your system control panel in case you're not using it.
more options

I too was having this most frustrating problem of "unchecking" every time I closed and opened my Firefox browser and never got any reply back from Firefox. Then yesterday I read this idea "if Trend Micro password manager was installed to delete it". Well sure enough I did have it, deleted it a now all is fixed. That was the problem all along. Thank you very much, now I am good to go until the next problem is introduced by the internet world of updates and changes. Mike W.