X
Tap here to go to the mobile version of the site.

Support Forum

Not fixed: Re: MAJOR BUG: Firefox ignores the hosts file

Posted

A previous issue that was created here, https://support.mozilla.org/en-US/questions/1011327, is not resolved. Firefox's behavior is simply wrong.

The problem has to do with Firefox searching strings in the the address bar when no keyword is specified.

If I type the name of a host in my machine's host file, Firefox should behave like any other app (for example ping) and consult the hosts file.

But instead it assumes that the string is something the user wants to search for. This without the user having entered a keyword for a search.

For example if a user has the keyword g set to search google.com, then if they enter "g somestring" in the address bar, it *should* search google for somestring.

But if the user enters "somestring" alone in the address bar, Firefox should not force a search for it, completely bypassing the hosts file.

A previous issue that was created here, https://support.mozilla.org/en-US/questions/1011327, is not resolved. Firefox's behavior is simply wrong. The problem has to do with Firefox searching strings in the the address bar when no keyword is specified. If I type the name of a host in my machine's host file, Firefox should behave like any other app (for example ping) and consult the hosts file. But instead it assumes that the string is something the user wants to search for. This without the user having entered a keyword for a search. For example if a user has the keyword g set to search google.com, then if they enter "g somestring" in the address bar, it *should* search google for somestring. But if the user enters "somestring" alone in the address bar, Firefox should not force a search for it, completely bypassing the hosts file.

Chosen solution

Firefox has changed a lot since that old thread, but the current default behavior is to search first and check DNS in the background. When Firefox detects a hostname, it should display an infobar asking if you wanted to access that hostname, and then if you click through, add a preference to do that from now on for that hostname. I have attached a screen shot illustrating this.

To force Firefox to do a DNS lookup first, you can use this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste fix and pause while the list is filtered

(3) Double-click the browser.fixup.dns_first_for_single_words preference to switch it from false to true

Does that work for you?

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Version 3.13.1.11376
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.77.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • LastPass Plugin
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

More Information

jscher2000
  • Top 10 Contributor
8199 solutions 67058 answers

Chosen Solution

Firefox has changed a lot since that old thread, but the current default behavior is to search first and check DNS in the background. When Firefox detects a hostname, it should display an infobar asking if you wanted to access that hostname, and then if you click through, add a preference to do that from now on for that hostname. I have attached a screen shot illustrating this.

To force Firefox to do a DNS lookup first, you can use this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste fix and pause while the list is filtered

(3) Double-click the browser.fixup.dns_first_for_single_words preference to switch it from false to true

Does that work for you?

Firefox has changed a lot since that old thread, but the current default behavior is to search first and check DNS in the background. When Firefox detects a hostname, it should display an infobar asking if you wanted to access that hostname, and then if you click through, add a preference to do that from now on for that hostname. I have attached a screen shot illustrating this. To force Firefox to do a DNS lookup first, you can use this setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''fix''' and pause while the list is filtered (3) Double-click the '''browser.fixup.dns_first_for_single_words''' preference to switch it from false to true Does that work for you?

Question owner

Thanks that is the solution! Works perfectly now!

Thanks that is the solution! Works perfectly now!