X
Tap here to go to the mobile version of the site.

Support Forum

Google constantly blocking access from my Thunderbird Account

Posted

Every time I try to send an email, Google rejects my password (which is done by Last Pass and is way too complex for anyone to memorize and type in without errors; especially since they don't let you see what you're typing.), and the Google message blocks my screen with a full screen invitation to sign in with Google, one account bla, bla, bla, sign in again and again , for each and every single email. Of course, the real message is that you don't have to do that if you just give your soul to Google. They sometimes don't even leave room for me to click away. My password is good, but I changed it, anyway, thinking it would appease them, somehow; ironically, I changed it to a much less secure one, just so that I could remember and be able to type it in for every single email I write, because they won't let you copy and paste at all. If you've seen the kind of passwords LastPass creates, then you know how insane that is. This is ridiculous. What's the purpose of Thunderbird, if Google, the largest provider, is just going to herd us all into their stupidly crafted, one size fits nobody website, kicking and screaming! Their only suggestion to resolve the issue was to use their site or click to use "less secure" apps to access our mail. I checked the site and I had had that box checked for some time already. Obviously it really means nothing. I just wanna know whether Thunderbird is going to resolve this issue, or are we all, eventually, going to have to just pull the plug on "The Thunderbird Project?

Every time I try to send an email, Google rejects my password (which is done by Last Pass and is way too complex for anyone to memorize and type in without errors; especially since they don't let you see what you're typing.), and the Google message blocks my screen with a full screen invitation to sign in with Google, one account bla, bla, bla, sign in again and again , for each and every single email. Of course, the real message is that you don't have to do that if you just give your soul to Google. They sometimes don't even leave room for me to click away. My password is good, but I changed it, anyway, thinking it would appease them, somehow; ironically, I changed it to a much less secure one, just so that I could remember and be able to type it in for every single email I write, because they won't let you copy and paste at all. If you've seen the kind of passwords LastPass creates, then you know how insane that is. This is ridiculous. What's the purpose of Thunderbird, if Google, the largest provider, is just going to herd us all into their stupidly crafted, one size fits nobody website, kicking and screaming! Their only suggestion to resolve the issue was to use their site or click to use "less secure" apps to access our mail. I checked the site and I had had that box checked for some time already. Obviously it really means nothing. I just wanna know whether Thunderbird is going to resolve this issue, or are we all, eventually, going to have to just pull the plug on "The Thunderbird Project?
Attached screenshots

Chosen solution

I was actually looking to see what your outgoing server settings were set to use as the issue was with sending. I can understand how you feel about Imap, it provides a means of getting around some peoples' need to see the server, but it is not for everyone.

I would agree with Matt. Change the Outgoing server (SMTP) Authentication method to use OAuth2. Gmail will ask you to verify by logging on, but it should then put a special OAuth password in the password manager.... I'm assuming you have selected checkbox to remember pasword. 'Tools' > Options' > 'security' > 'Passwords' tab clickon 'saved Password' clickon 'Show passwords' You will then see both your actual password and the generated OAuth password.

Sometimes, I get the impression that gmail is a deliberately causing constant needs to login because they want to make you use a different process, so suggest you try changing the Authentication Method.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.110 Safari/537.36

More Information

amanchesterman 189 solutions 994 answers

I can't think why you are having this problem because I have a Gmail account which works perfectly well with Thunderbird. Thunderbird is designed to cope with Gmail's peculiarities: https://support.mozilla.org/en-US/kb/thunderbird-and-gmail and Gmail explicitly supports Thunderbird as an email client: https://support.google.com/mail/troubleshooter/1668960?hl=en&ref_topic=3398031 Have you set Gmail up to work as an IMAP server, as explained in the second of those links? Are all the server and security settings correct in Thunderbird? Have you tried the steps in the Gmail troubleshooter? : https://support.google.com/mail/topic/3397501?hl=en&ref_topic=3398031 There are several things to try listed under 'can't sign in to my email app'.

I can't think why you are having this problem because I have a Gmail account which works perfectly well with Thunderbird. Thunderbird is designed to cope with Gmail's peculiarities: https://support.mozilla.org/en-US/kb/thunderbird-and-gmail and Gmail explicitly supports Thunderbird as an email client: https://support.google.com/mail/troubleshooter/1668960?hl=en&ref_topic=3398031 Have you set Gmail up to work as an IMAP server, as explained in the second of those links? Are all the server and security settings correct in Thunderbird? Have you tried the steps in the Gmail troubleshooter? : https://support.google.com/mail/topic/3397501?hl=en&ref_topic=3398031 There are several things to try listed under 'can't sign in to my email app'.

Helpful Reply

I've had a gmail account since, I guess, about 2006 or so. It's the only account I use, and I started having this problem just over the last couples weeks, give or take. I read what Google had to say, and their position is that Thunderbird and Outlook are both inadequate where security is concerned. Therefore, everyone should come to them for all their email needs. They're very clear about that.

I've had a gmail account since, I guess, about 2006 or so. It's the only account I use, and I started having this problem just over the last couples weeks, give or take. I read what Google had to say, and their position is that Thunderbird and Outlook are both inadequate where security is concerned. Therefore, everyone should come to them for all their email needs. They're very clear about that.
Toad-Hall
  • Top 10 Contributor
1769 solutions 11895 answers

re : I read what Google had to say, and their position is that Thunderbird and Outlook are both inadequate where security is concerned. Therefore, everyone should come to them for all their email needs. They're very clear about that.

Google would say that especially if they are trying to get people to only use their webmail via a browser. They are a business and need to generate income.

Google had security problems and came up with suitable methods to deal with it. But it depends on how you access google as to whether it needs a more secure method. If people access google using phones then they need to use a more secure method - 2 step authentication which then means you need to use a application specfic password in Thunderbird instead. But you would only set this up the once. The 'Less secure' is not less secure if you only access via Thunderbird on your computer. They are using what I would call a scare mongering term of phrase.

Google use OAuth2 and Thunderbird has already implemented OAuth2, but are you using it? IMAP mail accounts can use OAuth2 for sending and receiving. POP mail accounts can only use to send.

It would be useful to know what server settings you are using. Please post this info: In thunderbird Help > Troubleshooting Information click on 'Copy text to clipboard' In this forum question, right click in a 'Post a Reply' text box and select ' Paste. You can edit/remove all the info on fonts and printers, but nothing else.

re : '' I read what Google had to say, and their position is that Thunderbird and Outlook are both inadequate where security is concerned. Therefore, everyone should come to them for all their email needs. They're very clear about that.'' Google would say that especially if they are trying to get people to only use their webmail via a browser. They are a business and need to generate income. Google had security problems and came up with suitable methods to deal with it. But it depends on how you access google as to whether it needs a more secure method. If people access google using phones then they need to use a more secure method - 2 step authentication which then means you need to use a application specfic password in Thunderbird instead. But you would only set this up the once. The 'Less secure' is not less secure if you only access via Thunderbird on your computer. They are using what I would call a scare mongering term of phrase. Google use OAuth2 and Thunderbird has already implemented OAuth2, but are you using it? IMAP mail accounts can use OAuth2 for sending and receiving. POP mail accounts can only use to send. It would be useful to know what server settings you are using. Please post this info: In thunderbird Help > Troubleshooting Information click on 'Copy text to clipboard' In this forum question, right click in a 'Post a Reply' text box and select ' Paste. You can edit/remove all the info on fonts and printers, but nothing else.

Question owner

Thanks for your reply. I've had Thunderbird for many years, and I've always accessed gmail through Thunderbird, never a variation in that. I even have the same address. You asked about server settings, and I can tell you that I don't use Imap, because of the fact that it puts all those folders in my Thunderbird that are useless to me, as I simply use Thunderbird to send and receive emails, with occasional attachments. As I said before, I've never had a problem like this, and I don't normally use IMAP. When I delete something in Thunderbird, I do so with the full knowledge that, if I should make a mistake, and happen to want that at a later date, I can simply go to Gmail and look at the copy there. My experience with IMAP, however, is that, if I delete something in Thunderbird, using IMAP, it deletes it in all places, and it's completely gone. I don't like that. So I don't use IMAP. However, if that will restore my ability to use gmail, I'll just have to bite the bullet. I'm receiving all my Gmail without fail. However, when it comes to "sending" email with Thunderbird, I can't do it without that obnoxious full-screen popup taking over the screen and telling me to sign in with Gmail, that it's more "convenient" to do so. It does this for every single email I send. As I said, receiving is no problem at all, and I'm never asked to type in my password all over again, like I am when "sending" emails. You do them one at a time, carefully typing out complicated passwords for each and every email sent. That is crazy. Google cannot want that. It promotes bad passwords, as I have already had to stop using the passwords suggested by "Last Pass" in favor of simple ones that I can remember. Here is the server info form my Thunderbird account: Server Type: POP Mail Server Server Name: pop.gmail.com port: 995 user name: my email address connection security: SSL/TLS Authentication method: Normal Password At Gmail, I've got POP is enabled, disable IMAP Those are the same Gmail settings that I've had for a long, long time, without issue.

I'd sure appreciate any help that someone might be able to provide. As I said, I've used Thunderbird and Gmail together for many years, mostly problem free. I loathe the clutter of the Gmail site. I translate a few foreign languages, as a hobby, so I cannot stand the fact that an organization that offers so many translation services would have so little to offer in that vein on their own email site. They lack customization and the bright screens, usually the brightest white imaginable. I just can't take the glare. And I don't like having to go to a website to get mail I might have missed. If I use Thunderbird, any mail I might have missed earlier stays right there in the inbox. Very reliable, and very simple. And my small brain likes simple. :-)

Thanks for your reply. I've had Thunderbird for many years, and I've always accessed gmail through Thunderbird, never a variation in that. I even have the same address. You asked about server settings, and I can tell you that I don't use Imap, because of the fact that it puts all those folders in my Thunderbird that are useless to me, as I simply use Thunderbird to send and receive emails, with occasional attachments. As I said before, I've never had a problem like this, and I don't normally use IMAP. When I delete something in Thunderbird, I do so with the full knowledge that, if I should make a mistake, and happen to want that at a later date, I can simply go to Gmail and look at the copy there. My experience with IMAP, however, is that, if I delete something in Thunderbird, using IMAP, it deletes it in all places, and it's completely gone. I don't like that. So I don't use IMAP. However, if that will restore my ability to use gmail, I'll just have to bite the bullet. I'm receiving all my Gmail without fail. However, when it comes to "sending" email with Thunderbird, I can't do it without that obnoxious full-screen popup taking over the screen and telling me to sign in with Gmail, that it's more "convenient" to do so. It does this for every single email I send. As I said, receiving is no problem at all, and I'm never asked to type in my password all over again, like I am when "sending" emails. You do them one at a time, carefully typing out complicated passwords for each and every email sent. That is crazy. Google cannot want that. It promotes bad passwords, as I have already had to stop using the passwords suggested by "Last Pass" in favor of simple ones that I can remember. Here is the server info form my Thunderbird account: Server Type: POP Mail Server Server Name: pop.gmail.com port: 995 user name: my email address connection security: SSL/TLS Authentication method: Normal Password At Gmail, I've got POP is enabled, disable IMAP Those are the same Gmail settings that I've had for a long, long time, without issue. I'd sure appreciate any help that someone might be able to provide. As I said, I've used Thunderbird and Gmail together for many years, mostly problem free. I loathe the clutter of the Gmail site. I translate a few foreign languages, as a hobby, so I cannot stand the fact that an organization that offers so many translation services would have so little to offer in that vein on their own email site. They lack customization and the bright screens, usually the brightest white imaginable. I just can't take the glare. And I don't like having to go to a website to get mail I might have missed. If I use Thunderbird, any mail I might have missed earlier stays right there in the inbox. Very reliable, and very simple. And my small brain likes simple. :-)
Matt
  • Top 10 Contributor
  • Moderator
3252 solutions 22416 answers

use oAuth2.0 for SMTP and drop lastpass if it still does not work is my suggestion.

Password managers can introduce just as many bug as any other software.

use oAuth2.0 for SMTP and drop lastpass if it still does not work is my suggestion. Password managers can introduce just as many bug as any other software.
Toad-Hall
  • Top 10 Contributor
1769 solutions 11895 answers

Chosen Solution

I was actually looking to see what your outgoing server settings were set to use as the issue was with sending. I can understand how you feel about Imap, it provides a means of getting around some peoples' need to see the server, but it is not for everyone.

I would agree with Matt. Change the Outgoing server (SMTP) Authentication method to use OAuth2. Gmail will ask you to verify by logging on, but it should then put a special OAuth password in the password manager.... I'm assuming you have selected checkbox to remember pasword. 'Tools' > Options' > 'security' > 'Passwords' tab clickon 'saved Password' clickon 'Show passwords' You will then see both your actual password and the generated OAuth password.

Sometimes, I get the impression that gmail is a deliberately causing constant needs to login because they want to make you use a different process, so suggest you try changing the Authentication Method.

I was actually looking to see what your outgoing server settings were set to use as the issue was with sending. I can understand how you feel about Imap, it provides a means of getting around some peoples' need to see the server, but it is not for everyone. I would agree with Matt. Change the Outgoing server (SMTP) Authentication method to use OAuth2. Gmail will ask you to verify by logging on, but it should then put a special OAuth password in the password manager.... I'm assuming you have selected checkbox to remember pasword. 'Tools' > Options' > 'security' > 'Passwords' tab clickon 'saved Password' clickon 'Show passwords' You will then see both your actual password and the generated OAuth password. Sometimes, I get the impression that gmail is a deliberately causing constant needs to login because they want to make you use a different process, so suggest you try changing the Authentication Method.

Question owner

I just bent over and accepted the might IMAP. I've always used POP, since it just worked and did everything I needed without a huge clutter of folders that irritate me to no end. I know they would excite tech types to no end. But I just want to send and receive emails. How it's done, as we used to say in the navy, is above my pay grade. Interesting note: the last comment about my actual password and then another one made up by the system, i.e. Oauth2, or whatever...That's what I saw in my server's settings, instead of " normal password, " right after I disabled POP and enabled IMAP. I may just go back and re-enable POP and disable IMAP later on, just to see if it's that simple. I couldn't believe that Google called my home phone, and even asked a security question that I know I never selected when I set them up. They did all this even after my new password (at their suggestion) and forcing me to sign in all over again. They also asked me to allow Thunderbird to manage my email account. I did so. But they then rejected my sent email again. That was when I just switched to IMAP. Even then, it didn't work right away. I'd say...about 30 minutes later, the new IMAP server setttings kicked in and everything started working again. Thanks for your help, guys. I don't know why they employ so many geniuses who care little or nothing about how difficult their pages are to read and navigate for those over 35, many of whom, probably wear reading glasses. No fonts or page sizes seem to be adjustable without paying some sort of price in terms of things going off the screen. And they use a shade of white so intensely bright that even the deity might judge them to be way over the top. :-) Anyway, thanks for your insights. I know how trying to solve problems through email can be extremely difficult, especially when the guy on the other side of the server is a lot more angry than he is technically-minded. Have a good day. :-)

I just bent over and accepted the might IMAP. I've always used POP, since it just worked and did everything I needed without a huge clutter of folders that irritate me to no end. I know they would excite tech types to no end. But I just want to send and receive emails. How it's done, as we used to say in the navy, is above my pay grade. Interesting note: the last comment about my actual password and then another one made up by the system, i.e. Oauth2, or whatever...That's what I saw in my server's settings, instead of " normal password, " right after I disabled POP and enabled IMAP. I may just go back and re-enable POP and disable IMAP later on, just to see if it's that simple. I couldn't believe that Google called my home phone, and even asked a security question that I know I never selected when I set them up. They did all this even after my new password (at their suggestion) and forcing me to sign in all over again. They also asked me to allow Thunderbird to manage my email account. I did so. But they then rejected my sent email again. That was when I just switched to IMAP. Even then, it didn't work right away. I'd say...about 30 minutes later, the new IMAP server setttings kicked in and everything started working again. Thanks for your help, guys. I don't know why they employ so many geniuses who care little or nothing about how difficult their pages are to read and navigate for those over 35, many of whom, probably wear reading glasses. No fonts or page sizes seem to be adjustable without paying some sort of price in terms of things going off the screen. And they use a shade of white so intensely bright that even the deity might judge them to be way over the top. :-) Anyway, thanks for your insights. I know how trying to solve problems through email can be extremely difficult, especially when the guy on the other side of the server is a lot more angry than he is technically-minded. Have a good day. :-)