Search Support

Inactive tabs have white text, can't change...?

  • 7 replies
  • 1 has this problem
  • 374 views
  • Last reply by Cormy1

more options

Not sure if related to these posts but I'll link anyway since they seem relevant https://bugzilla.mozilla.org/show_bug.cgi?id=940393 https://support.mozilla.org/en-US/questions/997178?fpa=1

So here's the problem, my inactive tabs have a terrible text colour and I can't figure out how to change that. Strangely enough, if Firefox is my inactive window, the text goes to black and is perfectly readable.

Attached screenshots

Chosen solution

So I decided to try something different today and went over to a Windows 7 computer and copied its registry for HKCU\Control Panel\Colors, HKCU\Control Panel\Desktop\Colors and HKCU\Software\Microsoft\Windows\DWM I don't know what exactly was wrong, but clearly it wasn't anything that any of the Windows 8.1 themes changed since switching them didn't solve it. It is solved now, had some weird registry issue with the colours I guess and Windows 7 colour registry is compatible with Windows 8.

Read this answer in context 👍 0

All Replies (7)

more options

This issue is probably related to a theme or addon that you have installed on Firefox. To see if this is the case, try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

I have no style add-ons, am running the default theme and nothing has changed from booting it in safe mode. I'm a minimalist, I can assure you there is no unnecessary bloatware and extras that might be causing this, it's definitely either a base Firefox issue or a base Windows colours issue. Speaking of extras... When are we getting rid of Pocket integration and Hello?

What's the next troubleshooting step?

more options

I can assure you that this is not the default Firefox behavior. I suggest trying to reset your Windows color theme.

As for your additional question regarding the Pocket and Firefox Hello integration, there are no plans to remove the integration. Why do you want Pocket and Firefox Hello removed?

Modified by Wesley Branton

more options

Resetting my Windows Color Theme didn't help either. I will never use Pocket or Hello so to me it's just bloatware. Mozilla Firefox is a web browser and that's what I use it for, I have no intention of using it for Cloud storage or chatting of any kind. Their functions are very niche, I strongly doubt they would be used much, especially considering the number of people that use other browsers.

more options

This issue could be the result of an infection or unwanted program installed on your system. Try scanning for malware on your system. View this Mozilla support article for more details:


In regards to your question about Pocket and Hello, both of these features are compatible with other browsers and other devices. Nevertheless, Mozilla uses statistical data submitted from their users to determine which features are used. If Mozilla finds that users are not using the feature, then they will most likely remove it at that point.

more options
more options

Chosen Solution

So I decided to try something different today and went over to a Windows 7 computer and copied its registry for HKCU\Control Panel\Colors, HKCU\Control Panel\Desktop\Colors and HKCU\Software\Microsoft\Windows\DWM I don't know what exactly was wrong, but clearly it wasn't anything that any of the Windows 8.1 themes changed since switching them didn't solve it. It is solved now, had some weird registry issue with the colours I guess and Windows 7 colour registry is compatible with Windows 8.