X
Tap here to go to the mobile version of the site.

Support Forum

History dropdown auto-selects the first item in list

Posted

When I click the history drop-down button to the right of the URL/Search field the list appears briefly and then the first item in the list is automatically selected taking me to that web site. This does not leave me enough time to select the site I want from the list.

I am using Firefox 45.0.

Steps: 1) Open new tab 2) Click history dropdown button 3) First entry populates the URL field with the first item in the list and the browser jumps to that page.


When I click the history drop-down button to the right of the URL/Search field the list appears briefly and then the first item in the list is automatically selected taking me to that web site. This does not leave me enough time to select the site I want from the list. I am using Firefox 45.0. Steps: 1) Open new tab 2) Click history dropdown button 3) First entry populates the URL field with the first item in the list and the browser jumps to that page.

Chosen solution

Hmm, maybe it's a glitch with the Fastest Search extension? Its page on the Add-ons site says:

Instant Search (disabled by default - turn it on in Options Panel or press Ctrl-Alt-I) in both LocationBar and SearchBar - As you type in LocationBar, top match in history/bookmark and/or Google (or your chosen engine) search is instantly loaded.

The FAQ has steps to adjust that feature: http://mingyi.org/FastestSearch/faq.html

Does that make any difference?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • ETProPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.73.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Shockwave Flash 20.0 r0
  • 5.1.41105.0
  • VLC media player Web Plugin

Application

  • Firefox 45.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
  • Support URL: https://support.mozilla.org/1/firefox/45.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.7.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Fastest Search 3.363 (fastestsearch@mingyi.org)
  • Firebug 2.0.14 (firebug@software.joehewitt.com)
  • Firefox Hello Beta 0.1 (loop@mozilla.org)
  • HttpRequester 2.1.1-signed ({ea4637dc-e014-4c17-9c2c-879322d23268})
  • TiddlyFox extension for Firefox 1.0alpha18.1-signed (tiddlyfox@tiddlywiki.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon(TM) R7 250
  • adapterDescription2:
  • adapterDeviceID: 0x6610
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 21201028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7601.19061
  • driverDate: 7-6-2015
  • driverDate2:
  • driverVersion: 15.200.1055.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon(TM) R7 250 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8773 solutions 71719 answers

Chosen Solution

Hmm, maybe it's a glitch with the Fastest Search extension? Its page on the Add-ons site says:

Instant Search (disabled by default - turn it on in Options Panel or press Ctrl-Alt-I) in both LocationBar and SearchBar - As you type in LocationBar, top match in history/bookmark and/or Google (or your chosen engine) search is instantly loaded.

The FAQ has steps to adjust that feature: http://mingyi.org/FastestSearch/faq.html

Does that make any difference?

Hmm, maybe it's a glitch with the Fastest Search extension? Its page on the Add-ons site says: <blockquote>Instant Search (disabled by default - turn it on in Options Panel or press Ctrl-Alt-I) in both LocationBar and SearchBar - As you type in LocationBar, top match in history/bookmark and/or Google (or your chosen engine) search is instantly loaded.</blockquote> The FAQ has steps to adjust that feature: http://mingyi.org/FastestSearch/faq.html Does that make any difference?