Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not Log me off of websites.

  • 4 replies
  • 2 have this problem
  • 19 views
  • Last reply by jcardana

more options

When I close FireFox and then re-open... I'm still logged into various websites and forums..

Privacy Tab: History Clear History when firefox closes... Active Logins... CHECKED

Security Tab Logins... Remember Logins for sites... UNCHECKED.

Chosen solution

Most sites use cookies to keep you logged in. In the settings for "Clear history when Firefox closes" the term Active Logins does not clear the cookies used to keep your session open. Unfortunately, Firefox can't distinguish between cookies that store website preferences and those used to identify an active session.

If you do not want website cookies to persist beyond your current session, you can change the cookie permission of those sites from "Allow" to "Allow for Session". Firefox will still store the cookies in the session history file (the file that allows you to restore tabs from your previous session) unless you change a hidden setting.

Are you interested in the details of those changes or would you prefer to clear all cookies at shutdown?

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Most sites use cookies to keep you logged in. In the settings for "Clear history when Firefox closes" the term Active Logins does not clear the cookies used to keep your session open. Unfortunately, Firefox can't distinguish between cookies that store website preferences and those used to identify an active session.

If you do not want website cookies to persist beyond your current session, you can change the cookie permission of those sites from "Allow" to "Allow for Session". Firefox will still store the cookies in the session history file (the file that allows you to restore tabs from your previous session) unless you change a hidden setting.

Are you interested in the details of those changes or would you prefer to clear all cookies at shutdown?

more options

I changed the cookie thing from "When the expire" to "I close Firefox". I re-checked "Remember Logins for sites" so when I go back, it autofills my UN&PW. Then I Un-checked "Site Preferences" so when I go back to a site, it remembers my zoom level.

Seems to be working how I expect. Thank you

more options

That sounds good. Do you have a master password set? That would keep others from benefiting from Firefox auto-filling your username and password if they happen to gain access to your computer. More info: Use a Primary Password to protect stored logins and passwords.

more options

jscher2000 said

Do you have a master password set?
Yes