X
Tap here to go to the mobile version of the site.

Support Forum

can't view firefox too small

Posted

Firefox was too large for my monitor screen. So, I typed about:config in the address bar. Then I went to layout.css.devPixelsPerPx. I then made the terrible mistake of putting 2.0 in the box and the text went so small I can't do a thing in Firefox. I can't see anything on the screen even with a magnify glass. I am using my laptop right now. The problem is on my desktop. Vista Home premium 32 bit. I just downloaded Firefox yesterday. I did have Chrome on. They stopped supporting Vista so I thought I would use Mozilla. Remember, I can't see anything on the screen to be able to fix it. Help ,someone please!!

Firefox was too large for my monitor screen. So, I typed about:config in the address bar. Then I went to layout.css.devPixelsPerPx. I then made the terrible mistake of putting 2.0 in the box and the text went so small I can't do a thing in Firefox. I can't see anything on the screen even with a magnify glass. I am using my laptop right now. The problem is on my desktop. Vista Home premium 32 bit. I just downloaded Firefox yesterday. I did have Chrome on. They stopped supporting Vista so I thought I would use Mozilla. Remember, I can't see anything on the screen to be able to fix it. Help ,someone please!!

Chosen solution

This time it's the one on the left:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • 5.1.30514.0
  • NPWLPG
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

Hmm, I think 2.0 would be okay, since that means 200%. Maybe you entered 0.2, or 20%?

Assuming you still have the about:config page open, can you try zooming it by holding down the Ctrl key and tapping + numerous times? This may make it barely readable enough to right-click layout.css.devPixelsPerPx and choose the last item on the context menu, which is Reset (or you can right-click and tap the r key to activate that item).

Does that work?

Hmm, I think 2.0 would be okay, since that means 200%. Maybe you entered 0.2, or 20%? Assuming you still have the about:config page open, can you try zooming it by holding down the Ctrl key and tapping + numerous times? This may make it barely readable enough to right-click '''layout.css.devPixelsPerPx''' and choose the last item on the context menu, which is Reset (or you can right-click and tap the r key to activate that item). Does that work?
jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

If that doesn't work, and you haven't invested too much time in customizing Firefox yet, you could use the Refresh feature to reset your settings back to their defaults.

From inside Firefox, you'll use the Help menu > Restart with Add-ons disabled. To do that "blind" tap the Alt key on the keyboard, then H to activate the Help menu, then R to activate the restart.

A dialog should appear asking you to confirm. Click the Restart button or press the Enter key to activate it.

A small dialog should appear, hopefully in a more normal size. Click "Refresh" and approve the changes listed in the next dialog to proceed.

Does that work?

If that doesn't work, and you haven't invested too much time in customizing Firefox yet, you could use the Refresh feature to reset your settings back to their defaults. From inside Firefox, you'll use the Help menu > Restart with Add-ons disabled. To do that "blind" tap the Alt key on the keyboard, then H to activate the Help menu, then R to activate the restart. A dialog should appear asking you to confirm. Click the Restart button or press the Enter key to activate it. A small dialog should appear, hopefully in a more normal size. Click "Refresh" and approve the changes listed in the next dialog to proceed. Does that work?

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
17873 solutions 161723 answers

You can also go to the Firefox profile folder and edit the prefs.js file and change the value of layout.css.devPixelsPerPx to 1.0 or -1.0

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

"AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder.

Windows hides some file extensions by default. Among them .html and .ini and .js and .txt and you may only see a file name without file extension. You can check the file extension (type) in the properties of the file in Windows Explorer via the right-click context menu.

You can also go to the Firefox profile folder and edit the prefs.js file and change the value of layout.css.devPixelsPerPx to 1.0 or -1.0 *C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\Profiles\&lt;profile&gt;\ "AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder. *http://kb.mozillazine.org/Show_hidden_files_and_folders Windows hides some file extensions by default. Among them .html and .ini and .js and .txt and you may only see a file name without file extension. You can check the file extension (type) in the properties of the file in Windows Explorer via the right-click context menu.

Question owner

I'm sorry everyone that is trying to help, but remember, I can't see anything on the firefox screen but a line the size of a pencil mark. I have tried the ctrl-+ thing to no avail. I cant see to do anything with the toolbox. It just isnt there. Nothing will even highlight when I try hi hovering. The about:config page is not open and I can't find the "layout...." menu. I can't see what I am typing now, so I hope you can read this. Thank you so much for trying to help. I don't know what to do. I am not very good at this tech stuff, but i will try to do anything suggested. Thanks again

I'm sorry everyone that is trying to help, but remember, I can't see anything on the firefox screen but a line the size of a pencil mark. I have tried the ctrl-+ thing to no avail. I cant see to do anything with the toolbox. It just isnt there. Nothing will even highlight when I try hi hovering. The about:config page is not open and I can't find the "layout...." menu. I can't see what I am typing now, so I hope you can read this. Thank you so much for trying to help. I don't know what to do. I am not very good at this tech stuff, but i will try to do anything suggested. Thanks again
jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

Close Firefox using Alt+F4 or if Vista had this, right-click its icon on the Windows Taskbar and choose Close All Windows.

Next, select and copy (Ctrl+c) the following:

firefox.exe -P

Click the start menu icon then paste into the search box and press Enter to run that. Firefox should open its Profile Manager.

Don't delete anything here!

Click the Create Profile button, assign a name like Feb2016, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

You should be up and running.

Do you need anything from the original profile? Bookmarks, passwords, anything? If not, you're good to go.

Close Firefox using Alt+F4 or if Vista had this, right-click its icon on the Windows Taskbar and choose Close All Windows. Next, select and copy (Ctrl+c) the following: firefox.exe -P Click the start menu icon then paste into the search box and press Enter to run that. Firefox should open its Profile Manager. ''Don't delete anything here!'' Click the Create Profile button, assign a name like Feb2016, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile. You should be up and running. Do you need anything from the original profile? Bookmarks, passwords, anything? If not, you're good to go.

Question owner

Hi. I will try this. I do wish I wouldn't lose my bookmarks though. Need them pretty badly.

Hi. I will try this. I do wish I wouldn't lose my bookmarks though. Need them pretty badly.

Question owner

Jsher, the alt f4 only gives the option of shutting down. No other option

Jsher, the alt f4 only gives the option of shutting down. No other option
jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

bil75 said

Jsher, the alt f4 only gives the option of shutting down. No other option

Shutting down Windows? Make sure Firefox is the active application when you press that key combination.

bil75 said

I do wish I wouldn't lose my bookmarks though. Need them pretty badly.

Okay, we'll do that. Again, make sure not to delete your original profile when creating the new one.

''bil75 [[#answer-844842|said]]'' <blockquote> Jsher, the alt f4 only gives the option of shutting down. No other option </blockquote> Shutting down Windows? Make sure Firefox is the active application when you press that key combination. ''bil75 [[#answer-844839|said]]'' <blockquote> I do wish I wouldn't lose my bookmarks though. Need them pretty badly. </blockquote> Okay, we'll do that. Again, make sure not to delete your original profile when creating the new one.

Question owner

I wish the about:config would come up with just the "layout..." list. Then maybe I could find it and scroll down to the bottom and try and see 'reset' like you suggesteed. But I can't find the 'layout' menu at all. It just has a bunch of options to choose from to get to 'layout'

I wish the about:config would come up with just the "layout..." list. Then maybe I could find it and scroll down to the bottom and try and see 'reset' like you suggesteed. But I can't find the 'layout' menu at all. It just has a bunch of options to choose from to get to 'layout'
jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

bil75 said

I wish the about:config would come up with just the "layout..." list. Then maybe I could find it and scroll down to the bottom and try and see 'reset' like you suggesteed.

If you cannot read right-click context menus because they are too small, then you won't be able to use that method.

Also, the about:config page does have a search box at the top and you could use that to filter the list, but it's probably too small to click into or see what you're typing with your current settings.

''bil75 [[#answer-844844|said]]'' <blockquote> I wish the about:config would come up with just the "layout..." list. Then maybe I could find it and scroll down to the bottom and try and see 'reset' like you suggesteed.</blockquote> If you cannot read right-click context menus because they are too small, then you won't be able to use that method. Also, the about:config page does have a search box at the top and you could use that to filter the list, but it's probably too small to click into or see what you're typing with your current settings.

Question owner

I can't use alt f4. Just shuts down windows. Is there some way or some option on the mozilla icon when I right click and choose properties? Is there some way to reset it?

I can't use alt f4. Just shuts down windows. Is there some way or some option on the mozilla icon when I right click and choose properties? Is there some way to reset it?
jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

Helpful Reply

Well, is Firefox closed now? The point of using Alt+F4 is it closes the active application. If Firefox is now completely closed, you can move on to the next step.

If you want to try a refresh:

Hold down the Shift key while starting up Firefox again.

A small dialog should appear, hopefully in a more normal size. Click "Refresh" and approve the changes listed in the next dialog to proceed.

Does that work?

Note: if you just get a new Firefox window instead of the Safe Mode/Refresh dialog, try this sequence of keys to completely exit Firefox while that new window is active (press and release in this order):

Alt f x
Well, is Firefox closed now? The point of using Alt+F4 is it closes the active application. If Firefox is now completely closed, you can move on to the next step. ''If you want to try a refresh:'' Hold down the Shift key while starting up Firefox again. A small dialog should appear, hopefully in a more normal size. Click "Refresh" and approve the changes listed in the next dialog to proceed. Does that work? Note: if you just get a new Firefox window instead of the Safe Mode/Refresh dialog, try this sequence of keys to completely exit Firefox while that new window is active (press and release in this order): Alt f x

Question owner

I held down the shift key and clicked to open firefox. A tiny box opens with two little boxes on the bottom right. I can't rread what the boxes say. Could you tell me which box to choose for the reset?

I held down the shift key and clicked to open firefox. A tiny box opens with two little boxes on the bottom right. I can't rread what the boxes say. Could you tell me which box to choose for the reset?
jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

Helpful Reply

According to our help article on Safe Mode, it's the one on the right:

According to our help article on Safe Mode, it's the one on the right: <img src="https://support.cdn.mozilla.net/media/uploads/gallery/images/2014-12-18-07-22-44-971830.png">

Question owner

OK When the litle box came up with the two tiny boxes I clicked on the one on the right. Then another little box comes up with the title 'Refresh Firefox' and has two more boxes on the right bottom that , I guess , has two more choices. Which on of these do I click on? Gees

OK When the litle box came up with the two tiny boxes I clicked on the one on the right. Then another little box comes up with the title 'Refresh Firefox' and has two more boxes on the right bottom that , I guess , has two more choices. Which on of these do I click on? Gees
jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

Chosen Solution

This time it's the one on the left:

This time it's the one on the left: <img src="https://support.cdn.mozilla.net/media/uploads/images/2016-02-15-08-40-45-9fcf9a.png">

Question owner

jscher!! You did it!!! I am so happy!! It came up with my favorites and everything that I had put in it and it is regular size now. The only thing I have trouble with , (and that's how I got into this mess) is that the whole Mozilla page is just too large. It covers my whole screen and I have to scroll to see all of the page. Oh well. Thank you sooooooo much. You made my day a happy one!!

jscher!! You did it!!! I am so happy!! It came up with my favorites and everything that I had put in it and it is regular size now. The only thing I have trouble with , (and that's how I got into this mess) is that the whole Mozilla page is just too large. It covers my whole screen and I have to scroll to see all of the page. Oh well. Thank you sooooooo much. You made my day a happy one!!
jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

Maybe instead of using the about:config change, you could use one of these extensions to reduce the default zoom level globally (this is an old list, so I don't know for sure that these still work):

After setting your global or default zoom level, you can still fine-tune the zoom on individual sites using Firefox's standard zoom feature (keyboard shortcut or mouse wheel).

Maybe instead of using the about:config change, you could use one of these extensions to reduce the default zoom level globally (this is an old list, so I don't know for sure that these still work): * [https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ Default FullZoom Level] * [https://addons.mozilla.org/firefox/addon/zoom-page/ Zoom Page] (includes "fit to window" feature) * [https://addons.mozilla.org/firefox/addon/nosquint/ NoSquint] After setting your global or default zoom level, you can still fine-tune the zoom on individual sites using Firefox's standard zoom feature (keyboard shortcut or mouse wheel).