X
Tap here to go to the mobile version of the site.

Support Forum

I've changed d colors of d browser's background (hate that white page) n now i can't c anything, what is d way 2 d default browser settings? Please help!

Posted

I am using Linux (ZORIN) n have reinstalled it several times but it always remember d previous settings, why is it like that? That is not a feature but a hassle. Please help me, I don't want 2 have 2 reinstall d OS again..... confused!

I am using Linux (ZORIN) n have reinstalled it several times but it always remember d previous settings, why is it like that? That is not a feature but a hassle. Please help me, I don't want 2 have 2 reinstall d OS again..... confused!

Chosen solution

Could you please write in normal English and not use abbreviations that makes it harder to read your replies?

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-us) AppleWebKit/537+ (KHTML, like Gecko) Version/5.0 Safari/537.6+ Midori/0.4

More Information

jscher2000
  • Top 10 Contributor
8704 solutions 71122 answers

I'm not sure what you mean by "now i can't c anything". Do you mean, for example, you have black text on a black background on websites, or on Firefox's Preferences page? What is the extent of the problem?

Your text and background color selections are stored in a file named prefs.js in your Firefox profile folder. If necessary, you could quit Firefox and rename this file to something like prefs-old.js and then when you start Firefox up it will use default settings. Later you can rescue missing details from prefs-old.js.

To locate your Profile folder: Profiles - Where Firefox stores your bookmarks, passwords and other user data

I'm not sure what you mean by "now i can't c anything". Do you mean, for example, you have black text on a black background on websites, or on Firefox's Preferences page? What is the extent of the problem? Your text and background color selections are stored in a file named '''prefs.js''' in your Firefox profile folder. If necessary, you could quit Firefox and rename this file to something like prefs-old.js and then when you start Firefox up it will use default settings. Later you can rescue missing details from prefs-old.js. To locate your Profile folder: [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]]

Question owner

I c u do not understand! I changed d background colors n the fonts while using hi contrast settings, they both somehow got set 2 d same color. Now I can't c any of d pages content because d buttons can not b seen normal when d bcolor is changed. My results r both text n bcolors d same n can't c settings @ the content preferences.

WHERE IS D DEFAULT SETTING BUTTOM/OPTION 4 D ENTIRE BROWSER? It seems as all d changes r not for d best n instead Is making humanity more complex than ever.... I ironic I was trying 2 move away from that white page now everything is white!)bold text

I c u do not understand! I changed d background colors n the fonts while using hi contrast settings, they both somehow got set 2 d same color. Now I can't c any of d pages content because d buttons can not b seen normal when d bcolor is changed. My results r both text n bcolors d same n can't c settings @ the content preferences. WHERE IS D DEFAULT SETTING BUTTOM/OPTION 4 D ENTIRE BROWSER? It seems as all d changes r not for d best n instead Is making humanity more complex than ever.... I ironic I was trying 2 move away from that white page now everything is white!)'''bold text'''

Modified by ok66m.com

cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158000 answers

Did you make the change in Firefox or did you select a High Contrast theme in Linux?


You can delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

The Firefox Firefox profile folder is in this hidden location in ~/.mozilla/firefox/


Make sure that you allow pages to choose their own colors.

  • Edit > Preferences > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

This setting affects background images.

See also:

Did you make the change in Firefox or did you select a High Contrast theme in Linux? ----- You can delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences The Firefox Firefox profile folder is in this hidden location in ~/.mozilla/firefox/ ----- Make sure that you allow pages to choose their own colors. *Edit > Preferences > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above" Try "Never" if the default "Only with High Contrast themes" isn't working. This setting affects background images. See also: *http://kb.mozillazine.org/Website_colors_are_wrong

Question owner

I am using Linux n does not allow 2 delete or change files. D settings where changed on d browser, It's so **tarded but yes, it might b d solution 2 delete account, good thinking!!!! Thank u!

I am using Linux n does not allow 2 delete or change files. D settings where changed on d browser, It's so **tarded but yes, it might b d solution 2 delete account, good thinking!!!! Thank u!
jscher2000
  • Top 10 Contributor
8704 solutions 71122 answers

The only "default settings" button would perform a Refresh. You can read more about that feature in this article: Refresh Firefox - reset add-ons and settings. I think that would be more drastic than you're looking for.

Renaming settings files is actually the easiest approach to removing this problem, but you could try this. See the screen shots for illustration:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) At the top of the page is a search box, you'll have to "blind click" to hit it. In the search box above the list, type or paste document_color and pause while the list is filtered

(3) The browser.display.document_color_use preference is listed invisibly below where the triangle is. Right-click in that area and you should get a context menu with Modify as the top option. Click Modify or, if you cannot see it, try pressing M to activate it.

(4) A visible pop-up should allow you to edit the current value, usually 0, possibly 2 -- make a mental note -- to a 1 and then click OK. Immediately you should see black text on a white background again.

Now you can go back to the Preferences page and select the colors you actually wanted. Then the last step is to undo the change you made in about:config. On the Preferences page, you then can restore your earlier setting:

Override the colors specified by the page with my selections above: 0 = Only with High Contrast themes 1 = Never 2 = Always

The only "default settings" button would perform a Refresh. You can read more about that feature in this article: [[Refresh Firefox - reset add-ons and settings]]. I think that would be more drastic than you're looking for. Renaming settings files is actually the easiest approach to removing this problem, but you could try this. See the screen shots for illustration: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) At the top of the page is a search box, you'll have to "blind click" to hit it. In the search box above the list, type or paste '''document_color''' and pause while the list is filtered (3) The '''browser.display.document_color_use''' preference is listed invisibly below where the triangle is. Right-click in that area and you should get a context menu with Modify as the top option. Click Modify or, if you cannot see it, try pressing M to activate it. (4) A visible pop-up should allow you to edit the current value, usually 0, possibly 2 -- make a mental note -- to a 1 and then click OK. Immediately you should see black text on a white background again. Now you can go back to the Preferences page and select the colors you actually wanted. Then the last step is to undo the change you made in about:config. On the Preferences page, you then can restore your earlier setting: Override the colors specified by the page with my selections above: 0 = Only with High Contrast themes 1 = Never 2 = Always
jscher2000
  • Top 10 Contributor
8704 solutions 71122 answers

Helpful Reply

ok66m.com said

I am using Linux n does not allow 2 delete or change files.

That doesn't seem right. I thought Linux was all about user control? But I use Windows, so I can't help you there. Please try the about:config method I described above.

''ok66m.com [[#answer-844612|said]]'' <blockquote> I am using Linux n does not allow 2 delete or change files.</blockquote> That doesn't seem right. I thought Linux was all about user control? But I use Windows, so I can't help you there. Please try the about:config method I described above.
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158000 answers

Chosen Solution

Could you please write in normal English and not use abbreviations that makes it harder to read your replies?

Could you please write in normal English and not use abbreviations that makes it harder to read your replies?
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158000 answers

You should always have full read and write access to the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

You should always have full read and write access to the Firefox profile folder. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox

Helpful Reply

jscher2000 said

ok66m.com said
I am using Linux n does not allow 2 delete or change files.

That doesn't seem right. I thought Linux was all about user control? But I use Windows, so I can't help you there. Please try the about:config method I described above.

Yes,, Linux used 2 b all about that (d old code) but as it is Mark want 2 control all desktops, we think! Regarding my Firefox issue, someone recommended 2 create a new account n that worked, thank u for thinking. We r trying to use text verbiage 2 stimulate d brains of some humans but it's not working. OK66M*COM

''jscher2000 [[#answer-844620|said]]'' <blockquote> ''ok66m.com [[#answer-844612|said]]'' <blockquote> I am using Linux n does not allow 2 delete or change files.</blockquote> That doesn't seem right. I thought Linux was all about user control? But I use Windows, so I can't help you there. Please try the about:config method I described above. </blockquote> Yes,, Linux used 2 b all about that (d old code) but as it is Mark want 2 control all desktops, we think! Regarding my Firefox issue, someone recommended 2 create a new account n that worked, thank u for thinking. We r trying to use text verbiage 2 stimulate d brains of some humans but it's not working. OK66M*COM

Question owner

ok66m.com said

jscher2000 said
ok66m.com said
I am using Linux n does not allow 2 delete or change files.

That doesn't seem right. I thought Linux was all about user control? But I use Windows, so I can't help you there. Please try the about:config method I described above.

Yes,, Linux used 2 b all about that (d old code) but as it is Mark want 2 control all desktops, we think! Regarding my Firefox issue, someone recommended 2 create a new account n that worked, thank u for thinking. We r trying to use text verbiage 2 stimulate d brains of some humans but it's not working. OK66M*COM

''ok66m.com [[#answer-844658|said]]'' <blockquote> ''jscher2000 [[#answer-844620|said]]'' <blockquote> ''ok66m.com [[#answer-844612|said]]'' <blockquote> I am using Linux n does not allow 2 delete or change files.</blockquote> That doesn't seem right. I thought Linux was all about user control? But I use Windows, so I can't help you there. Please try the about:config method I described above. </blockquote> Yes,, Linux used 2 b all about that (d old code) but as it is Mark want 2 control all desktops, we think! Regarding my Firefox issue, someone recommended 2 create a new account n that worked, thank u for thinking. We r trying to use text verbiage 2 stimulate d brains of some humans but it's not working. OK66M*COM </blockquote>

Question owner

FireFOX thank you for blocking us out for a while, we know.... nobody wants to hear the truth, only a dilution of the truth it is acceptable; which is, the main reason why you have sold out to GOOGLE and that is the main problem with all of you Linux and all its Distros have become corrupted as yourself. You will never be able to remain original since, you are all submissive to your immediate conditions, but we will fix this thing once and for all>OK66M

FireFOX thank you for blocking us out for a while, we know.... nobody wants to hear the truth, only a dilution of the truth it is acceptable; which is, the main reason why you have sold out to GOOGLE and that is the main problem with all of you Linux and all its Distros have become corrupted as yourself. You will never be able to remain original since, you are all submissive to your immediate conditions, but we will fix this thing once and for all>OK66M

Modified by ok66m.com

Question owner

The Internet is so..... OVER RATED that must come to an END!

The Internet is so..... OVER RATED that must come to an END!