X
Tap here to go to the mobile version of the site.

Support Forum

Hi, I actually have a P4 with SSE2 but Firefox still won't update

Posted

This is a pretty old machine but am keeping hold of it because it runs well with older devices whereas Windows 10 throws a wobbly.

Its got a P4 2.2GHz which supports SSE2 according to CPU-Z but it will not work. I can't find a better BIOS so it looks like I am out of luck here. any suggestions?

This is a pretty old machine but am keeping hold of it because it runs well with older devices whereas Windows 10 throws a wobbly. Its got a P4 2.2GHz which supports SSE2 according to CPU-Z but it will not work. I can't find a better BIOS so it looks like I am out of luck here. any suggestions?

Additional System Details

Installed Plug-ins

  • npsitesafety (Official)
  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.71.2 for Mozilla browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.9.160
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.0; rv:34.0) Gecko/20100101 Firefox/34.0

More Information

James
  • Moderator
1593 solutions 11223 answers

Helpful Reply

You appear to be running Firefox 34.0 on Windows 2000 ?

Windows 2000 has not been able to run newer Firefox versions with Firefox 12.0 being the last unless you do some workarounds. http://forums.mozillazine.org/viewtopic.php?f=23&t=2482475

No grantee you would be able to use recent versions since.

If you do not have Windows 2000 then you may be running Firefox in compatibility mode..

You appear to be running Firefox 34.0 on Windows 2000 ? Windows 2000 has not been able to run newer Firefox versions with Firefox 12.0 being the last unless you do some workarounds. http://forums.mozillazine.org/viewtopic.php?f=23&t=2482475 No grantee you would be able to use recent versions since. If you do not have Windows 2000 then you may be running Firefox in compatibility mode..