Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No longer allowed the options to allow, allow for session, or block a cookie when I go to a website

  • 14 replies
  • 19 have this problem
  • 499 views
  • Last reply by jscher2000

more options

When I go to any website the cookies for the website are automatically allowed. I no longer have the ability to 'allow', 'allow for session', or block a cookie when I first go to a website. I used to be able to do so.

Tools->Options->Privacy->History is set to 'use custom settings for history'. I've never allowed third party cookies.

This has happened on 6 XP PCs. I hope this is not an 'enhancement'.

Chosen solution

This is a bug that got filed years ago and that landed in Firefox 44.

  • bug 606655 - Remove "Ask me everytime" cookies option

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Read this answer in context 👍 1

All Replies (14)

more options

Unfortunately, the old "Ask me every time" option was removed.

You can set your default to the permission you used most often, for example, for session cookies:

Keep until: I close Firefox

Firefox will continue to apply your accumulated allow/block list, but to choose a non-default setting for a site in the future, you'll need to use one of these methods:

For the site currently indicated in the address bar:

Call up the Permissions panel of the Page Info dialog any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address, then the ">" icon, then More Information > Permissions

The "Set Cookies" permission is about 3/4 of the way down the panel.

For other sites:

You can manually create an Exception on the Options page. However, it's probably easier to use an add-on. (I haven't tested any myself.)

more options

Thanks. While helpful, I really can't see doing the above for every page I visit on a daily basis. I resolved the problem by re-installing 42.0 and turning off the update function. I think that the bigger question is who, how and why are these abitrary decisions being made about functionallity? Thanks again.

more options

Chosen Solution

This is a bug that got filed years ago and that landed in Firefox 44.

  • bug 606655 - Remove "Ask me everytime" cookies option

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

more options

Thanks. Can't believe this was considered a bug. Was one of the main reasons I liked using firefox. I think that this highlights my main concern: what I considered a very useful tool someone else considered a bug, and I loose. I've downleved firefox to 43.0.4, and never intend to upgrade again.

Modified by trdcsfd

more options

Also can't believe this has been done. One of Firefox's big plus points gone. Will give it a while to see if it's corrected, but may have to look elsewhere, Or how do you downgrade to earlier firefox?

more options

Hi chilli-paul, please also submit your comments using the following site:

https://input.mozilla.org/feedback/firefox


Firefox will continue to apply your accumulated allow/block list, but when Firefox retrieves something from a site that isn't on the list, it will now use your default setting automatically. To maintain visibility on cookies and ease of changing permissions, you might consider using the Cookie Monster extension. Here's how it works:

  • When loading the page, Firefox automatically applies your permissions to each server from which it is loading content:
    • Any site-specific permission you set before (Allow, Allow for Session, Block)
    • For other sites, your default permission from the Options/Preferences page (Keep until...)
  • The Cookie Monster button on the toolbar allows you to see which servers have which cookie permissions and to change them. This is especially useful for the third party cookies -- sample screen shot:

Note: I turned on the option to "Apply cookie settings to both HTTP and HTTPS", which streamlines the menu. With this option you don't have to set/modify permissions for both HTTP or HTTPS on the same site (why would they be different?).

more options

Per jscher2000's suggestion of using the exception list, this does not work. FireFox ignores the exceptions list. Firefox deleted my exception list (or something did), so I painstakingly typed in my critical few "Allow" web pages but it does not keep them. I have it set to deleted cookies when I close FireFox, but I would expect the exception list to protect cookies from allowed sites.

more options

Hi skitty123, Firefox does not check the exceptions list when clearing cookies using these features:

  • Clear recent history
  • Forget
  • Clear history when Firefox closes

To expire all other cookies when you close Firefox, the best approach is to change the "lifetime" on the Privacy panel to

Keep until: I close Firefox

and allow Firefox to use that setting to flush all the session cookies while keeping the persistent cookies. (Screen shot example attached.)

If you are using the "Clear history when Firefox closes" feature, click the "Settings" button and make sure that Cookies are not selected for cleaning. Also, make sure Site Preferences is not selected for clearing -- those are site-specific permissions like Allow and Block for cookies.

more options

jscher2000, Thank you. I did as you described (though I never accept third party cookies) and this seems to be working. The screen snapshot was very helpful. Thanks for including that. I am using the "Clear history when Firefox closes" feature, but now have cookies unchecked. It is interesting that that piece does not recognize the exception list. Who knew?!

Sadly, it appears I will need to go in and add an https: version for each of the URLs that I already typed in, but I've now figured out that I can go to the various web pages, copy the URL, and paste it into the exception list box, so that will go more quickly (and more accurately!) than those that I typed in manually.

How sad that the powers that be at Mozilla did not (still do not?) recognize how much people relied on the "Ask me" feature. It is the one feature that distinguished Firefox. Sure there were web pages that triggered ridiculous numbers of those pop-ups - I counted 62 one time! - but that is a problem with the web page, not Mozilla.

Thanks again for taking the time to show us how to do this. It is greatly appreciated!

more options

skitty123 said

Sadly, it appears I will need to go in and add an https: version for each of the URLs that I already typed in, but I've now figured out that I can go to the various web pages, copy the URL, and paste it into the exception list box, so that will go more quickly (and more accurately!) than those that I typed in manually.

If you want to modify the cookie permission for the site in the address bar, you also could use the Page Info dialog, Permissions panel:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Set Cookies" and uncheck the "Use default" box, and then select the permission you prefer.

That is only for the site listed in the address bar. To work with third party cookies on the page, I suggest using the Cookie Monster extension.

more options

I would like to thank you all for the ongoing discussion. I still don't understand how the 'ask me every time' can be considered a bug when it is only an option that someone does not have to choose. I can’t believe that someone at Mozilla wants or needs to have the power to decide what cookies reside on my PCs. How about making a about:config option for those of us who can handle changing config parameters? Anyway, for those of you who want to back this off, you can get 43.0.4 at the majorgeeks site. I decided to go that route while I look at other browsers. I’ve turned off updates, I’m willing to take my chances there.

more options

There is no need to seek out unofficial sources for Firefox installers. See: Install an older version of Firefox.

more options

I did not realize that "Ask me every time" option was one of the key reasons why I am using Firefox. It looks like 43.0.4 is the last version with this option. Claiming that this feature was a bug is so beyond believe, so I decided to check this bug report... they just decided to remove inconvenient feature. But most worrying is how this removal was handled. Go to the bug report and read the comment 44 from Alan Curry dated 2016-01-29. Fragment here: "The upgrade to 44 erased the entire exception list! You opened me up not only to new privacy violating cookies but even the ones I had explicitly and permanently rejected before. It's hard to think of how you could have done a worse job. Submitted with Firefox 43, updates disabled." Many more similar voices follow this comment. I recommend to read the whole discussion and unbelievable developers' answers. This is how devs explain "ask me every time" is a bug: "It forces the user to make a ridiculous number of decisions before visiting a Web site. For instance, amazon.com produces 8 dialog boxes, and ebay.com 15". I couldn't encapsulate it better then user370560: "I really want to think the other way around: it is ridiculous that a web site wants to set 8 or 15 cookies!"

See also the principles 4 and 5 of Firefox manifesto: https://www.mozilla.org/en-US/about/manifesto

more options

Hi DexEngineer, changing the cookie lifetime preference shouldn't affect the existing permission list. If you lost your list, you could consider recovering an older version of the permissions.sqlite database from a backup (if you make backups of your Firefox profile folder) or on some versions of Windows, a restore point. However, please provide more information about your OS for specific suggestions.