X
Tap here to go to the mobile version of the site.

Support Forum

Firefox shortcut doesn't work; tried creating new one but it still doesn't work, only way to open it is from Firefoxes root folder (..Program files\Firefox...).

Posted

Hello.

Since I updated Firefox non of the shortcuts seem to work, desktop or quick-bar. Only way to star it is from the root folder of Firefox, I tried creating new shortcut from there but it doesn't work. Funny thing is that no matter how many times I try to open the Firefox via shortcuts they are shown in the Task manager, all of them, but non of them open the program, they are all around 2.000 K in size but the one that works goes from 75.000 K up.

Any help would be much appreciated.

Hello. Since I updated Firefox non of the shortcuts seem to work, desktop or quick-bar. Only way to star it is from the root folder of Firefox, I tried creating new shortcut from there but it doesn't work. Funny thing is that no matter how many times I try to open the Firefox via shortcuts they are shown in the Task manager, all of them, but non of them open the program, they are all around 2.000 K in size but the one that works goes from 75.000 K up. Any help would be much appreciated.

Chosen solution

Hey Cor-el, thanks for your help. I did try everything you suggested earlier and it didn't work, I tried with clean install with no profiles, created a new one, didn't work, deleted xulstore.json, also didn't work. I've tried everything all of you suggested but didn't fix the problem, but, on a higher note, this 44.0.2 update fixed the problem. I don't know what they changed, but it worked.

Once again, thank you all for help on this matter, FredMcD and cor-el, best regards to you.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • PlayNow Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.71.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Nokia Suite Enabler Plugin
  • NPWLPG
  • Shockwave Flash 18.0 r0
  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.3.153
  • 5.1.41212.0
  • Unity Player 4.5.5f1
  • VLC media player Web Plugin 2.1.3
  • Winamp Application Detector

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

FredMcD
  • Top 10 Contributor
4248 solutions 59427 answers

The Firefox window is opening outside of your view.

Right click on the icon and select Open New Window. Sometimes this works. If it opens, close it by Menu > File > Exit.

The Firefox window is opening outside of your view. Right click on the icon and select '''Open New Window.''' Sometimes this works. If it opens, close it by '''Menu > File > Exit.'''
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157978 answers

Try to rename (or delete) the xulstore.json file in the Firefox profile folder.

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

"AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder.

Try to rename (or delete) the xulstore.json file in the Firefox profile folder. *C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\Profiles\&lt;profile&gt;\ "AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder. *http://kb.mozillazine.org/Show_hidden_files_and_folders

Question owner

FredMcD said

The Firefox window is opening outside of your view. Right click on the icon and select Open New Window. Sometimes this works. If it opens, close it by Menu > File > Exit.

Thanks for the reply but you misunderstood me, I see Firefox in Task manager not in the Task bar..

''FredMcD [[#answer-837826|said]]'' <blockquote> The Firefox window is opening outside of your view. Right click on the icon and select '''Open New Window.''' Sometimes this works. If it opens, close it by '''Menu > File > Exit.''' </blockquote> Thanks for the reply but you misunderstood me, I see Firefox in Task manager not in the Task bar..

Modified by Pegasus_Prime

FredMcD
  • Top 10 Contributor
4248 solutions 59427 answers
'''http://kb.mozillazine.org/Firefox.exe_always_open''' '''http://kb.mozillazine.org/Firefox_hangs#Hang_at_exit'''

Question owner

Thanks again Fred, but still nothing... I do have NOD32 installed so it's not a malware or something of that kind.. It simply doesn't open via any shortcut. It's not a big problem it's just annoying.. :)

Thanks again Fred, but still nothing... I do have NOD32 installed so it's not a malware or something of that kind.. It simply doesn't open via any shortcut. It's not a big problem it's just annoying.. :)
FredMcD
  • Top 10 Contributor
4248 solutions 59427 answers

Create a new shortcut. Now right click on it and select Properties. Find the URL and post it here.

Create a new shortcut. Now right click on it and select '''Properties.''' Find the URL and post it here.

Question owner

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
FredMcD
  • Top 10 Contributor
4248 solutions 59427 answers

That should have worked. Try this; C:\PROGRA~2\MOZILL~1\firefox.exe

That should have worked. Try this; C:\PROGRA~2\MOZILL~1\firefox.exe

Question owner

Thanks again but still nothing, it's just a shorter path, but tried it anyway. This is what happens in the Task manager; the circled ones are from shortcuts and the highlighted is the one working, started from the root folder of the Firefox.

Thanks again but still nothing, it's just a shorter path, but tried it anyway. This is what happens in the Task manager; the circled ones are from shortcuts and the highlighted is the one working, started from the root folder of the Firefox.
FredMcD
  • Top 10 Contributor
4248 solutions 59427 answers

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.

Question owner

Thank You for all your help Fred, I appreciate it.

Best regards.

Thank You for all your help Fred, I appreciate it. Best regards.
guigs 1072 solutions 11697 answers

Please check these two settings:

Troubleshoot Firefox issues caused by malware and try a profile with no add ons or extensions.

Please check these two settings: *Please check the properties of the shortcut by right clicking on them. Can you please make sure that there is no -new-instance in the url? *Please check to see if each time you open a shortcut if there is another listed profile in the profile folder: [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]] [[Troubleshoot Firefox issues caused by malware]] and try a profile with no add ons or extensions.

Question owner

Thank You for reply. I've tried everything on the list, I even uninstalled Firefox a few times, erased all data from all the folders still left on the computer (after using Revo Uninstaller advanced uninstall), reinstalled, no add-ons, extensions, not even bookmark restoration and still I can open it only as already described.

Here are some screenshots, I'll provide anything You need.

Thanks for Your effort.

Thank You for reply. I've tried everything on the list, I even uninstalled Firefox a few times, erased all data from all the folders still left on the computer (after using Revo Uninstaller advanced uninstall), reinstalled, no add-ons, extensions, not even bookmark restoration and still I can open it only as already described. Here are some screenshots, I'll provide anything You need. Thanks for Your effort.
FredMcD
  • Top 10 Contributor
4248 solutions 59427 answers

Hold on, please. In the first picture, the first quotation mark is missing. Look at Target.

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

Hold on, please. In the first picture, the first quotation mark is missing. Look at '''Target.''' "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

Question owner

Sorry, the line is too long, it is there..

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

Sorry, the line is too long, it is there.. "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157978 answers

The second screenshot of three in above reply shows Administrators as the owner. I don't know if that makes a difference.

Does Firefox start when you run the application as administrator?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

The second screenshot of three in [/questions/1107283#answer-839297 above reply] shows Administrators as the owner. I don't know if that makes a difference. Does Firefox start when you run the application as administrator? Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

Question owner

Hey. Nope, starting it as admin doesn't work, I am the only user, and admin, starting in safe mode had no impact on the matter, but thank you for trying. If it comes to the point that it starts to bug me a lot, I'll install the previous version (43...) which worked without a glitch.

Feel free to post any other ideas, I'd be happy to try them out.

Best regards.

Hey. Nope, starting it as admin doesn't work, I am the only user, and admin, starting in safe mode had no impact on the matter, but thank you for trying. If it comes to the point that it starts to bug me a lot, I'll install the previous version (43...) which worked without a glitch. Feel free to post any other ideas, I'd be happy to try them out. Best regards.

Helpful Reply

O.K. So I accidentally right-clicked the quick bar shortcut and left-clicked the 'Open new window' tab and it opened Firefox without any problems. It's not a solution but it's something.

Once again, thank You for all and any future ideas about this problem and feel free to write up any other ideas to try out.

Many thanks.

O.K. So I accidentally right-clicked the quick bar shortcut and left-clicked the 'Open new window' tab and it opened Firefox without any problems. It's not a solution but it's something. Once again, thank You for all and any future ideas about this problem and feel free to write up any other ideas to try out. Many thanks.
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157978 answers

Helpful Reply

Did you try to close the not working window to see if that has effect?

Did you try to delete the xulstore.json file like I suggested above?

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Did you try to close the not working window to see if that has effect? Did you try to delete the xulstore.json file like I suggested above? Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Chosen Solution

Hey Cor-el, thanks for your help. I did try everything you suggested earlier and it didn't work, I tried with clean install with no profiles, created a new one, didn't work, deleted xulstore.json, also didn't work. I've tried everything all of you suggested but didn't fix the problem, but, on a higher note, this 44.0.2 update fixed the problem. I don't know what they changed, but it worked.

Once again, thank you all for help on this matter, FredMcD and cor-el, best regards to you.

Hey Cor-el, thanks for your help. I did try everything you suggested earlier and it didn't work, I tried with clean install with no profiles, created a new one, didn't work, deleted xulstore.json, also didn't work. I've tried everything all of you suggested but didn't fix the problem, but, on a higher note, this 44.0.2 update fixed the problem. I don't know what they changed, but it worked. Once again, thank you all for help on this matter, FredMcD and cor-el, best regards to you.