X
Tap here to go to the mobile version of the site.

Support Forum

Firefox won't let me login my Office 365 College email account anymore but Microsoft Edge or Explorer do

Posted

I use to be able to log on my Office 365 college email account with Firefox, but now it is not working anymore. When I click on the email link of my college website, it is suppose to open a new tab directing me to my Office 365 college email. But now the tab leads to Office 365 main login page with my college email address and a box to enter my password. When I enter my password, it says it doesn't recognize my email account or password. I already called my college IT department and they told me it was an issue with Firefox, not the college account. I can access my college email account with Explorer or Edge, but not with Firefox anymore. It did an update the other day, and it worked again for a couple days. Now it's not working again. Can someone help please?

I use to be able to log on my Office 365 college email account with Firefox, but now it is not working anymore. When I click on the email link of my college website, it is suppose to open a new tab directing me to my Office 365 college email. But now the tab leads to Office 365 main login page with my college email address and a box to enter my password. When I enter my password, it says it doesn't recognize my email account or password. I already called my college IT department and they told me it was an issue with Firefox, not the college account. I can access my college email account with Explorer or Edge, but not with Firefox anymore. It did an update the other day, and it worked again for a couple days. Now it's not working again. Can someone help please?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • HPDetect
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • 5.1.41212.0
  • WildTangent Games App V2 Presence Detector

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

More Information

FredMcD
  • Top 10 Contributor
4248 solutions 59413 answers

It could be the link you are using had been changed on the server.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

It could be the link you are using had been changed on the server. Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.