X
Tap here to go to the mobile version of the site.

Support Forum

Toolbar strange behavior

Posted

Dear Firefox Support,

I have just bought a new Lenovo Laptop with Windows 10. Everything is working perfectly (knocks on wood) but one thing has been bothering me. When I am using Firefox, I sometimes get a weird effect on my toolbar, or the whole top part of the screen. Sometimes even on the webpage, like it's not loading properly. I made a picture and added it in this message. I have tried setting the .exe as running as administrator and other settings and am quite good with computers (can bench test and build my own computer) but can't seem to solve this. All graphics drivers are of course up te date.

I also get a weird thing when opening my bookmarks, also made a picture of that and added it with this message.

Also, to add, I added the new tasbar skin so it would maybe help with the problem, it did not, so the cause is not the skin.

Maybe you know a quick solution to this problem?

Thank you very much in advance for the help.

Edit: I can't seem to upload the pictures through the website so I uploaded the to a website:

http://pho.to/A02eH

Best Regards, William

Dear Firefox Support, I have just bought a new Lenovo Laptop with Windows 10. Everything is working perfectly (knocks on wood) but one thing has been bothering me. When I am using Firefox, I sometimes get a weird effect on my toolbar, or the whole top part of the screen. Sometimes even on the webpage, like it's not loading properly. I made a picture and added it in this message. I have tried setting the .exe as running as administrator and other settings and am quite good with computers (can bench test and build my own computer) but can't seem to solve this. All graphics drivers are of course up te date. I also get a weird thing when opening my bookmarks, also made a picture of that and added it with this message. Also, to add, I added the new tasbar skin so it would maybe help with the problem, it did not, so the cause is not the skin. Maybe you know a quick solution to this problem? Thank you very much in advance for the help. Edit: I can't seem to upload the pictures through the website so I uploaded the to a website: http://pho.to/A02eH Best Regards, William

Chosen solution

It seems the laptop swaps between the integrated Intel chip and the Nvidia chip according to a) load b) power settings c) user preference (in Nvidia control panel).

Could you try option C and set the Nvidia chip as preferred when running Firefox: https://support.lenovo.com/fi/en/documents/ht071337 ? The swapping might be what is causing the rendering errors, if the rendering pipeline gets handed off from one chip to the other mid-stream or something.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.71.2 for Mozilla browsers
  • Shockwave Flash 20.0 r0
  • 5.1.41212.0

Application

  • Firefox 43.0.4
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • Support URL: https://support.mozilla.org/1/firefox/43.0.4/WINNT/nl/

Extensions

  • Adblock Plus 2.7.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 5500
  • adapterDescription2: NVIDIA GeForce 840M
  • adapterDeviceID: 0x1616
  • adapterDeviceID2: 0x1341
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 381c17aa
  • adapterSubsysID2: 381c17aa
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 11-18-2015
  • driverDate2: 12-16-2015
  • driverVersion: 20.19.15.4331
  • driverVersion2: 10.18.13.6143
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 5500 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
ideato 893 solutions 6250 answers

Hello William, any luck if you disabling graphics hardware acceleration ?

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

Thank you.

Hello William, any luck if you disabling graphics hardware acceleration ? You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! Thank you.

Question owner

Thank you for your help!

This did solve the problem but it did cause several other problems. Watching video's in Firefox are incredibly choppy now and firefox in general is very slow. When enabling Hardware Acceleration again, everything returns to normal again but the weird glitches return again.

Any suggestions how to keep hardware accelaration and get rid of the glitches?

Thanks in advance!

Best Regards, William

Thank you for your help! This did solve the problem but it did cause several other problems. Watching video's in Firefox are incredibly choppy now and firefox in general is very slow. When enabling Hardware Acceleration again, everything returns to normal again but the weird glitches return again. Any suggestions how to keep hardware accelaration and get rid of the glitches? Thanks in advance! Best Regards, William

Question owner

Anyone know what to do?

Anyone know what to do?
ideato 893 solutions 6250 answers

Hello, try to toggle (double-click on it) to false the layers.offmainthreadcomposition.enabled (always in about:config), and keep hardware accelaration enable.

any luck ?

thank you

Hello, try to toggle (double-click on it) to false the '''layers.offmainthreadcomposition.enabled''' (always in [http://kb.mozillazine.org/About:config about:config]), and keep hardware accelaration enable. any luck ? thank you

Question owner

Sorry for the late reply, had some problems to solve.

This did the same this as the first solution. It solves the problem but makes Firefox incredibly slow and video's choppy and slow.

Any other suggestions?

Thanks in advance and thanks for your patience.

Best regards, William

Sorry for the late reply, had some problems to solve. This did the same this as the first solution. It solves the problem but makes Firefox incredibly slow and video's choppy and slow. Any other suggestions? Thanks in advance and thanks for your patience. Best regards, William
Phoxuponyou 51 solutions 517 answers

What sort of hardware are you running on if disabling hardware acceleration cripples Firefox?

It sounds like there's an issue with the GPU chip and/or driver when it comes to rendering Firefox, if dropping HWA (hardware acceleration) fixes the problem. If the laptop is brand new, then there is possibly hope that a driver update will fix the issue in the future. The slowdown is due to the CPU not being powerful enough to take over rendering duties from the GPU.

It will take better knowledge than I have of Firefox internals to mess with the rendering. What you could do is try a previous version of Firefox (43.0.4) in Portable form to see if they render properly: http://sourceforge.net/projects/portableapps/files/Mozilla%20Firefox%2C%20Portable%20Ed./.

What sort of hardware are you running on if disabling hardware acceleration cripples Firefox? It sounds like there's an issue with the GPU chip and/or driver when it comes to rendering Firefox, if dropping HWA (hardware acceleration) fixes the problem. If the laptop is brand new, then there is possibly hope that a driver update will fix the issue in the future. The slowdown is due to the CPU not being powerful enough to take over rendering duties from the GPU. It will take better knowledge than I have of Firefox internals to mess with the rendering. What you could do is try a previous version of Firefox (43.0.4) in Portable form to see if they render properly: http://sourceforge.net/projects/portableapps/files/Mozilla%20Firefox%2C%20Portable%20Ed./.

Question owner

My laptop is a Lenovo Z70 and I am very happy with it. My new baby ;)

The strange thing is it has an Intel HD Graphics 5500 and a Nvidia Geforce 840M and that is new to me. I tried updating the Intel HD Graphics 5500 driver because it functions as the main video card and it is quite hard to find the driver. I did but it was hard. I would much rather use the 840M as my main video card but I don't think it works that way with laptops? I mostly work with desktops and have build my own pc's and can bench test them. Laptops are a bit new for me so sorry if I seem a bit noobish.

When I go into the display driver for the 840M it shows almost no settings so I guess that means the HD 5500 is the primary card now?

Here is a techical overview of my laptop. I have the standard model without any upgrades: http://shop.lenovo.com/nl/nl/laptops/lenovo/z-series/z70-80/#tab-technische_specificaties

I will fiddle with the settings somewhat to maybe check if it isn't easily solved by switching the cards priority.

Thanks again guys for helping. I can easily go to another browser but Firefox has always been good to me and I am a loyal user. I really want to use Firefox on all my computers.

Best Regards, William

My laptop is a Lenovo Z70 and I am very happy with it. My new baby ;) The strange thing is it has an Intel HD Graphics 5500 and a Nvidia Geforce 840M and that is new to me. I tried updating the Intel HD Graphics 5500 driver because it functions as the main video card and it is quite hard to find the driver. I did but it was hard. I would much rather use the 840M as my main video card but I don't think it works that way with laptops? I mostly work with desktops and have build my own pc's and can bench test them. Laptops are a bit new for me so sorry if I seem a bit noobish. When I go into the display driver for the 840M it shows almost no settings so I guess that means the HD 5500 is the primary card now? Here is a techical overview of my laptop. I have the standard model without any upgrades: http://shop.lenovo.com/nl/nl/laptops/lenovo/z-series/z70-80/#tab-technische_specificaties I will fiddle with the settings somewhat to maybe check if it isn't easily solved by switching the cards priority. Thanks again guys for helping. I can easily go to another browser but Firefox has always been good to me and I am a loyal user. I really want to use Firefox on all my computers. Best Regards, William
Phoxuponyou 51 solutions 517 answers

No worries about technical ability, this is the Support Forum after all, we're here to help.

The Z70 is definitely no slouch. The Intel GPU chip comes integrated with the CPU, but you should definitely use the Nvidia chip if you can. You should be able to select one or the other, somehow, but I don't know how Lenovo does that. I'll have a look in the manual simply out of curiosity.

Glad to hear Firefox has served well so far! Your hardware seems quite capable and fresh, so this shouldn't be too hard to sort out.

No worries about technical ability, this is the Support Forum after all, we're here to help. The Z70 is definitely no slouch. The Intel GPU chip comes integrated with the CPU, but you should definitely use the Nvidia chip if you can. You should be able to select one or the other, somehow, but I don't know how Lenovo does that. I'll have a look in the manual simply out of curiosity. Glad to hear Firefox has served well so far! Your hardware seems quite capable and fresh, so this shouldn't be too hard to sort out.
Phoxuponyou 51 solutions 517 answers

Chosen Solution

It seems the laptop swaps between the integrated Intel chip and the Nvidia chip according to a) load b) power settings c) user preference (in Nvidia control panel).

Could you try option C and set the Nvidia chip as preferred when running Firefox: https://support.lenovo.com/fi/en/documents/ht071337 ? The swapping might be what is causing the rendering errors, if the rendering pipeline gets handed off from one chip to the other mid-stream or something.

It seems the laptop swaps between the integrated Intel chip and the Nvidia chip according to a) load b) power settings c) user preference (in Nvidia control panel). Could you try option C and set the Nvidia chip as preferred when running Firefox: https://support.lenovo.com/fi/en/documents/ht071337 ? The swapping might be what is causing the rendering errors, if the rendering pipeline gets handed off from one chip to the other mid-stream or something.

Modified by Phoxuponyou

Helpful Reply

I think I solved it myself. I just went into the control panel for the 840M and then went into the 3D settings and selected Firefox. Then I selected the 840 as the only video card to use and it seems to solve the problem. I will use it tonight and see if the problem disappears completely.

Does seem like a strange way to do things to switch between video cards. Why 2 cards when 1 card would work as well? Very strange...

Edit: I see you suggested this above my post. Nicely found!

I think I solved it myself. I just went into the control panel for the 840M and then went into the 3D settings and selected Firefox. Then I selected the 840 as the only video card to use and it seems to solve the problem. I will use it tonight and see if the problem disappears completely. Does seem like a strange way to do things to switch between video cards. Why 2 cards when 1 card would work as well? Very strange... Edit: I see you suggested this above my post. Nicely found!
Phoxuponyou 51 solutions 517 answers

Great, glad to hear you got it sorted out!

Switching between two chips is not exactly new, but every time it's been tried there have been complications. It makes sense in a laptop, because a low-power integrated chip eats less Watts and hence runs less hot = more power-efficient = longer battery life and less cooling required. In a desktop the reduced power consumption and heat load still apply, but it's less of an issue because the desktop is mains powered.

Great, glad to hear you got it sorted out! Switching between two chips is not exactly new, but every time it's been tried there have been complications. It makes sense in a laptop, because a low-power integrated chip eats less Watts and hence runs less hot = more power-efficient = longer battery life and less cooling required. In a desktop the reduced power consumption and heat load still apply, but it's less of an issue because the desktop is mains powered.

Question owner

I have tested it thoroughly and the problem seems to be solved completely.

I want to thank everyone here for the great support and patience! You guys are awesome!

I have tested it thoroughly and the problem seems to be solved completely. I want to thank everyone here for the great support and patience! You guys are awesome!