X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Insecure Connection - "Your connection is not secure"

Posted

Hello,

I'm trying to access some sites, but firefox isn't loading it give me an error as "Your connection is not secure", I tried everything removing Cookies, Cache, and clearing browser Data, But those site loads perfectly with other browsers but Not with firefox. But Firefox has a great features so i can't really use other's.

Please let he know how to get rid of this "Insecure Connection" problem..

Thank you, Hope you reply.

Regards,

Hello, I'm trying to access some sites, but firefox isn't loading it give me an error as "Your connection is not secure", I tried everything removing Cookies, Cache, and clearing browser Data, But those site loads perfectly with other browsers but Not with firefox. But Firefox has a great features so i can't really use other's. Please let he know how to get rid of this "Insecure Connection" problem.. Thank you, Hope you reply. Regards,

Chosen solution

ok, so please try to disable https scanning within avast which is known to cause various problems:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok.

http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • RealDownloader Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealPlayer Download Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Shockwave Flash 20.0 r0
  • 5.1.40620.0
  • VLC media player Web Plugin 2.1.3

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

joseph1 1 solutions 5 answers
[[Secure connection failed|https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message?redirectlocale=en-US&redirectslug=Secure+Connection+Failed]]

Question owner

Hello, Thanks for replying.

I followed that procedure couple of days ago and i successfully deleted cert8.db file, But the file as it says is been recreated again.

But i'm not able to delete the file again says "The file in use and can't be deleted" so i can't really find any permanent solution or fix.

so more help would be useful

Regards,

'''Hello, Thanks for replying. I followed that procedure couple of days ago and i successfully deleted cert8.db file, But the file as it says is been recreated again. But i'm not able to delete the file again says "The file in use and can't be deleted" so i can't really find any permanent solution or fix. so more help would be useful Regards,'''
caspy7 0 solutions 10 answers

I believe Firefox recreating cert8.db is quite normal, so if your problem persists after deleting it but that does not solve your problem, then you can move on to another troubleshooting step.

Additionally, as the instructions note, Firefox must be shut down to delete the file. I'm wondering if it was still running, hence the "still in use" error.

I believe Firefox recreating cert8.db is quite normal, so if your problem persists after deleting it but that does not solve your problem, then you can move on to another troubleshooting step. Additionally, as the instructions note, Firefox must be shut down to delete the file. I'm wondering if it was still running, hence the "still in use" error.
cor-el
  • Top 10 Contributor
  • Moderator
16610 solutions 150021 answers
Does this stop you from accessing the website? Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB ---- See also: * https://support.mozilla.org/kb/how-does-content-isnt-secure-affect-my-safety * https://support.mozilla.org/kb/control-center-site-privacy-and-security-firefox * https://blog.mozilla.org/security/2015/11/03/updated-firefox-security-indicators-2/

Question owner

Hello, Thanks for replying.

And Yes the Firefox should be exited, if i need to delete cert8.db file. But However it's been re-created again as soon as i open Firefox and still can't able to access the Sites. Now Even Google is not able to open up says "Secure Connection Failed".

I've 2 problems now one is "Secure Connection Failed" and the other is "Your connection is not secure" many sites are not opening .

Please see the below Screenshot for better understanding

Regards,

'''Hello, Thanks for replying. And Yes the Firefox should be exited, if i need to delete cert8.db file. But However it's been re-created again as soon as i open Firefox and still can't able to access the Sites. Now Even Google is not able to open up says "Secure Connection Failed". I've 2 problems now one is "Secure Connection Failed" and the other is "Your connection is not secure" many sites are not opening . Please see the below Screenshot for better understanding Regards, '''
cor-el
  • Top 10 Contributor
  • Moderator
16610 solutions 150021 answers

You can check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

You can check the connection settings. *Tools > Options > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can ---- Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

Question owner

Nope,. I've changed the the Connection Setting to "No Proxy" & removed both cookies & Cache, but it's still not working.

So shall i try reinstalling the Software? Will that work?

Regards,

Nope,. I've changed the the Connection Setting to "No Proxy" & removed both cookies & Cache, but it's still not working. So shall i try reinstalling the Software? Will that work? Regards,
philipp
  • Top 25 Contributor
  • Moderator
5129 solutions 22719 answers

hi, which security program are you using on this system?

hi, which security program are you using on this system?

Question owner

Security Program? you mean by Anti Virus,? I'm using Avast Anti Virus.

Any help.?

Regards,

Security Program? you mean by Anti Virus,? I'm using Avast Anti Virus. Any help.? Regards,
philipp
  • Top 25 Contributor
  • Moderator
5129 solutions 22719 answers

Chosen Solution

ok, so please try to disable https scanning within avast which is known to cause various problems:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok.

http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

ok, so please try to disable https scanning within avast which is known to cause various problems: #Open the Avast dashboard on the affected system. #Select Settings from the left sidebar menu. #Switch to Active Protection. #Click on Customize next to Web Shield. #Uncheck the "Enable HTTPS Scanning" option and click ok. http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

Helpful Reply

Oh, Thanks a lot phiipp, it worked perfectly.

Now the sites are loading without any problem..

Thanks you again, all for helpin me.

Have a nice Day!

Regards,

'''Oh, Thanks a lot phiipp, it worked perfectly. Now the sites are loading without any problem.. Thanks you again, all for helpin me. Have a nice Day! Regards,'''
ses716 0 solutions 7 answers

I am on a Mac with the same issue--no anti-virus software or malware--so why is this happening?

I am on a Mac with the same issue--no anti-virus software or malware--so why is this happening?
cor-el
  • Top 10 Contributor
  • Moderator
16610 solutions 150021 answers

Hi ses716

Could you please start a new thread for your question?

Then you can provide more information like your operating system and installed extensions and installed plugins.


You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • click "Advanced" to expand the error message
  • click "Add Exception" to open "Add Security Exception"

If this isn't possible then open "Add Security Exception" by pasting this URL in the location/address bar and paste the URL of the website (https://xxx.xxx) in it's location field.

  • chrome://pippki/content/exceptionDialog.xul

Let Firefox retrieve the certificate -> "Get Certificate"

  • click the "View" button and inspect the certificate
    check who is the issuer of the certificate

You can see details like intermediate certificates that are used in the Delete tab.

You can check the connection settings.

See "Firefox connection settings":

Hi ses716 Could you please start a new thread for your question? Then you can provide more information like your operating system and installed extensions and installed plugins. *[[/questions/new start a new thread]] *[[/kb/Using+the+Troubleshooting+Information+page]] ---- You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates. *click "Advanced" to expand the error message *click "Add Exception" to open "Add Security Exception" If this isn't possible then open "Add Security Exception" by pasting this URL in the location/address bar and paste the URL of the website (https://xxx.xxx) in it's location field. *<b>chrome://pippki/content/exceptionDialog.xul</b> Let Firefox retrieve the certificate -> "Get Certificate" *click the "View" button and inspect the certificate<br>check who is the issuer of the certificate You can see details like intermediate certificates that are used in the Delete tab. You can check the connection settings. *Firefox > Preferences > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can
motelminder 0 solutions 1 answers

T am getting this when trying to view my new site: I use AVG if that is important. Just can't seem to fix it. I have deleted cache

HELP PLEASE


Your connection is not secure

The owner of www.motelminder.nz has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

Learn more…

www.motelminder.nz uses an invalid security certificate.

The certificate is only valid for the following names:

 *.au.syrahost.com, au.syrahost.com 

(Error code: ssl_error_bad_cert_domain)

T am getting this when trying to view my new site: I use AVG if that is important. Just can't seem to fix it. I have deleted cache HELP PLEASE Your connection is not secure The owner of www.motelminder.nz has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. Learn more… www.motelminder.nz uses an invalid security certificate. The certificate is only valid for the following names: *.au.syrahost.com, au.syrahost.com (Error code: ssl_error_bad_cert_domain)

Modified by motelminder

philipp
  • Top 25 Contributor
  • Moderator
5129 solutions 22719 answers

@motelminder, please open a new question: https://support.mozilla.org/questions/new

your issue won't get any attention at the end of an already solved thread. thank you for your understanding!

@motelminder, please open a new question: https://support.mozilla.org/questions/new your issue won't get any attention at the end of an already solved thread. thank you for your understanding!