X
Tap here to go to the mobile version of the site.

Support Forum

Self-Destructing Cookies add-on icon not visible

Posted

Windows 7 with all updates Firefox ver 43.0.3 Self-Destructing Cookies (SDC) add-on ver 0.4.9 Firefox set to remember history SDC is enabled and working No other add-ons enabled

Problem: SDC icon not visible

I have used SDC for a couple years and recently changed computers from XP to Win 7. The SDC icon is needed to easily change settings for each website I visit.

T. Howard

Windows 7 with all updates Firefox ver 43.0.3 Self-Destructing Cookies (SDC) add-on ver 0.4.9 Firefox set to remember history SDC is enabled and working No other add-ons enabled Problem: SDC icon not visible I have used SDC for a couple years and recently changed computers from XP to Win 7. The SDC icon is needed to easily change settings for each website I visit. T. Howard

Chosen solution

You can open the Browser Console (Firefox menu button or Tools > Web Developer) after starting Firefox and check for error messages about this extension.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Shockwave Flash 20.0 r0
  • VLC media player Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

FredMcD
  • Top 10 Contributor
4259 solutions 59631 answers

Enter about:config into your Firefox address bar Click the I'll be careful button Find xpinstall.signatures.required in the list Right click the preference Select Toggle until the value is false


Make sure the add-on is activated.


Type about:customizing<Enter> in the address bar. In the new window, look for the icon. When you find it, hold down the left button on it, and move it to where you want it to be. You can move any of the icons you want from here, but some icons are locked in place.

Enter '''about:config''' into your Firefox address bar Click the ''I'll be careful'' button Find '''xpinstall.signatures.required''' in the list Right click the preference Select Toggle until the value is false ---------------- Make sure the add-on is activated. ----------------- Type '''about:customizing'''<Enter> in the address bar. In the new window, look for the icon. When you find it, hold down the left button on it, and move it to where you want it to be. You can move any of the icons you want from here, but '''some icons are locked in place.'''

Question owner

Thanks for the reply. I toggled "xpinstall.signatures.required" to false, restarted Firefox and the icon is not visible when in customize.

T. Howard

Thanks for the reply. I toggled "xpinstall.signatures.required" to false, restarted Firefox and the icon is not visible when in customize. T. Howard
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158563 answers

Does the extension show as installed and enabled on the about:addons page?

Open the Customize window and set which toolbar items to display.

  • "3-bar" menu button > Customize
  • if missing items are in the Customize palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button to restore the default toolbar setup

Try to reset this pref on the about:config page via the right-click context menu to the default value.

  • browser.uiCustomization.state

Close and restart Firefox to make the change effective.

Does the extension show as installed and enabled on the about:addons page? Open the Customize window and set which toolbar items to display. *"3-bar" menu button > Customize *if missing items are in the Customize palette then drag them back from the Customize window on the toolbar *if you do not see an item on a toolbar and in the Customize palette then click the <u>Restore Defaults</u> button to restore the default toolbar setup Try to reset this pref on the <b>about:config</b> page via the right-click context menu to the default value. *browser.uiCustomization.state Close and restart Firefox to make the change effective.
FredMcD
  • Top 10 Contributor
4259 solutions 59631 answers

https://addons.mozilla.org/en-US/firefox/addon/self-destructing-cookies/

There are reports here of trouble. Check with it's support site.

https://addons.mozilla.org/en-US/firefox/addon/self-destructing-cookies/ There are reports here of trouble. Check with it's support site.

Question owner

The Add-on shows to be installed and enabled on the about:addons page

I did reset "browser.uiCustomization.state"

Now, I see "Self-Destructing Cookies" in "Additional Tools and Features" of the "Customize" window but there is no icon to go with the text. I attempt to drag the text to the toolbar and the other icons do not shift as though I am not really dragging an icon.

After closing the Customize window, the SDC Icon is not displayed.

The Add-on shows to be installed and enabled on the about:addons page I did reset "browser.uiCustomization.state" Now, I see "Self-Destructing Cookies" in "Additional Tools and Features" of the "Customize" window but there is no icon to go with the text. I attempt to drag the text to the toolbar and the other icons do not shift as though I am not really dragging an icon. After closing the Customize window, the SDC Icon is not displayed.
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158563 answers

Chosen Solution

You can open the Browser Console (Firefox menu button or Tools > Web Developer) after starting Firefox and check for error messages about this extension.

You can open the Browser Console (Firefox menu button or Tools > Web Developer) after starting Firefox and check for error messages about this extension. *https://developer.mozilla.org/Tools/Browser_Console

Question owner

I was using the Firefox default theme. I installed another theme and now I have the SDC icon. Thanks for all the suggestions.

T. Howard

I was using the Firefox default theme. I installed another theme and now I have the SDC icon. Thanks for all the suggestions. T. Howard
FredMcD
  • Top 10 Contributor
4259 solutions 59631 answers

Contact their support and tell them about it.

Contact their support and tell them about it.