Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't restore the pre-FF34 search bar, even going through about:config doesn't help.

  • 4 replies
  • 20 have this problem
  • 137 views
  • Last reply by malendras

more options

Today, my search bar randomly reverted to the post-FF34 "new" search bar. Despite repeatedly toggling the browser.search.showoneoffbuttons in about:config, and restarting the browser about a dozen times, it stubbornly stays with the new search. Does anyone know how to get it to stick on the old search? Or get the about:config toggle to work again?

Chosen solution

The underlying code which the browser.search.showOneOffbuttons used was removed from Firefox 43 - there is no way to revert to the older Search scheme.

From what I have read here, this extension - https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ - restores the old Search Bar scheme - but I haven't tried it yet, I switched to ESR 38 when Firefox 41 was released.

Read this answer in context 👍 2

All Replies (4)

more options

Chosen Solution

The underlying code which the browser.search.showOneOffbuttons used was removed from Firefox 43 - there is no way to revert to the older Search scheme.

From what I have read here, this extension - https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ - restores the old Search Bar scheme - but I haven't tried it yet, I switched to ESR 38 when Firefox 41 was released.

more options

Just installed CTR to check it out.

CTR Options > General UI (1) -> Old search (experimental)

more options

What are the features of the old bar that you miss in the new bar? There has been a lot of development on the new bar over the course of the year and if there are still issues that need to be worked out, there might be information in the bug tracking system about their status.

more options

Beautiful. Classic theme restorer worked perfectly! Ironically I already had it installed for layout reasons, never knew that was a feature. Thanks!

Modified by malendras