X
Tap here to go to the mobile version of the site.

Support Forum

I can't restore the pre-FF34 search bar, even going through about:config doesn't help.

Posted

Today, my search bar randomly reverted to the post-FF34 "new" search bar. Despite repeatedly toggling the browser.search.showoneoffbuttons in about:config, and restarting the browser about a dozen times, it stubbornly stays with the new search. Does anyone know how to get it to stick on the old search? Or get the about:config toggle to work again?

Today, my search bar randomly reverted to the post-FF34 "new" search bar. Despite repeatedly toggling the browser.search.showoneoffbuttons in about:config, and restarting the browser about a dozen times, it stubbornly stays with the new search. Does anyone know how to get it to stick on the old search? Or get the about:config toggle to work again?

Chosen solution

The underlying code which the browser.search.showOneOffbuttons used was removed from Firefox 43 - there is no way to revert to the older Search scheme.

From what I have read here, this extension - https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ - restores the old Search Bar scheme - but I haven't tried it yet, I switched to ESR 38 when Firefox 41 was released.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Google Update
  • np-mswmp
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Sony Reader Application Detector Plugin
  • Shockwave Flash 20.0 r0
  • 5.1.41105.0
  • VLC media player Web Plugin
  • iTunes Detector Plug-in

Application

  • Firefox 43.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • Support URL: https://support.mozilla.org/1/firefox/43.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Classic Theme Restorer 1.4.4 (ClassicThemeRestorer@ArisT2Noia4dev)
  • DownThemAll! 2.0.18.1-signed.1-let-fixed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Ghostery 5.4.9 (firefox@ghostery.com)
  • Image Zoom 0.6.3.1-signed ({1A2D0EC4-75F5-4c91-89C4-3656F6E44B68})
  • StumbleUpon 4.21 ({AE93811A-5C9A-4d34-8462-F7B864FC4696})
  • Tumblr Savior 0.4.22.1-signed (jid1-W5guVoyeUR0uBg@jetpack)
  • Video DownloadHelper 5.4.2 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Forecastfox 2.2.4 ({0538E3E3-7E9B-4d49-8831-A227C80A7AD3}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 750 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x1380
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 362d1458
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: D [ Gamma: 1000 Pixel Structure: R ClearType Level: 50 Enhanced Contrast: 0 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 10-2-2015
  • driverDate2:
  • driverVersion: 10.18.13.5850
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 750 Ti Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 solutions 40140 answers

Chosen Solution

The underlying code which the browser.search.showOneOffbuttons used was removed from Firefox 43 - there is no way to revert to the older Search scheme.

From what I have read here, this extension - https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ - restores the old Search Bar scheme - but I haven't tried it yet, I switched to ESR 38 when Firefox 41 was released.

The underlying code which the '''browser.search.showOneOffbuttons''' used was removed from Firefox 43 - there is no way to revert to the older Search scheme. From what I have read here, this extension - https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ - restores the old Search Bar scheme - but I haven't tried it yet, I switched to ESR 38 when Firefox 41 was released.
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 solutions 40140 answers

Just installed CTR to check it out.

CTR Options > General UI (1) -> Old search (experimental)

Just installed CTR to check it out. CTR Options > General UI (1) -> Old search (experimental)
jscher2000
  • Top 10 Contributor
8689 solutions 71031 answers

What are the features of the old bar that you miss in the new bar? There has been a lot of development on the new bar over the course of the year and if there are still issues that need to be worked out, there might be information in the bug tracking system about their status.

What are the features of the old bar that you miss in the new bar? There has been a lot of development on the new bar over the course of the year and if there are still issues that need to be worked out, there might be information in the bug tracking system about their status.

Question owner

Beautiful. Classic theme restorer worked perfectly! Ironically I already had it installed for layout reasons, never knew that was a feature. Thanks!

Beautiful. Classic theme restorer worked perfectly! Ironically I already had it installed for layout reasons, never knew that was a feature. Thanks!

Modified by malendras