X
Tap here to go to the mobile version of the site.

Support Forum

I am using "always use private mode", but private brwosing per window doesn't work

Posted

Using Firefox 42, did the restore thing and also tried the private tab addon. Nothing helped. I want to use the always use private mode option, however, "new window" or "private window" gives me a window where all my logins are still active. I need to close Firefox and restart it to clean it. Working on different windows independent from each other is not possible, which is the opposite of what I'm trying to achieve. However i do accept cookies in the settings, anyways I don't think they should be available in a new private window. Any help? Actually this smells very buggy to me.

Using Firefox 42, did the restore thing and also tried the private tab addon. Nothing helped. I want to use the always use private mode option, however, "new window" or "private window" gives me a window where all my logins are still active. I need to close Firefox and restart it to clean it. Working on different windows independent from each other is not possible, which is the opposite of what I'm trying to achieve. However i do accept cookies in the settings, anyways I don't think they should be available in a new private window. Any help? Actually this smells very buggy to me.

Chosen solution

In Firefox, always use private mode means that nothing is recorded, like history, cookies and so on. Your login status is saved in a special cookie.

Type about:preferences#privacy<enter> in the address bar.

The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Active Logins

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0

More Information

FredMcD
  • Top 10 Contributor
4224 solutions 58977 answers

Chosen Solution

In Firefox, always use private mode means that nothing is recorded, like history, cookies and so on. Your login status is saved in a special cookie.

Type about:preferences#privacy<enter> in the address bar.

The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Active Logins

In Firefox, '''always use private mode''' means that nothing is recorded, like history, cookies and so on. Your login status is saved in a special cookie. Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History,''' select '''Use Custom Settings'''. At the bottom of the page, turn on '''Clear History When Firefox Closes.''' At the far right, press the '''Settings''' button. Turn on '''Active Logins'''
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Helpful Reply

In automatic private browsing, both new windows and new private windows are private windows; all private windows share a single temporary cookie jar.

If you are trying to log into the same site using different credentials, maybe this will work for you (I haven't tried it myself):

https://addons.mozilla.org/firefox/addon/multifox/

In automatic private browsing, both new windows and new private windows are private windows; all private windows share a single temporary cookie jar. If you are trying to log into the same site using different credentials, maybe this will work for you (I haven't tried it myself): https://addons.mozilla.org/firefox/addon/multifox/
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157344 answers

Note that Active Logins applies to servers that use basic authentication and doesn't apply to servers that use a cookie to recognize you.

Note that <i>Active Logins</i> applies to servers that use basic authentication and doesn't apply to servers that use a cookie to recognize you.