Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I updated win 7 with newest update and now my FF 42.0 is nothing but black screen and glitched menus, nor see any text. Is this a bug?

  • 3 replies
  • 2 have this problem
  • 21 views
  • Last reply by thedes45

more options

Hello Mozilla Friends,

Jeanny from the Netherlands here. I have used FF 42.0 with my Windows 7 laptop happily each day up until today. Yesterday I received a Windows Update and installed it overnight. Today, I am trying to use my Firefox 42 - but the entire program is nothing but black screen, glitched components and all the text is gone. I can't even access any menus or get to any options. Also experiencing several artifacts around the screen, which might indicate on a graphical bug. Have tried to use Chrome, Internet Explorer and Opera to see if the same problem persists, but all these browsers work fine. Of course I would still prefer to use Mozilla simply because I like the program and all my settings are stored here. ;)

What can I do to bring my Firefox back to life? It's kind of hard to explain what FF is showing me, so I uploaded a screenshot for you to see instead. Hopefully you can help me, as the weekend is around the corner and I would like to do some browsing! :)

Tnx in advance.

Attached screenshots

Chosen solution

hi jeannette123, probably that's an issue with hardware acceleration - please try updating your graphics driver, or in case this doesn't solve the issue or there is no new version available at the moment, disable hardware acceleration in the firefox menu ≡ > options > advanced > general (that setting will take a restart of the browser to take effect).

if the interface isn't usable at all, you could also run firefox in safemode first to get to this configuration option: Diagnose Firefox issues using Troubleshoot Mode

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

hi jeannette123, probably that's an issue with hardware acceleration - please try updating your graphics driver, or in case this doesn't solve the issue or there is no new version available at the moment, disable hardware acceleration in the firefox menu ≡ > options > advanced > general (that setting will take a restart of the browser to take effect).

if the interface isn't usable at all, you could also run firefox in safemode first to get to this configuration option: Diagnose Firefox issues using Troubleshoot Mode

more options

Hi Philipp,

Thank you ever so much. I found out about launching FF in safe mode, so I had been using that throughout the weekend. My display drivers are up-to-date, but I managed to disable hardware acceleration through the FF safe mode. Restarted my browser and pow - Firefox worked again. Hopefully it will stay stable with this setting unticked, but I'm happy to have found out what that toggle is useful for!

Thanks again from a happy FF user!

more options

Even with Hardware acceleration disabled, the intermittent black screen appears (first one tab and then the rest). So, this is not a universal solution.