Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firebox is very slow when switching between tabs, the more tabs the slower it gets, switching between Firefox windows is almost instantaneous.

  • 12 replies
  • 12 have this problem
  • 5324 views
  • Last reply by R.J.H

more options

This happens whatever each tab is displaying. For example, if I open, say, 8 default new tabs it takes about 5 seconds to switch between them although all they are showing are links to my 9 top sites. I've also noticed that opening a new tab takes longer the more I have open already. The problem is uniquely with the tabs. Browsing isn't any slower than usual and as I say above, switching between Firefox windows in unaffected.

Chosen solution

If it works in Safe Mode and in normal mode with all extensions (Firefox menu button/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via *"3-bar" menu button > Exit (Power button)

  • Windows: File > Exit
  • Mac: Firefox > Quit Firefox
  • Linux: File > Quit
Read this answer in context 👍 0

All Replies (12)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with the sessionstore.js file in the profile folder that stores session data. When sessionstore.js is deleted you lose App Tabs and Tab Groups and open tabs and you will have to recreate them, so if necessary make a note or bookmark them.

You can use this button to go to the current Firefox profile folder:


You can check for problems with the places.sqlite database file (bookmarks, history) in the Firefox profile folder.

If the Places Maintenance extension can't repair the places.sqlite database file then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database file from the most recent JSON backup in the bookmarkbackups folder.

Modified by cor-el

more options

Thanks for you suggestions, it seems there are at least two others with this problem. I had already tried Safe Mode and Places Maintenance without success. The latter ran OK but didn't fix the problem. I'm already using the default theme. At your suggestion I closed Firefox, renamed sessionstore.js to sessionstore.js.old and restarted Firefox. No better I'm afraid. Can I provide any further information that might be helpful?

more options

You can try to rename the places.sqlite file and the places.sqlite-shm and places.sqlite-wal files to see if that helps.

You can create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

I renamed places.sqlite to places.sqlite.old, it isn't possible to rename the other .sqlite-* files you mention because they seem to be deleted when Firefox is closed and recreated when it's opened again. They can't be renamed whilst Firefox is running.

I tried a Refresh which didn't solve the problem.

I then created a new profile, this didn't solve the problem either. It looks like this is something a bit more fundamental than a user profile problem.

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

—-- Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

more options

I disabled hardware acceleration but it made no discernible difference after I restarted the program. I found a much more recent version of my graphics driver, installed it and rebooted. There was no obvious improvement with or without hardware acceleration in Firefox. Finally, in safe mode Firefox works fine and the tabs switch as they should although of course the resolution is extremely low.

I might add that I've used Firefox ever since its inception and for over 4 years on the present PC (yes, I know I should get a new one!). I never had this problem until Firefox Version 41.0 arrived. When that was updated to Ver 42.0 it seemed to solve the issue for a short while but then it returned. Nothing else on the PC seems particularly slow.

more options

Chosen Solution

If it works in Safe Mode and in normal mode with all extensions (Firefox menu button/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via *"3-bar" menu button > Exit (Power button)

  • Windows: File > Exit
  • Mac: Firefox > Quit Firefox
  • Linux: File > Quit
more options

I thought I had already tried disabling extensions, either when I did a Refresh or when I created a new profile, since removed. Nevertheless I have done the following.

1) Disabled extensions, I only had one enabled which ironicallty was Places Maintenance. 2) Disabled all Plugins (ie set them to Never Activate). 3) Disabled the Dictionary I was using. 4) Double checked that I was definitely using the default theme. 5) Checked Services - I have none installed. 6) Switched off Hardware acceleration again. 7) Restarted Firefox.

The problem persists. With just two tabs switching is relatively quick although not as fast as window switching. The more tabs I open the slower the switching gets.

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

You can check for problems with the sessionstore.js file in the profile folder that stores session data. When sessionstore.js is deleted you lose App Tabs and Tab Groups and open tabs and you will have to recreate them, so if necessary make a note or bookmark them.

You can use this button to go to the current Firefox profile folder:


Firefox uses the sessionstore.js file in the profile folder to store session data, but this file is only present when Firefox is closed. The sessionstore.js file is created from recovery.js when you close Firefox and is removed and copied to previous.js when you start Firefox to make is possible to restore the session at any time.

You will normally find these files in the sessionstore-backups folder:

previous.js (cleanBackup: copy of sessionstore.js from previous session that was loaded successfully)
recovery.js (latest version of the sessionstore written during runtime)
recovery.bak (previous version of the sessionstore written during runtime)
upgrade.js-<build_id> (backup created during an upgrade of Firefox)

You can copy a file from the sessionstore-backups folder to the main profile and rename the file to sessionstore.js to replace the current file (make a backup copy of the current sessionstore.js).

See also:

more options

We have already established that tab switching seems to work OK in Windows safe mode but not in Firefox safe mode. Why this should be puzzles me.

I tried copying the upgrade.js file (upgrade.js-20151029151421) from the sessionstore-backups folder to the main profile and renaming it sessionstore.js. No improvement.

more options

What security software do you have?

It is possible that security (Anti-Virus, firewall) is causing problems. Try to disable security software temporarily to see if that makes a difference.

more options

My AV software is Sophos and I'm using Windows firewall. Firefox is already marked as an exception for the latter so that can't be having any effect.

I disabled Sophos on access scanning and behaviour monitoring and rebooted to be sure the changes had been applied. Tab switching is still slow.