X
Tap here to go to the mobile version of the site.

Support Forum

When I click on a link it will not open but but it goes to the downloads file on the taskbar. I need it to open like it used to.

Posted

When I used to click on a link a box opened up - "you have chosen to open:" and asked what Firefox should do with the file giving me a choice of "open with" or "save file". I would click "OK" on "open with" Microsoft Word and it would open. Now it does not do that. It just goes directly to the download icon and when i click on that it says its downloading the link. I've been able to go from there and get to the file and open it but most of the time it wont. Regardless, I would like it to open immediately like it did originally. I think i must have accidentally changed something somewhere but I have no clue. I'm very computer illiterate. I appreciate any help I get on this!

When I used to click on a link a box opened up - "you have chosen to open:" and asked what Firefox should do with the file giving me a choice of "open with" or "save file". I would click "OK" on "open with" Microsoft Word and it would open. Now it does not do that. It just goes directly to the download icon and when i click on that it says its downloading the link. I've been able to go from there and get to the file and open it but most of the time it wont. Regardless, I would like it to open immediately like it did originally. I think i must have accidentally changed something somewhere but I have no clue. I'm very computer illiterate. I appreciate any help I get on this!

Chosen solution

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the mimeTypes.rdf file. Then rename or delete it. Restart Firefox.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape
  • Bing Bar
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • 4.1.10329.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

More Information

FredMcD
  • Top 10 Contributor
4343 solutions 61082 answers

Chosen Solution

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the mimeTypes.rdf file. Then rename or delete it. Restart Firefox.

Deleting the '''mimeTypes.rdf''' will reset all download actions to the default settings. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the '''mimeTypes.rdf''' file. Then rename or delete it. Restart Firefox.
jscher2000
  • Top 10 Contributor
8888 solutions 72718 answers

Helpful Reply

In some cases, you can change the behavior on the Options page. The main difficulty is that it's sometimes hard to figure out the correct content type name.

"3-bar" menu button (or Tools menu) > Options

In the left column, click Applications. It may take 10-30 seconds for this to load up.

Then you can type word in the search/filter box above the list and Firefox should show just Word-related entries. On the right side, you can click the current selection ("Save File"?) and change it to something different such as "Always Ask".

If it's already set that way and Firefox isn't asking, please see FredMcD's post for next steps.

In some cases, you can change the behavior on the Options page. The main difficulty is that it's sometimes hard to figure out the correct content type name. "3-bar" menu button (or Tools menu) > Options In the left column, click Applications. It may take 10-30 seconds for this to load up. Then you can type ''word'' in the search/filter box above the list and Firefox should show just Word-related entries. On the right side, you can click the current selection ("Save File"?) and change it to something different such as "Always Ask". If it's already set that way and Firefox isn't asking, please see FredMcD's post for next steps.

Question owner

Thank you for your help but unfortunately that didn't work. I followed the steps you suggested but when I typed in "word" in the search box the content type and actions lists completely disappeared. I made it blank again and the lists reappeared so I clicked on "word" from the content type list and it highlighted it and when I clicked on "always ask" from the actions list it UN-highlighted "word" but put a box around "always ask" I didn't really know where to go from there so I closed options and tried to open a link again but its doing the same thing and not opening. Does all that make sense? Am I missing something? Thanks again for your help!

Thank you for your help but unfortunately that didn't work. I followed the steps you suggested but when I typed in "word" in the search box the content type and actions lists completely disappeared. I made it blank again and the lists reappeared so I clicked on "word" from the content type list and it highlighted it and when I clicked on "always ask" from the actions list it UN-highlighted "word" but put a box around "always ask" I didn't really know where to go from there so I closed options and tried to open a link again but its doing the same thing and not opening. Does all that make sense? Am I missing something? Thanks again for your help!

Question owner

Thanks Fred and Jscher for all your help! Fred-your solution worked. Yours may have worked also Jscher but I have a feeling I wasn't doing it correctly... Thanks again!

Thanks Fred and Jscher for all your help! Fred-your solution worked. Yours may have worked also Jscher but I have a feeling I wasn't doing it correctly... Thanks again!
FredMcD
  • Top 10 Contributor
4343 solutions 61082 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.