X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

HTTPS "Connection not secure" message when viewing yahoo mail website in firefox

Posted

I have a persistent problem with the yahoo mail page reporting the HTTPS connection is not secure. The green lock changes to a grey with yellow lock symbol as soon as I open an email.

It reports that: The website contains content that is not secure.

I can view yahoo mail website on IE without problems, but equally so, I have zero problems with any other HTTPS site when viewed via firefox. It seems there is some specific problem with yahoo mail on firefox and wanted to know if anybody else has seen this problem.

I have played around with disabling add ons, no effect.

I have a persistent problem with the yahoo mail page reporting the HTTPS connection is not secure. The green lock changes to a grey with yellow lock symbol as soon as I open an email. It reports that: The website contains content that is not secure. I can view yahoo mail website on IE without problems, but equally so, I have zero problems with any other HTTPS site when viewed via firefox. It seems there is some specific problem with yahoo mail on firefox and wanted to know if anybody else has seen this problem. I have played around with disabling add ons, no effect.

Chosen solution

hello, this will be caused by emails which embed content (like an image) that is loaded through a http-connection. the grey lock with the yellow warning still means that the data you view and enter on the site is secure and only transmitted to yahoo. firefox might be more proactive warning you about this than other browsers.

you can also set up firefox to block the loading of http-elements like images on an otherwise encrypted https-site - then the green lock should always stay in place on your mail: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.mixed_content.block_display_content. double-click it and change its value to true.

Mixed content blocking in Firefox

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.13
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Shockwave Flash 18.0 r0
  • VLC media player Web Plugin
  • Plug-in for Workspace Webmail

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/WINNT/en-GB/

Extensions

  • AdBlock Lite 0.2.7 (jid1-dwtFBkQjb3SIQp@jetpack)
  • Adblock Plus 2.6.13 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Block site 1.1.8.1-signed ({dd3d7613-0246-469d-bc65-2a3cc1668adc})
  • Disconnect 3.15.3.1-signed (2.0@disconnect.me)
  • Google Analytics Opt-out Browser Add-on 0.9.8 ({6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65})
  • HTTPS-Everywhere 5.1.0 (https-everywhere@eff.org)
  • HTTPSpatrol 0.1.8 (@httpspatrol)
  • toggle-mixed-active-content 2.0 (jid0-LfpuGtyvjqw5JxLBjdCjX5Fzorw@jetpack)
  • Video AdBlock for Firefox 1.0 ({a00bef25-f21a-4539-adbb-b179b29e2b92})
  • WBE Paste 1.3 (wbepaste@starfield)
  • bidbag Remote 1.9.1 (development@bidbag.de) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 0101106b
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 400
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 9-30-2014
  • driverDate2:
  • driverVersion: 10.18.10.3958
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 25 Contributor
  • Moderator
5330 solutions 23532 answers

Chosen Solution

hello, this will be caused by emails which embed content (like an image) that is loaded through a http-connection. the grey lock with the yellow warning still means that the data you view and enter on the site is secure and only transmitted to yahoo. firefox might be more proactive warning you about this than other browsers.

you can also set up firefox to block the loading of http-elements like images on an otherwise encrypted https-site - then the green lock should always stay in place on your mail: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.mixed_content.block_display_content. double-click it and change its value to true.

Mixed content blocking in Firefox

hello, this will be caused by emails which embed content (like an image) that is loaded through a http-connection. the grey lock with the yellow warning still means that the data you view and enter on the site is secure and only transmitted to yahoo. firefox might be more proactive warning you about this than other browsers. you can also set up firefox to block the loading of http-elements like images on an otherwise encrypted https-site - then the green lock should always stay in place on your mail: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''security.mixed_content.block_display_content'''. double-click it and change its value to '''true'''. [[Mixed content blocking in Firefox]]

Helpful Reply

That worked first time!!!!

Thank you so much philipp!

That worked first time!!!! Thank you so much philipp!
lansimivalley 0 solutions 3 answers

Thank you! This helped me too!

Thank you! This helped me too!
awdrifter 0 solutions 2 answers

I tried the solution and I'm still having the same issue. I can't even go to Google.

I tried the solution and I'm still having the same issue. I can't even go to Google.
philipp
  • Top 25 Contributor
  • Moderator
5330 solutions 23532 answers

@awdrifter: please open a new question for your problem - thank you! https://support.mozilla.org/questions/new

@awdrifter: please open a new question for your problem - thank you! https://support.mozilla.org/questions/new