X
Tap here to go to the mobile version of the site.

Support Forum

How do I enable Javascript?

Posted

For online editing the proof of a mathematics article, the website of the journal (Geometriae Mathematica) says I need to enable Javascript, by doing the following:

" In Edit menu –>Preferences->Advanced->Scripts & Plug-ins -> if Navigator check box is unchecked, check the tick box."

But I don't see "Scripts & Plugins" anywhere.

Please advise.

For online editing the proof of a mathematics article, the website of the journal (Geometriae Mathematica) says I need to enable Javascript, by doing the following: " In Edit menu –>Preferences->Advanced->Scripts & Plug-ins -> if Navigator check box is unchecked, check the tick box." But I don't see "Scripts & Plugins" anywhere. Please advise.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/Linux/en-US/

Extensions

  • Advertising Cookie Opt-out 1.5 (optout@google.com)
  • LastFM 1.0.3.9 ({82BC70E0-FE85-11DA-A899-3A655C103D30})
  • Ubuntu Modifications 3.2 (ubufox@ubuntu.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: X.Org -- Gallium 0.4 on AMD PALM
  • adapterDeviceID: Gallium 0.4 on AMD PALM
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • driverDate:
  • driverVersion: 3.0 Mesa 10.1.3
  • info: {u'CairoUseXRender': 1, u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: X.Org -- Gallium 0.4 on AMD PALM
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

Helpful Reply

I don't think those instructions are for Firefox.

When you install Firefox, JavaScript is enabled by default. To confirm that it is enabled, you can check this hidden setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste javas and pause while the list is filtered

(3) If the javascript.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true


Usually when only one website says that JavaScript is not enabled, it is merely guessing at the source of a problem that is caused by something else, such as a missing plugin or blocked content.

Can you give a link to the page where you get this message and indicate the steps that invoked it?

I don't think those instructions are for Firefox. When you install Firefox, JavaScript is enabled by default. To confirm that it is enabled, you can check this hidden setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''javas''' and pause while the list is filtered (3) If the '''javascript.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true ---- Usually when only one website says that JavaScript is not enabled, it is merely guessing at the source of a problem that is caused by something else, such as a missing plugin or blocked content. Can you give a link to the page where you get this message and indicate the steps that invoked it?

Question owner

I followed (1), (2), and (3). The Preference javascript.enabled is not bolded; its Status is "default". Its Value is "true".

I can't link you to the page where I got the message. The journal's email to me says:

"The URL is valid only until your paper is published online. It is for proof purposes only and may not be used by third parties."

Thanks for your help.

I followed (1), (2), and (3). The Preference javascript.enabled is not bolded; its Status is "default". Its Value is "true". I can't link you to the page where I got the message. The journal's email to me says: "The URL is valid only until your paper is published online. It is for proof purposes only and may not be used by third parties." Thanks for your help.
jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

Could you check with the Journal on whether that page requires any special plugins to enable equation editing?

You might also try in another browser if time is of the essence.

Could you check with the Journal on whether that page requires any special plugins to enable equation editing? You might also try in another browser if time is of the essence.