X
Tap here to go to the mobile version of the site.

Support Forum

firefox cannot install Video Download Helper,

Posted

after downloading video download helper,firefox asks to install now,when i do it tells me it,firefox,cannot install

after downloading video download helper,firefox asks to install now,when i do it tells me it,firefox,cannot install

Chosen solution

thank you FredMcD deleting the files you suggested has solved the problem. agan,thanks mate

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • npdivxplayerplugin
  • DivX Web Player version 1.4.2.7
  • DivX® Content Upload Plugin
  • Google Update
  • MetaStream 3 Plugin r4
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • 5.1.30514.0
  • Version 1.1.4, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Windows NT 4.0; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce4 MX 420 (Microsoft Corporation)
  • adapterDescription2:
  • adapterDeviceID: 0x0172
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 02ab1043
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 4-7-2004
  • driverDate2:
  • driverVersion: 5.6.7.3
  • driverVersion2:
  • failures: [u'[GFX1]: [D3D9] insufficient capabilities', u'[GFX1]: [D3D9] insufficient capabilities', u'[GFX1]: [D3D9] Could not Initialize the DeviceManagerD3D9', u'[GFX1]: [D3D9] Could not Initialize the DeviceManagerD3D9', u'[GFX1]: [D3D9] insufficient capabilities', u'[GFX1]: [D3D9] Could not Initialize the DeviceManagerD3D9']
  • indices: [0, 6, 7, 3, 4, 5]
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRendererMessage: [u'']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4314 solutions 60593 answers

I have it on my system. No problem. Contact it's support site.

I have it on my system. No problem. Contact it's support site.
cor-el
  • Top 10 Contributor
  • Moderator
17697 solutions 160119 answers

Your user agent shows that you run Firefox in compatibility mode for Windows 95 (NT 4.0).

Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Your user agent shows that you run Firefox in compatibility mode for Windows 95 (NT 4.0). Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Question owner

cor-el said

Your user agent shows that you run Firefox in compatibility mode for Windows 95 (NT 4.0). Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

still no joy.the following always pops up after clicking install now Video Download Helper could not be installed because Firefox cannot modify the needed file.thanks anyways

''cor-el [[#answer-804771|said]]'' <blockquote> Your user agent shows that you run Firefox in compatibility mode for Windows 95 (NT 4.0). Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window. </blockquote> still no joy.the following always pops up after clicking install now Video Download Helper could not be installed because Firefox cannot modify the needed file.thanks anyways
FredMcD
  • Top 10 Contributor
4314 solutions 60593 answers

Helpful Reply

Does it say what file?

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

Does it say what file? It is possible that there is a problem with the file(s) that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons

Chosen Solution

thank you FredMcD deleting the files you suggested has solved the problem. agan,thanks mate

thank you FredMcD deleting the files you suggested has solved the problem. agan,thanks mate