X
Tap here to go to the mobile version of the site.

Support Forum

Have just upgraded to Firefox 42.0 and background color setting does not work anymore - a blank window is forever white.

Posted

I've just upgraded to Firefox 42.0 and, unlike previous versions, the background color setting in "Content" does not work anymore. On the setting page the "Background color" indicator does change to the color I select (not the white one) from the color theme choices, but whenever I open a blank window the background color is always white. Then, when I go back to the setting page to check, that indicator still shows the color I have chosen. And whether I tick the "Use the system color" box or not tick it, the result remains the same -- the background color of a blank window is always white.

This is a problem I have never encountered before. I would like to find out why.

Thank you for any help.

I've just upgraded to Firefox 42.0 and, unlike previous versions, the background color setting in "Content" does not work anymore. On the setting page the "Background color" indicator does change to the color I select (not the white one) from the color theme choices, but whenever I open a blank window the background color is always white. Then, when I go back to the setting page to check, that indicator still shows the color I have chosen. And whether I tick the "Use the system color" box or not tick it, the result remains the same -- the background color of a blank window is always white. This is a problem I have never encountered before. I would like to find out why. Thank you for any help.

Chosen solution

You can make that one rule:

@-moz-document url(about:blank), url(about:newtab){ html,body {background-color: #ccc !important } }
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Web player NPPlugin
  • Baofeng Web Browser plugin
  • Google Update
  • Shockwave Flash 19.0 r0
  • 2.0.587.11
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:42.0) Gecko/20100101 Firefox/42.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16332 solutions 147379 answers

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

This setting affects background images.

See also:

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings. Make sure that you allow pages to choose their own colors. *Tools > Options > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above" Try "Never" if the default "Only with High Contrast themes" isn't working. This setting affects background images. See also: *http://kb.mozillazine.org/Website_colors_are_wrong

Question owner

Thanks for your reply, but this doesn't solve the problem. Actually when I posted the question two days ago I had already chosen "Never" (the other two options had already been tried before and had not worked).

As to the High Contrast theme, I have never chosen such a theme on my system (Windows XP) -- in fact the previous version of my Firefox didn't have this problem at all, i.e., if I selected a background color, then I got it right away. All this changed after I upgraded to the current version 4.20. I really should have ignored the upgrading notice!

Thanks for your reply, but this doesn't solve the problem. Actually when I posted the question two days ago I had already chosen "Never" (the other two options had already been tried before and had not worked). As to the High Contrast theme, I have never chosen such a theme on my system (Windows XP) -- in fact the previous version of my Firefox didn't have this problem at all, i.e., if I selected a background color, then I got it right away. All this changed after I upgraded to the current version 4.20. I really should have ignored the upgrading notice!
cor-el
  • Top 10 Contributor
  • Moderator
16332 solutions 147379 answers

Maybe set the code for the about:blank page via userContent.css.

Add code to the userContent.css file.


/* about:blank */
@-moz-document url(about:blank){ html,body {background-color: #ccc !important } }

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userContent.css file in the editor window
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.
    Otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file
Maybe set the code for the about:blank page via userContent.css. Add code to the <b>userContent.css</b> file. *http://kb.mozillazine.org/userContent.css ---- <pre><nowiki>/* about:blank */ @-moz-document url(about:blank){ html,body {background-color: #ccc !important } }</nowiki></pre> ---- The customization files userChrome.css (user interface) and userContent.css (websites) are located in the <b>chrome</b> folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *Use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file name is case sensitive) *Paste the code in the userContent.css file in the editor window *Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.<br>Otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file

Question owner

Hi there,

First I should thank you for your advice. I opened the Firefox profile folder, but there was no folder named "chrome" (My operating system is Windows XP). There were altogether 13 folders as follows -

- bookmarkbackups - crashes - datareporting - extensions - gmp - gmp-gmpopen264 - healthreport - jetpack - minidumps - saved-telemetry-pings - sessionstore-backups - storage - webapps

As you can see, I couldn't determine which one is what you described as the "<xxxxxxxx>.default profile folder". I opened all these folders to check and found in the "storage" folder there were three folders -

- default - permanent - temporary

And I found a folder named chrome in the "permanent" folder. So I assumed this was the folder where the userContent.css file should be created. I then created such a file exactly according to your instruction (opening a notepad and pasting the code you have provided and saved it (All files) as userContent.css, but after I closed Firefox and relaunched it again, nothing changed. I checked the background color setting page, and every setting remains the same (i.e., the selected color is still shown as black, "Use system color" is ticked (un-ticking it doesn't make any difference), and "Never override the color ..." is selected). When I open a blank window, the color is still white.

What should I try next?

I must add that you said, "The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder." However, I thoroughly searched this folder named chrome, and there is no such a file named userChrome.css. Is this actually the problem?

Hi there, First I should thank you for your advice. I opened the Firefox profile folder, but there was no folder named "chrome" (My operating system is Windows XP). There were altogether 13 folders as follows - - bookmarkbackups - crashes - datareporting - extensions - gmp - gmp-gmpopen264 - healthreport - jetpack - minidumps - saved-telemetry-pings - sessionstore-backups - storage - webapps As you can see, I couldn't determine which one is what you described as the "<xxxxxxxx>.default profile folder". I opened all these folders to check and found in the "storage" folder there were three folders - - default - permanent - temporary And I found a folder named '''chrome ''' in the "permanent" folder. So I assumed this was the folder where the userContent.css file should be created. I then created such a file exactly according to your instruction (opening a notepad and pasting the code you have provided and saved it (All files) as userContent.css, but after I closed Firefox and relaunched it again, nothing changed. I checked the background color setting page, and every setting remains the same (i.e., the selected color is still shown as black, "Use system color" is ticked (un-ticking it doesn't make any difference), and "Never override the color ..." is selected). When I open a blank window, the color is still '''white'''. What should I try next? I must add that you said, "The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder." However, I thoroughly searched this folder named '''chrome''', and there is no such a file named userChrome.css. Is this actually the problem?
cor-el
  • Top 10 Contributor
  • Moderator
16332 solutions 147379 answers

You need to create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\chrome\userContent.css
  • Use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file and folder names are case sensitive)

Make sure to select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css to prevent Windows from adding a hidden .txt file extension that would make you end up with a not working userChrome.css.txt file.

You need to create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\Profiles\&lt;profile&gt;\chrome\userContent.css *Use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file and folder names are case sensitive) Make sure to select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css to prevent Windows from adding a hidden .txt file extension that would make you end up with a not working userChrome.css.txt file.

Question owner

Hi there,

I have created the chrome folder in the <xxxxxxxx>.default folder (C:\Documents and Settings\Administrator\Application Data\Mozilla\Firefox\Profiles\vjyy1vzn.default), then moved the userContent.css file I had created earlier today into this chrome folder (file created exactly as you have said). So far it has not worked. If I still need to create a userChrome.css file in the same chrome folder, please provide the code for this file (I can't find it in your reply).

Thank you.

Hi there, I have created the chrome folder in the <xxxxxxxx>.default folder (C:\Documents and Settings\Administrator\Application Data\Mozilla\Firefox\Profiles\vjyy1vzn.default), then moved the userContent.css file I had created earlier today into this chrome folder (file created exactly as you have said). So far it has not worked. If I still need to create a '''userChrome.css''' file in the same chrome folder, please provide the '''code''' for this file (I can't find it in your reply). Thank you.
jscher2000
  • Top 10 Contributor
7376 solutions 60084 answers

Hmm, the internal blank page (named "about:blank") definitely should follow your default background color setting.

How are you opening a blank window? Are you setting your home page to a blank page?

Hmm, the internal blank page (named "about:blank") definitely should follow your default background color setting. How are you opening a blank window? Are you setting your home page to a blank page?

Question owner

I just click on that "+" to open a new tab which is a blank window, but the background color is always white despite the fact it has already been set as black, blue, etc. On the background color setting page the selected color is always shown, but any new blank window doesn't follow it. Very strange indeed. This happened only recently when I upgraded to Firefox 42.0.

I just click on that "+" to open a new tab which is a blank window, but the background color is always white despite the fact it has already been set as black, blue, etc. On the background color setting page the selected color is always shown, but any new blank window doesn't follow it. Very strange indeed. This happened only recently when I upgraded to Firefox 42.0.
jscher2000
  • Top 10 Contributor
7376 solutions 60084 answers

Oh, okay, I was taking "window" literally to mean a separate window. New windows (Ctrl+n) show your home page(s).

Is your "new tab page" completely blank or does it have the "gear" or "wheel" icon in the corner that lets you choose between top sites and a blank page? In other words, is it the built-in Firefox new tab page, or some other page?

To determine the internal address of the page, you can right-click it and choose View Page Info. The address should appear on the first panel ("General").

Oh, okay, I was taking "window" literally to mean a separate window. New windows (Ctrl+n) show your home page(s). Is your "new tab page" completely blank or does it have the "gear" or "wheel" icon in the corner that lets you choose between top sites and a blank page? In other words, is it the built-in Firefox new tab page, or some other page? To determine the internal address of the page, you can right-click it and choose View Page Info. The address should appear on the first panel ("General").

Question owner

To answer your question:

1) Whether a separate new window or a new tab, the background color is always white.

2) The blank page is the built-in Firefox new tab page, and I have long selected "Show blank page" from the drop-down menu after clicking the wheel.

To answer your question: 1) Whether a separate new window or a new tab, the background color is always white. 2) The blank page is the built-in Firefox new tab page, and I have long selected "Show blank page" from the drop-down menu after clicking the wheel.
cor-el
  • Top 10 Contributor
  • Moderator
16332 solutions 147379 answers

The browser.newtab.url pref is no longer supported in Firefox 41 and later, so you can no longer use this to set the new tab page.

You can look at this extension to set the new tab page:

You can set the new tab URL setting via the Options/Preferences of the extension on the about:addons page.

You can look at this extension if you use the home page as the new tab page.

Classic Theme Restorer includes this feature as well. In current CTR versions (1.3.9+) you find "New tab page url" in the Tabs (1) section.

You can use these special pages for the new tab page or use the URL of a web page. the default new tab page with the tiles is about:newtab

  • the default home page is about:home
  • for a blank page you can use about:blank
  • for Super Start you can use about:superstart
The <b>browser.newtab.url</b> pref is no longer supported in Firefox 41 and later, so you can no longer use this to set the new tab page. You can look at this extension to set the new tab page: *New Tab Override: https://addons.mozilla.org/firefox/addon/new-tab-override/ You can set the new tab URL setting via the Options/Preferences of the extension on the about:addons page. You can look at this extension if you use the home page as the new tab page. *New Tab Homepage: https://addons.mozilla.org/firefox/addon/new-tab-homepage/ Classic Theme Restorer includes this feature as well. In current CTR versions (1.3.9+) you find "New tab page url" in the Tabs (1) section. You can use these special pages for the new tab page or use the URL of a web page. the default new tab page with the tiles is <b>about:newtab</b> *the default home page is <b>about:home</b> *for a blank page you can use <b>about:blank</b> *for Super Start you can use <b>about:superstart</b>
jscher2000
  • Top 10 Contributor
7376 solutions 60084 answers

charlie323 said

2) The blank page is the built-in Firefox new tab page, and I have long selected "Show blank page" from the drop-down menu after clicking the wheel.

In that case, I think you need to duplicate the rule cor-el provided, list that additional page, and add it to your userContent.css file:

@-moz-document url(about:blank){ html,body {background-color: #ccc !important } } @-moz-document url(about:newtab){ html,body {background-color: #ccc !important } }

Does that work?

''charlie323 [[#answer-804494|said]]'' <blockquote>2) The blank page is the built-in Firefox new tab page, and I have long selected "Show blank page" from the drop-down menu after clicking the wheel.</blockquote> In that case, I think you need to duplicate the rule cor-el provided, list that additional page, and add it to your userContent.css file: <code>@-moz-document url('''about:blank'''){ html,body {background-color: #ccc !important } } @-moz-document url('''about:newtab'''){ html,body {background-color: #ccc !important } }</code> Does that work?
cor-el
  • Top 10 Contributor
  • Moderator
16332 solutions 147379 answers

Chosen Solution

You can make that one rule:

@-moz-document url(about:blank), url(about:newtab){ html,body {background-color: #ccc !important } }
You can make that one rule: <pre><nowiki>@-moz-document url(about:blank), url(about:newtab){ html,body {background-color: #ccc !important } }</nowiki></pre>

Question owner

Hi cor-el,

Thanks for your advice. I have installed the New Tab Override extension and reset the new tab URL as "about:blank", and this time it works!

Again, thank you very much!

Hi cor-el, Thanks for your advice. I have installed the New Tab Override extension and reset the new tab URL as "about:blank", and this time it works! Again, thank you very much!

Question owner

Hi jscher2000,

The problem has been solved (re: my above reply to cor-el). Anyway thank you very much for your care and help!

Hi jscher2000, The problem has been solved (re: my above reply to cor-el). Anyway thank you very much for your care and help!