X
Tap here to go to the mobile version of the site.

Support Forum

Every time I start Firefox after rebooting my PC it asks me to re-enable all of my add-ons; started about 3 or 4 days ago.

Posted

I have already tried deleting the extensions.* files and refreshing Firefox (the latter which caused me to have to re-install all my add-ons, BTW). Happens only after I reboot my PC. What, if anything, has changed in the past few days...?

I have already tried deleting the extensions.* files and refreshing Firefox (the latter which caused me to have to re-install all my add-ons, BTW). Happens only after I reboot my PC. What, if anything, has changed in the past few days...?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.13
  • Amazon MP3 Downloader Plugin 1.0.17
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Facebook Video Calling Plugin
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.9.159
  • 5.1.40728.0
  • VLC media player Web Plugin 2.1.3
  • wpidetector
  • WildTangent Games App V2 Presence Detector
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Helpful Reply

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

It is possible that there is a problem with the file(s) that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons

Question owner

Many thanks! I had deleted the extensions.* files, but had failed to delete compatibility.ini. Seems to have done the trick! :-D

Many thanks! I had deleted the extensions.* files, but had failed to delete compatibility.ini. Seems to have done the trick! :-D
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Glad to help. Safe surfing.

Glad to help. Safe surfing.

Question owner

Apparently I spoke too soon. Same problem when I booted up this morning. :-/

Apparently I spoke too soon. Same problem when I booted up this morning. :-/
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Reboot again. Same problem?

Reboot again. Same problem?

Question owner

Yep, every time I reboot. I'm stumped. And I'm unwilling to give up Firefox. I'd hate to uninstall and reinstall because that's a lot of hoops to jump through and my gut tells me it will not resolve the issue. I did try refreshing Firefox, but that didn't help either. I'm open to suggestion. Gonna try running a scan of my system in the meantime... Thanks!

Yep, every time I reboot. I'm stumped. And I'm unwilling to give up Firefox. I'd hate to uninstall and reinstall because that's a lot of hoops to jump through and my gut tells me it will not resolve the issue. I did try refreshing Firefox, but that didn't help either. I'm open to suggestion. Gonna try running a scan of my system in the meantime... Thanks!
cor-el
  • Top 10 Contributor
  • Moderator
17472 solutions 157915 answers

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

I'll give this a shot this evening when I get home from work and let you know the results. Thanks for the suggestion and your patience!

I'll give this a shot this evening when I get home from work and let you know the results. Thanks for the suggestion and your patience!

Question owner

Ack! Exact same issue after creating a new profile. This did not happen until the latest Firefox update, BTW. Just sayin'... I'm not sure what else to do at this point short of a total uninstall/re-install. Or just living with it. I'm still open to suggestion. :-/

Ack! Exact same issue after creating a new profile. This did not happen until the latest Firefox update, BTW. Just sayin'... I'm not sure what else to do at this point short of a total uninstall/re-install. Or just living with it. I'm still open to suggestion. :-/

Question owner

Just to follow up, I did a complete un-install and re-installed several times in order to make sure the issue was not related to any one, specific add-on. It is not. I am now convinced that this problem is the direct result of the most recent update to Firefox since it occurs with every single add-on I've tested. And I'd be shocked if I'm the only user having this problem. Guess I'll wait and see whether this ever gets addressed. I'd hate to give up Firefox, but it may come to that.

Just to follow up, I did a complete un-install and re-installed several times in order to make sure the issue was not related to any one, specific add-on. It is not. I am now convinced that this problem is the direct result of the most recent update to Firefox since it occurs with every single add-on I've tested. And I'd be shocked if I'm the only user having this problem. Guess I'll wait and see whether this ever gets addressed. I'd hate to give up Firefox, but it may come to that.
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.

Question owner

Greatly appreciated. Thanks!

Greatly appreciated. Thanks!
cor-el
  • Top 10 Contributor
  • Moderator
17472 solutions 157915 answers

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software. You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences

Question owner

One (hopefully) final update: The problem appears to have inexplicably resolved itself. Not sure if there was a patch installed, since I accept updates automatically, but the issue has not recurred in the past few days. Keeping my fingers crossed. Thanks for everyone's patience and suggestions!

One (hopefully) final update: The problem appears to have inexplicably resolved itself. Not sure if there was a patch installed, since I accept updates automatically, but the issue has not recurred in the past few days. Keeping my fingers crossed. Thanks for everyone's patience and suggestions!
philipwatling 0 solutions 13 answers

I have had this problem for a while and though it is a pain opening the add-ons and enabling them each time, it is manageable - and simpler than all this advice which may or may not work. This never happened before my current version of Firefox (42?) so I hope it is ironed out on the next version :)

I have had this problem for a while and though it is a pain opening the add-ons and enabling them each time, it is manageable - and simpler than all this advice which may or may not work. This never happened before my current version of Firefox (42?) so I hope it is ironed out on the next version :)
kenatsun 0 solutions 14 answers

I'm having the same problem so well documented by Sowalsky back on 10/28/15, which is roughly the date when I started having this problem too.

Here's my log of trying to fix it using the instructions in this thread. See the attached numbered screen shots.

1. The original problem is illustrated in screen #1: Every time FF upgrades itself to a new release (this shows the aftermath of the upgrade to release 44.0), a row of "Install add-on" tabs like this one pops up. I have to go through each tab to "allow" the installation.

2. I follow FredMcD's 10/28 advice: delete the compatibility.ini and extensions.* files, close FF, reopen FF. No change (except I think the first time I tried it I got a message, which I ignored, saying there's something wrong with my profile).

3. So I reboot the computer and restart FF. The row of tabs has disappeared, but apparently none of the add-ons have been enabled. The "Extensions" tab of the "Add-ons manager" page (screen #2) is empty! I worry that I'm gonna have to not just re-enable but re-install all of them.

4. I close and restart FF. Now the "Install add-on" tabs have reappeared. I reinstall one of them (LastPass). Maybe (I can't remember) I also restarted FF at this point. Then I go look at the "Extensions" tab, and it looks like screen #3: All the extensions have reappeared; LastPass is enabled (and working, as confirmed by its little red icon in the taskbar); and the others aren't.

5. Using the buttons on the "Extensions" tab, I enable all of the extensions that I want . I close FF. I reboot the computer. I reopen FF. I look at the Extensions tab - and (screen #4) it's empty again! However, the extensions seem to be enabled and working - see evidence on screen 4 that at least LastPass, AdBlock Plus, and FireBug are up-and-running.

6. I close and reopen the "Extensions" tab. Then I restart FF. Then I restart the computer. None of this changes anything from what you see in screen #4: the extensions are working, and the "Extensions" tab is still empty.

So my guess is that it will all stay like this until the next time FF upgrades itself. I'll report back here at that time. Meanwhile, I'm open to any insights and suggestions.

I'm having the same problem so well documented by Sowalsky back on 10/28/15, which is roughly the date when I started having this problem too. Here's my log of trying to fix it using the instructions in this thread. See the attached numbered screen shots. 1. The original problem is illustrated in screen #1: Every time FF upgrades itself to a new release (this shows the aftermath of the upgrade to release 44.0), a row of "Install add-on" tabs like this one pops up. I have to go through each tab to "allow" the installation. 2. I follow FredMcD's 10/28 advice: delete the compatibility.ini and extensions.* files, close FF, reopen FF. No change (except I think the first time I tried it I got a message, which I ignored, saying there's something wrong with my profile). 3. So I reboot the computer and restart FF. The row of tabs has disappeared, but apparently none of the add-ons have been enabled. The "Extensions" tab of the "Add-ons manager" page (screen #2) is empty! I worry that I'm gonna have to not just re-enable but re-install all of them. 4. I close and restart FF. Now the "Install add-on" tabs have reappeared. I reinstall one of them (LastPass). Maybe (I can't remember) I also restarted FF at this point. Then I go look at the "Extensions" tab, and it looks like screen #3: All the extensions have reappeared; LastPass is enabled (and working, as confirmed by its little red icon in the taskbar); and the others aren't. 5. Using the buttons on the "Extensions" tab, I enable all of the extensions that I want . I close FF. I reboot the computer. I reopen FF. I look at the Extensions tab - and (screen #4) it's empty again! However, the extensions seem to be enabled and working - see evidence on screen 4 that at least LastPass, AdBlock Plus, and FireBug are up-and-running. 6. I close and reopen the "Extensions" tab. Then I restart FF. Then I restart the computer. None of this changes anything from what you see in screen #4: the extensions are working, and the "Extensions" tab is still empty. So my guess is that it will all stay like this until the next time FF upgrades itself. I'll report back here at that time. Meanwhile, I'm open to any insights and suggestions.
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

kenatsun said

2. I follow FredMcD's 10/28 advice: delete the compatibility.ini and extensions.* files, close FF, reopen FF.

The instruction said; Close Firefox. Locate the file. Then rename or delete it. Restart Firefox.

You should NEVER alter the files of a running program.

''kenatsun [[#answer-838237|said]]'' <blockquote> 2. I follow FredMcD's 10/28 advice: delete the compatibility.ini and extensions.* files, close FF, reopen FF. </blockquote> The instruction said; '''Close Firefox.''' Locate the file. Then rename or delete it. Restart Firefox. You should NEVER alter the files of a running program.
philipwatling 0 solutions 13 answers

I have just upgraded, Kenatsun, and the problem remains :(

I have just upgraded, Kenatsun, and the problem remains :(