Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

text display too big

  • 13 replies
  • 3 have this problem
  • 7 views
  • Last reply by bill

more options

hi

have tried a couple of adjustments but text on web pages is usually too big. it wont change with one setting until another setting is changed, the 2 settings seem interdependent

hi have tried a couple of adjustments but text on web pages is usually too big. it wont change with one setting until another setting is changed, the 2 settings seem interdependent

All Replies (13)

more options

Which settings are involved?

more options

in option menu am using size 13 but i this is dependent somehow on the windows text size being custom dpi 140, but i fiddled with this and ended up using 140 for some reason, maybe i should reduce it now


also changed setting here: u enter "about *****" in search window and get "layout.css.devPixelsPerPx", i set it to 1.35 in which effects the bars, and is better.

also thunderbird text id way to big

thanks for looking at this problem

Modified by bill

more options

The layout.css.devPixelsPerPx preference is your overall "zoom factor" for all of Firefox. It sets the floor from which page zoom and other values are calculated.

  • At the default value of -1, Firefox was applying your Windows setting of 1.40, meaning Firefox will enlarge everything 40% compared with the old standard of 96dpi
  • Your change to 1.35 means that Firefox is enlarging everything 35% compared with the old standard of 96dpi

Does that make sense?

To adjust the size of web pages and the browser toolbar area separately, you can use add-ons. Now... the interplay can be a little confusing, but you could take either of these approaches:

  • If you set the layout.css.devPixelsPerPx preference to the size you prefer for most web pages, then you can enlarge the toolbar area using this extension: Theme Font & Size Changer
  • If you set the layout.css.devPixelsPerPx preference to the size you prefer for the toolbar area, but this makes most web pages too large, you can use one of these extensions to set a global zoom for pages of less than 100%:

With either extension, you still can zoom individual pages that do not use a medium text size.

Can you get it to work the way you want?

The font size settings in Options really would be the last resort.

more options

Note that the Zoom setting in Theme Font & Size Changer affects the layout.css.devPixelsPerPx pref.

You normally set this pref to make the icon on the toolbars look in the right size and then use other means (extensions) to adjust the text size.

more options

fgnbfgnv

Modified by bill

more options

hi

how can i ask or talk further

more options

pls ignore above

thanks for the info, i sort of understands . are there such things as default settings i can start with again.

also u suggest 2 options at the bottom , which one is in ur opinion best. they both involve add ons

Modified by bill

more options

The Default FullZoom Level only sets a default zoom level. NoSquint can also set the text color in addition of setting the page zoom and can remember the zoom setting per domain.

You can look at the NoSquint extension to set font size (text/page zoom) and text color on web pages.

NoSquint allows you to adjust the text-only and full-page (both text and images) zoom levels as well as color settings both globally (for all sites) and per site.
more options

what is default zoom level please .

ive got no squint but turned it off until i sort this problem as its just interfering.

anyway it seems there are 2 options if i use addons

more options

The default zoom level is the global zoom setting that will be applied to all web pages where you do not have override the page zoom.

See:

Firefox can remember the page zoom per domain as part of the Site Preferences.

Firefox comes with some settings that you can inspect and modify via prefs on the about:config page. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

to be honest i will never get this its too complicated, is there a way i can just set to defaults again

i can see ur trying to help thanks

more options

If you go one step at a time, you can do it.

(1) Disable any extensions you added related to this issue.

(2) Set the layout.css.devPixelsPerPx preference to a value that makes either the toolbar area or the content area the size you want. In a perfect world they would both look great, but I'll settle for either one. If you want to see the default level, use -1 otherwise try values around 1.25 to 1.35.

(3) Depending on which text is too large or too small, enable or install one extension to address just that problem. cor-el and I already listed the popular extensions for separately adjusting the toolbar area and the content area.

more options

all done now, thanks to those who assisted. it seems that no squint is essential and not just a quick fix

one more thing, i want to change the font type i see on web pages [incl this text] it is either a nasty font or a fault, the uprights [vertical strokes] of the font are thicker on some letters or sometimes thicker on only half a letter

any ideals

mark

Modified by bill