X
Tap here to go to the mobile version of the site.

Support Forum

How can I prevent Firefox from opening iTunes or asking me what application I want to use for itms/itmss links?

Posted

When I open an iTunes App Store link, Firefox wants to automatically open iTunes. In Options>Applications, I found content types itms and itmss, which cause this behavior. I can change them to "Always ask", but when I do, I get a the pop-up every time I open link asking me to pick between "iTunes" or "Choose an Application." To prevent future pop-ups, I can check "Remember my choice for itmss links" but only after selecting iTunes or another application. There should be a third option there for "Do Nothing." Is there some way to tell Firefox to completely ignore itms/itmss content?

When I open an iTunes App Store link, Firefox wants to automatically open iTunes. In Options>Applications, I found content types itms and itmss, which cause this behavior. I can change them to "Always ask", but when I do, I get a the pop-up every time I open link asking me to pick between "iTunes" or "Choose an Application." To prevent future pop-ups, I can check "Remember my choice for itmss links" but only after selecting iTunes or another application. There should be a third option there for "Do Nothing." Is there some way to tell Firefox to completely ignore itms/itmss content?

Chosen solution

cor-el said

Are there protocol-handler prefs if you search the about:config page?
  • network.protocol-handler.

You have just solved my problem - there were no network.protocol-handler.external. prefs for itms or itmss, so I added them as booleans:

network.protocol-handler.external.itms network.protocol-handler.external.itmss

Set both to false, and voila! No more iTunes, no more asking me what program to use.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • Unity Player 5.0.3f2
  • VLC media player Web Plugin
  • Widevine Technologies, Inc. Digital Rights Management and Video Optimization

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

guigs 1072 solutions 11697 answers

It will only take action if you choose in action. Unfortunately the default is always ask.

It will only take action if you choose in action. Unfortunately the default is always ask.
cor-el
  • Top 10 Contributor
  • Moderator
17881 solutions 161785 answers

I assume that you mean protocol links (itms:// and itmss://) and not a file extension or MIME type.

You can search the Windows registry and remove the keys for the itms and itmss protocols to prevent Firefox from finding these protocols.

I assume that you mean protocol links (itms:// and itmss://) and not a file extension or MIME type. You can search the Windows registry and remove the keys for the itms and itmss protocols to prevent Firefox from finding these protocols. *http://kb.mozillazine.org/Register_protocol

Question owner

cor-el said

I assume that you mean protocol links (itms:// and itmss://) and not a file extension or MIME type. You can search the Windows registry and remove the keys for the itms and itmss protocols to prevent Firefox from finding these protocols.

It looks like the app store pages automatically redirect to itmss links, so when I delete these registry keys, I get:

"Problem loading page

The address wasn't understood

Firefox doesn't know how to open this address, because one of the following protocols (itmss) isn't associated with any program or is not allowed in this context.

You might need to install other software to open this address."

I guess I'll just have to deal with the pop-ups.

''cor-el [[#answer-796990|said]]'' <blockquote> I assume that you mean protocol links (itms:// and itmss://) and not a file extension or MIME type. You can search the Windows registry and remove the keys for the itms and itmss protocols to prevent Firefox from finding these protocols. *http://kb.mozillazine.org/Register_protocol </blockquote> It looks like the app store pages automatically redirect to itmss links, so when I delete these registry keys, I get: "Problem loading page The address wasn't understood Firefox doesn't know how to open this address, because one of the following protocols (itmss) isn't associated with any program or is not allowed in this context. You might need to install other software to open this address." I guess I'll just have to deal with the pop-ups.
cor-el
  • Top 10 Contributor
  • Moderator
17881 solutions 161785 answers

Helpful Reply

Are there protocol-handler prefs if you search the about:config page?

  • network.protocol-handler.
Are there protocol-handler prefs if you search the <b>about:config</b> page? *network.protocol-handler.

Chosen Solution

cor-el said

Are there protocol-handler prefs if you search the about:config page?
  • network.protocol-handler.

You have just solved my problem - there were no network.protocol-handler.external. prefs for itms or itmss, so I added them as booleans:

network.protocol-handler.external.itms network.protocol-handler.external.itmss

Set both to false, and voila! No more iTunes, no more asking me what program to use.

''cor-el [[#answer-797019|said]]'' <blockquote> Are there protocol-handler prefs if you search the <b>about:config</b> page? *network.protocol-handler. </blockquote> You have just solved my problem - there were no network.protocol-handler.external. prefs for itms or itmss, so I added them as booleans: network.protocol-handler.external.itms network.protocol-handler.external.itmss Set both to false, and voila! No more iTunes, no more asking me what program to use.