X
Tap here to go to the mobile version of the site.

Support Forum

I keep getting "Stop Running this Script?" messages which advise that they are causing my web browser to run slowly. How do I rectify this?

Posted

There isn't an obvious sign of the browser slowing down. It doesn't appear to be restricted to any one website.

There isn't an obvious sign of the browser slowing down. It doesn't appear to be restricted to any one website.

Chosen solution

Sometimes this problem is caused by an add-on which starts interacting with the page after most of the content loads, so you don't notice the problem until you get the message. The Skype Click-to-Call extension can have this issue.

In other cases, the problem may be caused by the page content itself.

Do you notice any pattern to the script that Firefox says is running slowly? Script names that start with chrome:// or resource:// refer either to parts of Firefox or an extension. Script names that start with http:// or https:// usually are part of the site you're visiting.

For additional information, you could try our support article: Warning Unresponsive script - What it means and how to fix it.

Another common cause of unresponsive script errors on Windows Vista and newer is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • BT DesktopHelp plug-in for Mozilla Browsers
  • GEPlugin
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Motive Management Plug-in for Mozilla Browsers
  • NPWLPG
  • Picasa plugin
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • 5.1.40728.0
  • WildTangent Games App V2 Presence Detector

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

jscher2000
  • Top 10 Contributor
7770 solutions 63297 answers

Chosen Solution

Sometimes this problem is caused by an add-on which starts interacting with the page after most of the content loads, so you don't notice the problem until you get the message. The Skype Click-to-Call extension can have this issue.

In other cases, the problem may be caused by the page content itself.

Do you notice any pattern to the script that Firefox says is running slowly? Script names that start with chrome:// or resource:// refer either to parts of Firefox or an extension. Script names that start with http:// or https:// usually are part of the site you're visiting.

For additional information, you could try our support article: Warning Unresponsive script - What it means and how to fix it.

Another common cause of unresponsive script errors on Windows Vista and newer is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Sometimes this problem is caused by an add-on which starts interacting with the page after most of the content loads, so you don't notice the problem until you get the message. The Skype Click-to-Call extension can have this issue. In other cases, the problem may be caused by the page content itself. Do you notice any pattern to the script that Firefox says is running slowly? Script names that start with chrome:// or resource:// refer either to parts of Firefox or an extension. Script names that start with http:// or https:// usually are part of the site you're visiting. For additional information, you could try our support article: [[Warning Unresponsive script - What it means and how to fix it]]. Another common cause of unresponsive script errors on Windows Vista and newer is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then ''uncheck'' the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Helpful Reply

Did as advised and dis-enabled the Adobe Flash protected made. This seems to have solved thingds - no more annoying messages.

Many thanks

Did as advised and dis-enabled the Adobe Flash protected made. This seems to have solved thingds - no more annoying messages. Many thanks