Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More when I try to add on, it just is blocked no option to allow

  • 10 replies
  • 9 have this problem
  • Last reply by aarauz02

more options

On the website, when I try to add the plugin, I get a message that Firefox didn´t allow it, but it doesn´t give me the option to allow it. I have changed the security parameters, adding exceptions and allowing Pop Up, but still it doesn´t work

All Replies (10)

more options

What is the plugin you want to install? What is the full message?


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

It´s on the website The plugin I think, is 19.0

When I try to install it, I get a message

"Firefox prevented this site from asking you to install software on your computer"

I have tried by allowing pop ups, changing the security parameters, and adding an exception to this website, but nothing seems to work. In teh past, the message had a window with the option to install the software if trusted, but it is not appearing now.


more options

The site is Spanish, so someone else will have to check. I've called the big guys to help you. Good luck.

more options

Ok, thanks. I´ll await the response

more options

There should be an allow button at the right end of the this notification bar or in the doorhanger that opens if you click the icon on the location/address bar.

It shouldn't be necessary to specially allow web pages to install software (extensions). You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • click the "Site Identity Button" (globe/padlock) on the location/address bar
  • click "More Information" to open "Tools > Page Info" with the Security tab selected

Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab.

Note that Firefox may refuse to install unsigned extensions.

more options

The "allow" button doesn´t appear at all. Did the procedure, an selected "allow" on the permissions tab. Still not working. This is an unverified website. Any chance that is the problem? And if it is, is there any way to jump this? Thanks

more options

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options

That is likely because this is in an iframe. Try to right-click this area and select "This Frame > Open Frame in a New Tab". That gives me the Allow button.

more options

I did. In the new tab it appears the same legend that Firefox doesn´t allow this webpage from asking permition, along with a blank page