Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why doesn't Firefox automatically allow my home page to open?

  • 3 replies
  • 1 has this problem
  • 42 views
  • Last reply by FredMcD

more options

Recently Firefox stopped automatically allowing me to access my home page, requiring me to hit the allow button each time I try to log in. Why is this happening, and can I go back to the way it used to work?

Chosen solution

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.

Read this answer in context 👍 0

All Replies (3)

more options

Is Firefox saying it stopped the page from redirecting?

Two things:

(1) You can turn off that feature on the Preferences page:

"3-bar" menu button (or Firefox menu) > Preferences > Advanced

Click the "General" mini-tab on the Advanced panel, then uncheck the box for "Warn me when websites try to redirect or reload the page"

(2) If your home page is redirecting, you may want to update it to the "final" address to save on that extra web request. For example, if your home page was:

http://www.google.com/

it will always tell Firefox to request the following address instead:

https://www.google.com/?gws_rd=ssl

So you could save on the extra request by updating your home page to:

https://www.google.com/

(Basically, changing http to https) (That last part after ? just tells Google it redirected you for its internal logging purposes, you don't really need that in your home page setting.)

That's also on the Preference page. See: Startup, home page, tabs, and download settings.

Success?

more options

What is your home page?

more options

Chosen Solution

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.