X
Tap here to go to the mobile version of the site.

Support Forum

Why does "Check Your Plugins" report outdated plugins as "Up to Date"?

Posted

When I visit the "Check Your Plugins Page" here: https://www.mozilla.org/en-US/plugincheck/

It shows that that I Silverlight 5.1.404160, and shows it as "Up to Date."

That version has been out of date since the release of Silverlight 5.1.40728.0 back on August 11, 2015. That update fixed a vulnerability that allowed remote code execution!

Even that has been superseded by Silverlight 5.1.40905.0, released September 29, 2015.

So, why does your "Check Your Plugins" page report that an old vulnerable version of Silverlight is up to date?

When I visit the "Check Your Plugins Page" here: https://www.mozilla.org/en-US/plugincheck/ It shows that that I Silverlight 5.1.404160, and shows it as "Up to Date." That version has been out of date since the release of Silverlight 5.1.40728.0 back on August 11, 2015. That update fixed a vulnerability that allowed remote code execution! Even that has been superseded by Silverlight 5.1.40905.0, released September 29, 2015. So, why does your "Check Your Plugins" page report that an old vulnerable version of Silverlight is up to date?

Chosen solution

Thank you for bringing this to our attention. I have just updated the page and it should reflect the proper version now.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Provides information about the default web browser
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Lync 2010 Meeting Join Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 5.1.40728.0
  • WebEx64 General Plugin Container Version 205

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

guigs 1072 solutions 11697 answers

Chosen Solution

Thank you for bringing this to our attention. I have just updated the page and it should reflect the proper version now.

Thank you for bringing this to our attention. I have just updated the page and it should reflect the proper version now.
guigs 1072 solutions 11697 answers

Helpful Reply

If you run into this in the future for any other plugins please also report it here: https://support.mozilla.org/en-US/for.../plug-check-page-discussions

If you run into this in the future for any other plugins please also report it here: [https://support.mozilla.org/en-US/forums/plug-check-page-discussions]