Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Playing video on YouTube is always choppy

  • 1 reply
  • 1 has this problem
  • 8 views
  • Last reply by guigs

more options

First of all, my apology for adding a question instead of replying, the "Post reply" button keeps directing me to https://support.mozilla.org/en-US/#question-reply all the time.

This post refers to another question, Low framerate when watching Youtube videos on HTML5 in fullscreen, where KalKent said

Ever since Firefox made Youtube videos only play in HTML5, no matter what quality setting I have on the video I'm watching, when I view the video on fullscreen it has low framerate. This problem does not happen with other video sites that uses Flash, like Twitch, Blip, or Dailymotion. Is it software related to the browser or hardware related with it being HTML5?

I got the same problem (low frame rate watching HTML5 videos, slow overall performance) and situation (had hardware acceleration disabled, Youtube videos running well at 1080 non-auto mode) as OP since Firefox 40 or 41 (I don't remember exactly which, but it was autoupdated around one month ago, early September) and today after I read that question thread, attempted to set media.webm.intel_decoder.enabled to true, I tried one thing that, to some extent and at least for me, fixed this:

  • Enabling hardware acceleration (Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available")

So I'm sharing this hoping that this help someone else with the same problem. Regards.

Modified by NgoKimPhu

All Replies (1)

more options

Hi NgoKimPhu , Thank you for sharing this. I will lock the thread since it is a suggested solution here. I might also encourage you to help others by answering other Firefox questions. Thank you!!!