X
Tap here to go to the mobile version of the site.

Support Forum

HTML 5 sounds are not played, videos are

Posted

Hi everybody,

I just updated my Ubuntu Gnome and hence also Firefox to version 41.0. Now I cannot hear any sounds played via HTML5. Videos are played just fine, however.

I have already tried resetting Firefox, creating a new profile and even going back to 37 via apt-get install firefox=37.0+build2-0ubuntu1

None of this helped at all.

Because sound doesn't even work under 37.0 I do assume that the problem is rooted in some system update, but I still post this here and not the Ubuntu forums because this problem persists ONLY in Firefox playing HTML5 files (as far as I know). As soon as I force YouTube, for example, to use Flash everything is fine (except that it is using flash :D).

As I am not that confident with Linux yet I am not quite sure how to fix this. I don't even know how to best post some sort of debug-log or list of updated programs/files that came with the Ubuntu update. So any help is appreciated!

Thanks in advance :)

Hi everybody, I just updated my Ubuntu Gnome and hence also Firefox to version 41.0. Now I cannot hear any sounds played via HTML5. Videos are played just fine, however. I have already tried resetting Firefox, creating a new profile and even going back to 37 via apt-get install firefox=37.0+build2-0ubuntu1 None of this helped at all. Because sound doesn't even work under 37.0 I do assume that the problem is rooted in some system update, but I still post this here and not the Ubuntu forums because this problem persists ONLY in Firefox playing HTML5 files (as far as I know). As soon as I force YouTube, for example, to use Flash everything is fine (except that it is using flash :D). As I am not that confident with Linux yet I am not quite sure how to fix this. I don't even know how to best post some sort of debug-log or list of updated programs/files that came with the Ubuntu update. So any help is appreciated! Thanks in advance :)

Chosen solution

Ok I fixed it. And could have long ago if would have read a little more carefully.

So I went back and looked through all the sites I have already read and revisited this site: https://bugzilla.mozilla.org/show_bug.cgi?id=803042#c12

The comment from Steve Fink [:sfink, :s:] describes exactly my problem and I could actually fix it by just plugging in a TV via HDMI and change the output device to internal speakers via the sound settings.

Even when unplugging the TV it works.

I guess the cause of my problem then was just HTML5 still sending Audio to the HDMI although these settings should have changed...

Is this a know bug? How can I best report this if it's not?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 41.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
  • Support URL: https://support.mozilla.org/1/firefox/41.0/Linux/de/

Extensions

  • Adblock Plus 2.6.11 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Tab for a Cause 5.7 (contact@tabforacause.org)
  • Ubuntu Modifications 3.2 (ubufox@ubuntu.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Haswell Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 3.0 Mesa 10.5.9
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Mobile
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Helpful Reply

Bump, nobody having a clue or hint? :(

Bump, nobody having a clue or hint? :(
FredMcD
  • Top 10 Contributor
4254 solutions 59572 answers

I've called the big guys to help you. Good luck.


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

I've called the big guys to help you. Good luck. --------------- check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''
jscher2000
  • Top 10 Contributor
8757 solutions 71650 answers

Do HTML5 audio players pay audio audibly, in other words, is this related to being encoded as part of a video? For example: http://hpr.dogphilosophy.net/test/

Do HTML5 audio players pay audio audibly, in other words, is this related to being encoded as part of a video? For example: http://hpr.dogphilosophy.net/test/
cor-el
  • Top 10 Contributor
  • Moderator
17516 solutions 158398 answers

On Linux the HTML5 media player depends on GStreamer support, so make sue you have the latest GStreamer updates and have installed all relevant packages. If you have multiple pages for audio components then try to uninstall some older GStreamer (MP3) audio packages.

On Linux the HTML5 media player depends on GStreamer support, so make sue you have the latest GStreamer updates and have installed all relevant packages. If you have multiple pages for audio components then try to uninstall some older GStreamer (MP3) audio packages.

Question owner

First thanks for the answers.

Second I am currently trying to upgrade my video drivers, but as Ubuntu only supports version 346.59 things are a little harder. I fail at installing the drivers manually because somehow I can't kill X-Server. sudo apt-get install nvidia-current installs version 302 and nvidia-352 does not exist... Tomorrow I try what else I can do...

I don't think that changing any Flash settings would solve my problems because Flash files play normally.

@jscher2000 None of the files play.

GStreamer should be up to date, as apt-get update doesn't scream for anything new, but I don't know how to verify my version.

First thanks for the answers. Second I am currently trying to upgrade my video drivers, but as Ubuntu only supports version 346.59 things are a little harder. I fail at installing the drivers manually because somehow I can't kill X-Server. sudo apt-get install nvidia-current installs version 302 and nvidia-352 does not exist... Tomorrow I try what else I can do... I don't think that changing any Flash settings would solve my problems because Flash files play normally. @jscher2000 None of the files play. GStreamer should be up to date, as apt-get update doesn't scream for anything new, but I don't know how to verify my version.

Modified by Znert

FredMcD
  • Top 10 Contributor
4254 solutions 59572 answers

Znert said

GStreamer should be up to date, as apt-get update doesn't scream for anything new, but I don't know how to verify my version.

The best way to check is download the current full installer.

''Znert [[#answer-786806|said]]'' <blockquote> GStreamer should be up to date, as apt-get update doesn't scream for anything new, but I don't know how to verify my version. </blockquote> The best way to check is download the current full installer.

Question owner

FredMcD said

The best way to check is download the current full installer.

Well I ran sudo apt-get install gstreamer-tools but no change. However, I'm not sure if this really install/updates what you want...

''FredMcD [[#answer-786823|said]]'' <blockquote> The best way to check is download the current full installer. </blockquote> Well I ran sudo apt-get install gstreamer-tools but no change. However, I'm not sure if this really install/updates what you want...
jscher2000
  • Top 10 Contributor
8757 solutions 71650 answers

Znert said

@jscher2000 None of the files play.

I'm not sure what you're seeing/not seeing or not hearing:

  • Is there a player bar in the page?
  • If so, and you click play, to do you get loading progress and a current playback point marker?

Screen shot attached for comparison.

If the audio tag isn't working, hmm, something is broken or disabled.

''Znert [[#answer-786806|said]]'' <blockquote> @jscher2000 None of the files play. </blockquote> I'm not sure what you're seeing/not seeing or not hearing: * Is there a player bar in the page? * If so, and you click play, to do you get loading progress and a current playback point marker? Screen shot attached for comparison. If the audio tag isn't working, hmm, something is broken or disabled.
James
  • Moderator
1598 solutions 11285 answers

FredMcD said

The best way to check is download the current full installer.

This is Linux and not Windows that you use.

http://gstreamer.freedesktop.org/download/

Linux Most, if not all, Linux distributions provide packages of GStreamer. You should find these in your distribution's package repository. Note that some distributions split the GStreamer plugins up further than the upstream sources. Additionally, some distributions do not include the gst-plugins-bad, gst-plugins-ugly, and gst-libav packages in their main repository, for legal reasons.
''FredMcD [[#answer-786823|said]]'' <blockquote> The best way to check is download the current full installer. </blockquote> This is Linux and not Windows that you use. http://gstreamer.freedesktop.org/download/ <blockquote>Linux Most, if not all, '''Linux''' distributions provide '''packages''' of GStreamer. You should find these in your distribution's package repository. Note that some distributions split the GStreamer plugins up further than the upstream sources. Additionally, some distributions do not include the gst-plugins-bad, gst-plugins-ugly, and gst-libav packages in their main repository, for legal reasons.</blockquote

Question owner

jscher2000 said

I'm not sure what you're seeing/not seeing or not hearing:

Sorry if I was a little too vague.

Basically my problem is best described as muted. Everything just plays fine, loads fine and even looks fine. But I can't hear anything.

And obviously I didn't mute anything either. Not Firefox (otherwise I wouldn't be able to play Flash files just fine) nor the player.

Edit: One thing I forgot to mention is that I don't have option to enable/disable hardware acceleration at all... Could this be the cause of my problem?

Edit#2: I just checked again, suddenly hardware acceleration is there. No idea what changed. The only thing that could be related is that I just switched to the Nouveu drivers to confirm that drivers are not the cause (same results as with Nvidia drivers) and then changed back to Nvidia's drivers to be able to use PRIME.

''jscher2000 [[#answer-786830|said]]'' <blockquote> I'm not sure what you're seeing/not seeing or not hearing: </blockquote> Sorry if I was a little too vague. Basically my problem is best described as muted. Everything just plays fine, loads fine and even looks fine. But I can't hear anything. And obviously I didn't mute anything either. Not Firefox (otherwise I wouldn't be able to play Flash files just fine) nor the player. Edit: One thing I forgot to mention is that I don't have option to enable/disable hardware acceleration at all... Could this be the cause of my problem? Edit#2: I just checked again, suddenly hardware acceleration is there. No idea what changed. The only thing that could be related is that I just switched to the Nouveu drivers to confirm that drivers are not the cause (same results as with Nvidia drivers) and then changed back to Nvidia's drivers to be able to use PRIME.

Modified by Znert

jscher2000
  • Top 10 Contributor
8757 solutions 71650 answers

I thought I posted this earlier but I don't see it now...

Some users have reported that they have no audio when Firefox is sending audio output to a device that was previously but is not currently connected such as a headset or bluetooth device. I can't recall the solution if that is the explanation.

I thought I posted this earlier but I don't see it now... Some users have reported that they have no audio when Firefox is sending audio output to a device that was previously but is not currently connected such as a headset or bluetooth device. I can't recall the solution if that is the explanation.

Chosen Solution

Ok I fixed it. And could have long ago if would have read a little more carefully.

So I went back and looked through all the sites I have already read and revisited this site: https://bugzilla.mozilla.org/show_bug.cgi?id=803042#c12

The comment from Steve Fink [:sfink, :s:] describes exactly my problem and I could actually fix it by just plugging in a TV via HDMI and change the output device to internal speakers via the sound settings.

Even when unplugging the TV it works.

I guess the cause of my problem then was just HTML5 still sending Audio to the HDMI although these settings should have changed...

Is this a know bug? How can I best report this if it's not?

Ok I fixed it. And could have long ago if would have read a little more carefully. So I went back and looked through all the sites I have already read and revisited this site: https://bugzilla.mozilla.org/show_bug.cgi?id=803042#c12 The comment from Steve Fink [:sfink, :s:] describes exactly my problem and I could actually fix it by just plugging in a TV via HDMI and change the output device to internal speakers via the sound settings. Even when unplugging the TV it works. I guess the cause of my problem then was just HTML5 still sending Audio to the HDMI although these settings should have changed... Is this a know bug? How can I best report this if it's not?

Question owner

Thanks for the tip btw @jscher2000 :)

Thanks for the tip btw @jscher2000 :)