Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FireFTP can't add certificate exception from Yahoo hosting server

  • 9 replies
  • 5 have this problem
  • 392 views
  • Last reply by A u d e e

more options

Hi,

Can anyone help me, how to get the right setting to access Yahoo hosting server using FireFTP. I used to get this way before (from a forum thread) and worked: http://forums.mozillazine.org/viewtopic.php?f=38&t=2514599 Which is by adding https:// prefix on ftp.[MyWebsite].com:21

I'm using Firefox version 39.0.3 btw.

Thanks!

Chosen solution

I couldn't access using FireFTP. Perhaps it's because FireFTP doesn't support FTPS. FireFTP is not one of the FTP client suggested by Yahoo: https://help.yahoo.com/kb/yahoo-web-hosting/ftp-client-sln20423.html

But now I can access using FIleZilla, by adding ftpes:// prefix on ftp.[MyWebsite].com This is the reference link to set it: https://forum.filezilla-project.org/viewtopic.php?t=25975


Nevertheless thanks jscher2000 for trying to help!

Read this answer in context 👍 0

All Replies (9)

more options

Are you getting this:

This address is restricted
This address uses a network port which is normally used for purposes other than Web browsing. Firefox has canceled the request for your protection.

You can create a preference using about:config and allow the port number which Firefox is blocking. Here's how:

(0) Select and copy the following preference name

network.security.ports.banned.override

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste ports and pause while the list is filtered

If the above-listed preference exists:

(3) Double-click it and add a comma to the end of the list followed by the port number you need to allow. No spaces. Then click OK.

If the above-listed preference does not exist:

(4) right-click anywhere on the page and choose New > String

(5) In the preference name dialog, paste the name you coped and click OK

(6) In the preference value dialog, type in the port number you need to allow, then click OK.

Screen shot for illustration: https://support.cdn.mozilla.net/media/uploads/images/2015-09-11-16-49-30-d45faa.png

Once you're done creating the certificate exception, you may want to clear this preference so that Firefox doesn't inadvertently follow a link to anyone else's FTP server.

more options

I didn't get something like that.

It's happening in FireFTP. When I tried to add security exception, the certificate status showed that FireFTP is unable to obtain identification status for the site

more options

Oh, I thought you were trying the old method from the thread you linked to.

more options

It worked before, but now it didn't go. If you know what I mean

more options

I don't think I have the whole picture.

So if you try to go to the site using https://ftp.yourdomain.com:21/ in a tab, do you get the restricted error?

And if you use about:config to un-ban the port, and then reload the page, do you get an Add Exception button?

And does that one work or does it have the same problem?

more options

Sorry if I was not too descriptive in posting my issue here.

I am getting this issue when I use FireFTP. FireFTP is one of the Firefox Add-ons. This FireFTP doesn't get the right setting to access Yahoo hosting server.

Previously I had the same problem and it was solved using the instruction given in this forum thread: http://forums.mozillazine.org/viewtopic.php?f=38&t=2514599

But since night this issue has been going on again even I've tried to use the same solution from that forum thread.

Btw. I've tried to set the 'about:config' thing you've suggested to un-ban the port. I tried to put the URL in Firefox browser and it seems connecting but it's not, sort of in lag or something.

more options

Actually, I use FireFTP myself, but I've never had to do what you're doing and I don't know why Firefox won't show the certificate error page when you try to connect in a regular tab. ??

more options

Well this only happening when I try to access Yahoo server. I have no problem with Hostgator server and other server like Dreamhost.

more options

Chosen Solution

I couldn't access using FireFTP. Perhaps it's because FireFTP doesn't support FTPS. FireFTP is not one of the FTP client suggested by Yahoo: https://help.yahoo.com/kb/yahoo-web-hosting/ftp-client-sln20423.html

But now I can access using FIleZilla, by adding ftpes:// prefix on ftp.[MyWebsite].com This is the reference link to set it: https://forum.filezilla-project.org/viewtopic.php?t=25975


Nevertheless thanks jscher2000 for trying to help!