Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I correct Firefox only starting with creation of new profile each time?

  • 18 replies
  • 1 has this problem
  • 676 views
  • Last reply by FredMcD

more options

I've uninstalled, reinstalled, deleted all profiles, viewed and attempted every suggestion that was found via search engine. Firefox will only start with -P option and creation of new profile. Once closed, it will not open again using the profile just created. Any ideas as to what type of additional troubleshooting that is available. There are no crash reports or logs generated anywhere that can be found. Running on Windows 7 Professional.

Chosen solution

Last resort;

Download Firefox Full Version For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.

• Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory.


Look for, and rename any Mozilla or Firefox folders by adding .old to them.

Now run the full installer. If all goes well, remove the OLD folders when you are done.

Read this answer in context 👍 1

All Replies (18)

more options
more options

badlhby said

I've uninstalled, reinstalled, deleted all profiles, viewed and attempted every suggestion that was found via search engine. Firefox will only start with -P option and creation of new profile. Once closed, it will not open again using the profile just created. Any ideas as to what type of additional troubleshooting that is available. There are no crash reports or logs generated anywhere that can be found. Running on Windows 7 Professional.

Profile isn't missing just not available for use. Each time a profile is created, it works only for that session. There were multiple profiles defined and startup was set so that it asked which one to use. Each one was selected and nothing happened. Also noted that the profile names that were changed didn't remain changed. Looking of more ideas...

more options

You need to locate the profiles.ini file and delete this file or use the Profile Manager to create a new profile.

This is usually caused by a problem with the profiles.ini file.

You can use one of these to make Firefox create a new default profile or reuse an existing profile:

  • Delete the profiles.ini file to force Firefox to create a new default profile
  • Use the Profile Manager to create a new profile
    If you still have an existing profile then click "Choose Folder" in the PM and select the location of a lost profile and recover this profile.

You should find the profiles.ini file in this hidden location:

  • Windows: %AppData%\Mozilla\Firefox\
    *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\
  • Mac: ~/Library/Application Support/Firefox/
  • Linux: ~/.mozilla/firefox/

If clearing the profiles.ini file isn't working then also check the location of the cache files.

  • Windows: *C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\
  • Mac: ~/Library/Caches/Firefox/Profiles/
  • Linux:~/.cache/mozilla/firefox/

more options

Removed profile.ini, all profile directories, all cache directories and same result. Still need to create a new profile each time in order to be able to launch firefox. Any other ideas?

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Did you check the content of the profiles.ini file or is the profiles.ini file not created?

If you do not have other Mozilla software then you can try to delete or rename the Mozilla folder (Mozilla.old).

  • C:\Users\<user>\AppData\Roaming\Mozilla\

Modified by cor-el

more options

Have tried Safe mode with the same results. Have renames directory to old and started Firefox with same results. Still can't start firefox without creating a new profile each time. Any more ideas?

more options

You did try Firefox, and later the Computer in Safe Mode, yes?

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

Application Basics


Name: Firefox Version: 40.0.2 Build ID: 20150812163655 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0 Multiprocess Windows: 0/1 (default: false)

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: ThinkVantage Password Manager Version: 4.60 Enabled: false ID: {F74D5734-46F5-4B16-96F0-1E7FBF41B750}

Graphics


Adapter Description: Intel(R) HD Graphics Family Adapter Description (GPU #2): NVIDIA NVS 4200M Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32 Adapter Drivers (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: Unknown Adapter RAM (GPU #2): 1024 Asynchronous Pan/Zoom: none Device ID: 0x0126 Device ID (GPU #2): 0x1057 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.17292) Driver Date: 9-26-2011 Driver Date (GPU #2): 2-4-2015 Driver Version: 8.15.10.2538 Driver Version (GPU #2): 9.18.13.4520 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC) Subsys ID: 21d117aa Subsys ID (GPU #2): 21d117aa Supports Hardware H264 Decoding: true Vendor ID: 0x8086 Vendor ID (GPU #2): 0x10de WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: true AzureCanvasBackend: direct2d 1.1 AzureContentBackend: direct2d 1.1 AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0 (#0) Error: OpenSharedResource failed for format 65

Important Modified Preferences


browser.cache.disk.capacity: 1048576 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.frecency_experiment: 3 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 7 browser.startup.homepage_override.buildID: 20150812163655 browser.startup.homepage_override.mstone: 40.0.2 dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 40.0.2 gfx.direct3d.last_used_feature_level_idx: 0 network.cookie.prefsMigrated: true places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf privacy.sanitize.migrateFx3Prefs: true

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.8 Version in use: 4.10.8

NSS Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSMIME Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSSL Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSUTIL Expected minimum version: 3.19.2 Version in use: 3.19.2

Experimental Features


more options

Just as an FYI. I downgraded Firefox to 39.0.3 with the same exact results. Anyone have any ideas?

more options

Open your profiles.ini file with a text editor. Does it have the line "StartWithLastProfile=1" ?

more options

Did you check your Anti-Virus security software to make sure that it isn't locking the profiles.ini file?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that has effect.

more options

Already attempted that without success. See above thread. Any other ideas?

more options

Please try this; Close Firefox.

Open the file browser / explorer on your computer. Note: You may have to enable Show Hidden Folders / Files. Enter this in the address bar;

Windows: %AppData%\Mozilla\ C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\ http://kb.mozillazine.org/Profile_folder_-_Firefox#Windows Linux: ~/.mozilla/ http://kb.mozillazine.org/Profile_folder_-_Firefox#Linux Mac: ~/Library/Application Support/ http://kb.mozillazine.org/Profile_folder_-_Firefox#Mac

Rename the profiles.ini file by adding .old to it. Now restart Firefox.

more options

Same issues. After closing FireFox, need to create new profile each time to start it. Any other ideas?

more options

Chosen Solution

Last resort;

Download Firefox Full Version For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.

• Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory.


Look for, and rename any Mozilla or Firefox folders by adding .old to them.

Now run the full installer. If all goes well, remove the OLD folders when you are done.

more options

Thank you... the rename and full install did the trick. Must have been a file in the old folder that caused issues.

more options

Glad to help. Safe surfing.