X
Tap here to go to the mobile version of the site.

Support Forum

Firefox doesn't connect to the internet unless restarted

Posted

So recently I've had a problem with Firefox not connecting to the internet unless I quit and reopen the app. It happens like this: - I open Firefox and it works; - I lose the internet connection (e.g. I turn off my wifi, or my laptop goes to sleep); - I reconnect to the internet; - the open Firefox browser will not connect to anything and just keeps loading when I click on a link - I need to quit the Firefox app and restart it before it starts to work again.

This doesn't happen to my other browsers (Safari, Chrome), once I reconnect to the internet the open browser will just continue working without needing to be restarted.

It's not a big deal but it is a little inconvenient and I'd like to know if there's something I can do to fix it.

So recently I've had a problem with Firefox not connecting to the internet unless I quit and reopen the app. It happens like this: - I open Firefox and it works; - I lose the internet connection (e.g. I turn off my wifi, or my laptop goes to sleep); - I reconnect to the internet; - the open Firefox browser will not connect to anything and just keeps loading when I click on a link - I need to quit the Firefox app and restart it before it starts to work again. This doesn't happen to my other browsers (Safari, Chrome), once I reconnect to the internet the open browser will just continue working without needing to be restarted. It's not a big deal but it is a little inconvenient and I'd like to know if there's something I can do to fix it.

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Provides information about the default web browser
  • GameTree Download Manager Plugin
  • Version 5.40.2.0
  • Version 5.41.0.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0

Application

  • Firefox 40.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.2/Darwin/en-US/

Extensions

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • DownThemAll! 2.0.18.1-signed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Hola Better Internet 1.9.150 (jid1-4P0kohSJxU1qGg@jetpack)
  • Media Hint 0.1.13.1 (mediahint@jetpack)
  • Pin It Button 1.35 (jid1-YcMV6ngYmQRA2w@jetpack)
  • Readability 2.4 (readability@readability.com)
  • Reddit Enhancement Suite 4.5.4.1-signed (jid1-xUfzOsOFlzSOXg@jetpack)
  • TabRenamizer 0.9.7.1-signed ({792BDDFE-2E7C-42ed-B18D-18154D2761BD})
  • Video DownloadHelper 5.3.1.1-signed ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x a2e
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: Intel Inc. -- Intel Iris OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Chosen Solution

What setting is set for your Network preferences in about:preferences#advanced *[[Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox]] *[[Server Not Found - Troubleshoot connection problems]]

Modified by guigs

FredMcD
  • Top 10 Contributor
4335 solutions 61002 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Separate Issue; Your System Details shows;

Installed Plug-ins

Version 5.40.2.0 Version 5.41.0.0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? ----------------------- Separate Issue; Your System Details shows; Installed Plug-ins Version 5.40.2.0 Version 5.41.0.0 <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Question owner

said

What setting is set for your Network preferences in about:preferences#advanced

Thanks guigs! Changing the Network Preferences to no proxy solved the problem.

[[#answer-769531|said]]'' <blockquote> What setting is set for your Network preferences in about:preferences#advanced *[[Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox]] *[[Server Not Found - Troubleshoot connection problems]] </blockquote> Thanks guigs! Changing the Network Preferences to no proxy solved the problem.