X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Connection is untrusted error, after updating to windows 10

Posted

I recently updated my PC to Windows 10. Now, on firefox, I cannot connect to ANY website. I only receive this message:

This Connection is Untrusted

You have asked Firefox to connect securely to www.youtube.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

Thanks for your help.

I recently updated my PC to Windows 10. Now, on firefox, I cannot connect to ANY website. I only receive this message: This Connection is Untrusted You have asked Firefox to connect securely to www.youtube.com, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do? If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate. Thanks for your help.

Chosen solution

hi OscarTM, what anti-virus software are you using, as some are known to interfere in this way?

this might be happening in accounts restricted by microsoft family parental controls. you could turn that off for your account like described at: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

in case you want to have it on by intention, you'd need to some configuration work in firefox, and install the certificate of ms family safety that is getting used to intercept secure connections into the browser's trust store. open this link in firefox - then a dialog about adding a cert should display. please check the box to Trust this CA to identify web sites & confirm the change.

alternatively you could also try the manual steps described at https://support.microsoft.com/en-us/kb/2965142 in the section about firefox.

Read this answer in context 2
philipp
  • Top 25 Contributor
  • Moderator
5348 solutions 23617 answers

Chosen Solution

hi OscarTM, what anti-virus software are you using, as some are known to interfere in this way?

this might be happening in accounts restricted by microsoft family parental controls. you could turn that off for your account like described at: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

in case you want to have it on by intention, you'd need to some configuration work in firefox, and install the certificate of ms family safety that is getting used to intercept secure connections into the browser's trust store. open this link in firefox - then a dialog about adding a cert should display. please check the box to Trust this CA to identify web sites & confirm the change.

alternatively you could also try the manual steps described at https://support.microsoft.com/en-us/kb/2965142 in the section about firefox.

hi OscarTM, what anti-virus software are you using, as some are known to interfere in this way? this might be happening in accounts restricted by microsoft family parental controls. you could turn that off for your account like described at: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings in case you want to have it on by intention, you'd need to some configuration work in firefox, and install the certificate of ms family safety that is getting used to intercept secure connections into the browser's trust store. open '''[http://tinyurl.com/purlf29 this link]''' in firefox - then a dialog about adding a cert should display. please check the box to '''Trust this CA to identify web sites''' & confirm the change. alternatively you could also try the manual steps described at https://support.microsoft.com/en-us/kb/2965142 in the section about firefox.

Question owner

I have Norton 360. I've never had this problem up till updating to Windows 10.

I have Norton 360. I've never had this problem up till updating to Windows 10.

Question owner

Turning off Parental Controls fixed my problem. Thanks a lot.

Turning off Parental Controls fixed my problem. Thanks a lot.
denisehilton 0 solutions 1 answers

comment removed. advertising for paid third-party paid products or support services isn't allowed in the forum.

''comment removed. advertising for paid third-party paid products or support services isn't allowed in the forum.''

Modified by philipp