Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

old pages open when starting

  • 8 replies
  • 1 has this problem
  • 257 views
  • Last reply by cor-el

more options

3 tabs are open when I start Firefox. They are all last pages visited.

Chosen solution

You can try to create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 👍 0

All Replies (8)

more options

Type about:preferences#general<enter> in the address bar.

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display. Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want displayed.

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any web page or about: page you want.

more options

Right now I have 7 pages loaded and open in my system try. I want to stop that. Only need current page open.

more options

zeekman09 said

Right now I have 7 pages loaded and open in my system try. I want to stop that. Only need current page open.

Firefox has a setting for whether to show only one tab per window on the Windows Taskbar, or ALL tabs in ALL windows.

Here's where you can check and adjust that:

"3-bar" menu button (or Tools menu) > Options > General

It's the last item: "Show tab previews in the Windows taskbar". If that is checked, you get ALL tabs in ALL windows on the Taskbar, and if it's unchecked, you only get the active tab in each window.

Is that what you're looking for?

more options

That is not checked. The middle 3 are.

more options

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.


You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can check for problems with the sessionstore.js file in the Firefox profile folder that stores session data. Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

You can use this button to go to the current Firefox profile folder:

more options

zeekman09 said

That is not checked. The middle 3 are.

Okay, let's start again:

You said when Firefox starts, it open 3 pages instead of your home page. How did you get up to seven different Firefox windows open?

Are these windows that you want to be open but NOT to be shown in the Windows task bar, or are these windows that you do not want to be open at all?

more options

I am going to uninstall and try it again. I must have some kind of bug.

more options

Chosen Solution

You can try to create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.