X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Web pages are black or partially black - new in Firefox 39

Posted

Many pages sporadically come up completely or partially black (except for some images) in FF 39 for the Mac, including the Firefox home page itself. To reproduce: Go to the Firefox home page and then resize the page small (attached graphic). Graphics card: AMD Radeon HD 6770M 512 MB "Use hardware acceleration where possible" unchecked, as checking it causes additional problems with transient gray boxes over content appearing in random places.

Many pages sporadically come up completely or partially black (except for some images) in FF 39 for the Mac, including the Firefox home page itself. To reproduce: Go to the Firefox home page and then resize the page small (attached graphic). Graphics card: AMD Radeon HD 6770M 512 MB "Use hardware acceleration where possible" unchecked, as checking it causes additional problems with transient gray boxes over content appearing in random places.

Additional System Details

Installed Plug-ins

  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Version 5.41.0.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • CIG Download
  • 15.8.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 18.0 r0
  • iPhoto6

Application

  • Firefox 39.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:39.0) Gecko/20100101 Firefox/39.0
  • Support URL: https://support.mozilla.org/1/firefox/39.0/Darwin/en-US/

Extensions

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Default Full Zoom Level 7.5.1-signed ({D9A7CBEC-DE1A-444f-A092-844461596C4D})
  • Lightbeam 1.2.1.1-signed (jid1-F9UJ2thwoAm5gQ@jetpack)
  • The Addon Bar (restored) 3.2.1-signed (the-addon-bar@GeekInTraining-GiT)
  • Zoom Page 13.7 (zoompage@DW-dev)
  • Adobe Acrobat - Create PDF 1.1 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • CacheToggle 0.6.1-signed (cachetoggle@pau.santesmasses.net) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6740
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 6
  • webglRenderer: ATI Technologies Inc. -- AMD Radeon HD 6770M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers

You could be seeing this bug:

  • bug 1180688 - On OSX 10.10 yosemite VM everything renders as black or white except popups/panels

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

You could be seeing this bug: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1180688 bug 1180688] - On OSX 10.10 yosemite VM everything renders as black or white except popups/panels <i>Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>