X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Everytime I open Firefox, an options tab comes up as well

Posted

So, every time I open up firefox my home page opens up like it should, but also an options tab always comes along with it. This does not happen, however, when I open up a private browsing window.

So, every time I open up firefox my home page opens up like it should, but also an options tab always comes along with it. This does not happen, however, when I open up a private browsing window.

Chosen solution

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.3.153
  • VLC media player Web Plugin
  • iTunes Detector Plug-in

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.2.1-signed (adblockpopups@jessehakanen.net)
  • Avast Online Security 10.2.0.187 (wrc@avast.com)
  • DownThemAll! 2.0.18.1-signed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Ghostery 5.4.5.1-signed (firefox@ghostery.com)
  • Reddit Enhancement Suite 4.5.4.1-signed (jid1-xUfzOsOFlzSOXg@jetpack)
  • Tab Extension 11.1 ({17f34fab-9e59-491b-b2e1-1a9116ad8c26})
  • ProxTube 2.0.0.2.1-signed (ich@maltegoetz.de) (Inactive)
  • YouTube Unblocker 0.6.10 (youtubeunblocker@unblocker.yt) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce GT 750M
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2: 0x0fe4
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 4095
  • adapterSubsysID: 079b1025
  • adapterSubsysID2: 079b1025
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17795
  • driverDate: 10-3-2013
  • driverDate2: 8-29-2013
  • driverVersion: 10.18.10.3316
  • driverVersion2: 9.18.13.2702
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157436 answers

Chosen Solution

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

You can check the home page setting: *Tools > Options > General > Startup: Home page Firefox supports multiple home pages separated by '|' (pipe) symbols. *https://support.mozilla.org/kb/How+to+set+the+home+page
fjelenko 0 solutions 2 answers

hologram78 said

So, every time I open up firefox my home page opens up like it should, but also an options tab always comes along with it. This does not happen, however, when I open up a private browsing window.

Who was the genius that decided to make this the default without asking the user? This seems like something Microsoft would do. Even google usually asks. Brain dead!

''hologram78 [[#question-1069010|said]]'' <blockquote> So, every time I open up firefox my home page opens up like it should, but also an options tab always comes along with it. This does not happen, however, when I open up a private browsing window. </blockquote> Who was the genius that decided to make this the default without asking the user? This seems like something Microsoft would do. Even google usually asks. Brain dead!
ShirlinOz 1 solutions 6 answers

hologram78 said

So, every time I open up firefox my home page opens up like it should, but also an options tab always comes along with it. This does not happen, however, when I open up a private browsing window.
''hologram78 [[#question-1069010|said]]'' <blockquote> So, every time I open up firefox my home page opens up like it should, but also an options tab always comes along with it. This does not happen, however, when I open up a private browsing window. </blockquote>
ShirlinOz 1 solutions 6 answers

I have the same issue and all my settings are correct

I have the same issue and all my settings are correct
prjdmd 0 solutions 8 answers

I am flabbergasted that the geniuses who allowed the options page to open in a tab rather than a popup box have not tried to use the "use current pages" to set their home page. If they did they would find that a tab for the options is also included in the home page along with the desired tabs. This is another brilliant idea gone wrong with Firefox 42. I have three tabs that open with my home page. Now since I changed one tab and reset by clicking the "use current pages" I now have four that open, the last being the options tab. Since the options tab is open when I press the "use current pages" the settings include the options tab. I do NOT want the options tab opening with my home page but cannot find a way to correct this issue. Firefox please resolve this issue by allowing the options to open in a box rather than a tab. If any Firefox users have an idea to correct this issue please let me know.

I am flabbergasted that the geniuses who allowed the options page to open in a tab rather than a popup box have not tried to use the "use current pages" to set their home page. If they did they would find that a tab for the options is also included in the home page along with the desired tabs. This is another brilliant idea gone wrong with Firefox 42. I have three tabs that open with my home page. Now since I changed one tab and reset by clicking the "use current pages" I now have four that open, the last being the options tab. Since the options tab is open when I press the "use current pages" the settings include the options tab. I do NOT want the options tab opening with my home page but cannot find a way to correct this issue. Firefox please resolve this issue by allowing the options to open in a box rather than a tab. If any Firefox users have an idea to correct this issue please let me know.
ShirlinOz 1 solutions 6 answers

I did a system restore and I got rid of it.

I did a system restore and I got rid of it.
prjdmd 0 solutions 8 answers

Helpful Reply

Thanks for the reply. I tried that but it didn't work for me. I just found a work around however. I opened about:config, accepted the warning and went to "browser.startup.homepage" and right clicked on "modify". A new box opened and I was able to correct the desired home page string. Now my home page opens with my desired three tabs. This is a terrible way to correct an issue that should be resolved with a single mouse click. Firefox get your act together and allow the options to open in a popup box rather than a tab so those of us who want to "use current pages" for our homepage won't have to see the options tab too.

Thanks for the reply. I tried that but it didn't work for me. I just found a work around however. I opened about:config, accepted the warning and went to "browser.startup.homepage" and right clicked on "modify". A new box opened and I was able to correct the desired home page string. Now my home page opens with my desired three tabs. This is a terrible way to correct an issue that should be resolved with a single mouse click. Firefox get your act together and allow the options to open in a popup box rather than a tab so those of us who want to "use current pages" for our homepage won't have to see the options tab too.
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157436 answers

Helpful Reply

You can check the home page setting to see if the about:preferences page is included (|about:preferences#general).

Note that this can happen if you click "Use Current Page(s)" to set the home page. You can pin the tab with the about:preferences page to prevent including about:preferences to the home page setting if you want to use this button. To set a single page as the home page you can drag the globe/padlock to the toolbar Home button.

You can check the home page setting to see if the about:preferences page is included (|about:preferences#general). Note that this can happen if you click "Use Current Page(s)" to set the home page. You can pin the tab with the about:preferences page to prevent including about:preferences to the home page setting if you want to use this button. To set a single page as the home page you can drag the globe/padlock to the toolbar Home button.
prjdmd 0 solutions 8 answers

I appreciate the info. I have found a way around the issue but Firefox should go back to providing the options in a pop up box rather than a tab. It will make things much easier if setting multiple tabs as home page. I can appreciate their desire to eliminate all pop up boxes but in this case their idea to include the options in a tab is a failure. I hope the next update corrects the problem.

I appreciate the info. I have found a way around the issue but Firefox should go back to providing the options in a pop up box rather than a tab. It will make things much easier if setting multiple tabs as home page. I can appreciate their desire to eliminate all pop up boxes but in this case their idea to include the options in a tab is a failure. I hope the next update corrects the problem.
timinftl 0 solutions 7 answers

I have the same here, just for grins I did several complete uninstalls w/ eraser by norton with dod algorithms and I accomplished nothing and I haven't the old version anymore dangit :-)


prjdmd said

"I am flabbergasted that the geniuses who allowed the options page to open in a tab rather than a popup box have not tried to use the "use current pages" to set their home page. If they did they would find that a tab for the options is also included in the home page along with the desired tabs. This is another brilliant idea gone wrong with Firefox 42. I have three tabs that open with my home page. "
I have the same here, just for grins I did several complete uninstalls w/ eraser by norton with dod algorithms and I accomplished nothing and I haven't the old version anymore dangit :-) ''prjdmd [[#answer-811795|said]]'' <blockquote> "I am flabbergasted that the geniuses who allowed the options page to open in a tab rather than a popup box have not tried to use the "use current pages" to set their home page. If they did they would find that a tab for the options is also included in the home page along with the desired tabs. This is another brilliant idea gone wrong with Firefox 42. I have three tabs that open with my home page. "

Modified by timinftl

timinftl 0 solutions 7 answers

Thanks and Kudos to you and all who jumped on this one, Not a major problem but it was driving me bananas for over a week now. Tim

Thanks and Kudos to you and all who jumped on this one, Not a major problem but it was driving me bananas for over a week now. Tim
newton_shaw 0 solutions 1 answers

I am able to fix this by removing from the home page setting, "about:preferences." So if you set your homepage to yahoo.com (it should show this: www.yahoo.com|aboutpreference. Delete the |aboutpreference part. Close and reopen firefox. The issue will go away.

I am able to fix this by removing from the home page setting, "about:preferences." So if you set your homepage to yahoo.com (it should show this: www.yahoo.com|aboutpreference. Delete the |aboutpreference part. Close and reopen firefox. The issue will go away.
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157436 answers

This can happen if you click "Use Current Page(s)" to set the home page and about:preferences is open in a tab. You can pin the tab with the about:preferences page via the right-click context menu of the tab to prevent including about:preferences to the home page setting if you want to use this button in "Options/Preferences > General". To set a single page as the home page you can drag the globe/padlock to the toolbar Home button.

This can happen if you click "Use Current Page(s)" to set the home page and about:preferences is open in a tab. You can pin the tab with the about:preferences page via the right-click context menu of the tab to prevent including about:preferences to the home page setting if you want to use this button in "Options/Preferences > General". To set a single page as the home page you can drag the globe/padlock to the toolbar Home button.

Modified by cor-el