X
Tap here to go to the mobile version of the site.

Support Forum

Why won't my privacy settings be retained when I exit options???

Posted

when I set my privacy settings and exit options, then reenter options/privacy, the settings have been returned to the default. Solution?????

when I set my privacy settings and exit options, then reenter options/privacy, the settings have been returned to the default. Solution?????

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.11
  • GEPlugin
  • Google Update
  • Shockwave Flash 18.0 r0

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

  • Avast Online Security 10.2.0.187 (wrc@avast.com) (Inactive)
  • HP Smart Web Printing 4.51 (smartwebprinting@hp.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) G33/G31 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x29c2
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 020d1028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 9-23-2009
  • driverDate2:
  • driverVersion: 8.15.10.1930
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedDriver']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11 WARP

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

See also:


Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark. "Use custom settings for history" stays only selected if at least one of the History or Cookie settings is not the default to make you aware that changes from the default setting have been made.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software. See also: *http://kb.mozillazine.org/Preferences_not_saved ---- Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark. "Use custom settings for history" stays only selected if at least one of the History or Cookie settings is not the default to make you aware that changes from the default setting have been made.
MarjaE 2 solutions 216 answers

I've had the same problem.

Go to preferences > privacy, find that the settings have somehow changed to "remember history," try changing them back, try clearing out some of the suspicious cookies, close tab, go back to preferences > privacy, find that the settings have somehow reverted to "remember history," again, and the cookies have remained...

It's possible that there's a confirmation button somewhere off-screen.

I can't reach it if it's off-screen.

It's hard to identify which cookies arrived while the system was down, and need to be deleted.

It's really help to be able to search the cookies, especially by date, and to separate witelisted cookies from other cookies which have arrived.

I've had the same problem. Go to preferences > privacy, find that the settings have somehow changed to "remember history," try changing them back, try clearing out some of the suspicious cookies, close tab, go back to preferences > privacy, find that the settings have somehow reverted to "remember history," again, and the cookies have remained... It's possible that there's a confirmation button somewhere off-screen. I can't reach it if it's off-screen. It's hard to identify which cookies arrived while the system was down, and need to be deleted. It's really help to be able to search the cookies, especially by date, and to separate witelisted cookies from other cookies which have arrived.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

There are extensions that keep a list of special opt-out cookies. Such cookies can't be removed unless you uninstall the involved extension.

The Cookie Manager also works differently when you run Firefox in permanent Private Browsing mode and only shows cookies created in regular mode.

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

There are extensions that keep a list of special opt-out cookies. Such cookies can't be removed unless you uninstall the involved extension. The Cookie Manager also works differently when you run Firefox in permanent Private Browsing mode and only shows cookies created in regular mode. If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted. *Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted. *http://kb.mozillazine.org/Cookies *https://support.mozilla.org/kb/Deleting+cookies
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

MarjaE said

Go to preferences > privacy, find that the settings have somehow changed to "remember history," try changing them back, try clearing out some of the suspicious cookies, close tab, go back to preferences > privacy, find that the settings have somehow reverted to "remember history," again, and the cookies have remained...

Did you change to "Firefox will: Use custom settings for history" and then modify any of the settings below that? If you don't modify any settings, then it's normal for you to see the same thing when you close the tab and open it up again. Adding/removing cookie exceptions or removing cookies doesn't change any of the settings (just some of the data Firefox has stored) so in that case, you would expect to see "Firefox will: Remember history" the next time, too.

''MarjaE [[#answer-813868|said]]'' <blockquote> Go to preferences > privacy, find that the settings have somehow changed to "remember history," try changing them back, try clearing out some of the suspicious cookies, close tab, go back to preferences > privacy, find that the settings have somehow reverted to "remember history," again, and the cookies have remained... </blockquote> Did you change to "Firefox will: Use custom settings for history" and then modify any of the settings below that? If you don't modify any settings, then it's normal for you to see the same thing when you close the tab and open it up again. Adding/removing cookie exceptions or removing cookies doesn't change any of the settings (just some of the data Firefox has stored) so in that case, you would expect to see "Firefox will: Remember history" the next time, too.
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

MarjaE said

It's hard to identify which cookies arrived while the system was down, and need to be deleted.

It's really help to be able to search the cookies, especially by date, and to separate witelisted cookies from other cookies which have arrived.

Maybe I'm misunderstanding what you mean by the system being down, but no new cookies should be set by sites if Firefox is closed or Windows is sleeping. Cookies are only set when Firefox loads something from a site, or if a script in a webpage is running and reading/setting cookies.

Unfortunately, I don't think there is any record of when a cookie was set, or at least it's not easy to see.

''MarjaE [[#answer-813868|said]]'' <blockquote> It's hard to identify which cookies arrived while the system was down, and need to be deleted. <br><br> It's really help to be able to search the cookies, especially by date, and to separate witelisted cookies from other cookies which have arrived. </blockquote> Maybe I'm misunderstanding what you mean by the system being down, but no new cookies should be set by sites if Firefox is closed or Windows is sleeping. Cookies are only set when Firefox loads something from a site, or if a script in a webpage is running and reading/setting cookies. Unfortunately, I don't think there is any record of when a cookie was set, or at least it's not easy to see.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

MarjaE is on Mac and there it is possible to minimize the application to the dock or close all open windows, but keep the application running.

MarjaE is on Mac and there it is possible to minimize the application to the dock or close all open windows, but keep the application running.
MarjaE 2 solutions 216 answers

"Did you change to "Firefox will: Use custom settings for history" and then modify any of the settings below that?"

Yes of course I did:

"Go to preferences > privacy, find that the settings have somehow changed to "remember history," try changing them back, try clearing out some of the suspicious cookies, close tab, go back to preferences > privacy, find that the settings have somehow reverted to "remember history," again, and the cookies have remained..."

And

"Maybe I'm misunderstanding what you mean by the system being down,"

I mean the privacy settings having switched to "remember history."

I know part of the problem is that the dialogues in the privacy preferences don't show properly on the small laptop screen. There are additional options to confirm the removal of cookies, to close the dialogue box without closing the whole preferences tab, etc. that only show up with the large external monitor.

"Did you change to "Firefox will: Use custom settings for history" and then modify any of the settings below that?" Yes of course I did: "Go to preferences > privacy, find that the settings have somehow changed to "remember history," try changing them back, try clearing out some of the suspicious cookies, close tab, go back to preferences > privacy, find that the settings have somehow reverted to "remember history," again, and the cookies have remained..." And "Maybe I'm misunderstanding what you mean by the system being down," I mean the privacy settings having switched to "remember history." I know part of the problem is that the dialogues in the privacy preferences don't show properly on the small laptop screen. There are additional options to confirm the removal of cookies, to close the dialogue box without closing the whole preferences tab, etc. that only show up with the large external monitor.
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

Hi MarjaE, to see more of the page, try zooming out (hold down the Command key and press the - key once or twice).

What option(s) did you change? For example:

  • Unchecked "Remember my browsing and download history"
  • Unchecked "Remember search and form history"
  • Unchecked "Accept cookies from sites" (would cause lots of problems)
    • Changed "Accept third-party cookies" setting from Always to a different setting
    • Changed "Keep until" setting from they expire to a different setting
  • Turned on "Clear history when Firefox closes" (if you do, check the detailed settings to make sure you don't clear things you do not want to clear)

If you did not change any of those, then it is normal for Firefox to return to "Firefox will: Remember history" when you close the Preferences page and open it again.

Hi MarjaE, to see more of the page, try zooming out (hold down the Command key and press the - key once or twice). What option(s) did you change? For example: * Unchecked "Remember my browsing and download history" * Unchecked "Remember search and form history" * Unchecked "Accept cookies from sites" (would cause lots of problems) ** Changed "Accept third-party cookies" setting from Always to a different setting ** Changed "Keep until" setting from they expire to a different setting * Turned on "Clear history when Firefox closes" (if you do, check the detailed settings to make sure you don't clear things you do not want to clear) If you did not change any of those, then it is normal for Firefox to return to "Firefox will: Remember history" when you close the Preferences page and open it again.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

You can possibly zoom out the about:preferences page via "View > Zoom" if you do not see the full content and aren't able to scroll the page. When all history setting are the default then you will have to use "Use custom settings for history" to be able to access all individual settings. If you clear the cookies via the Show Cookies button then the cookies should stay cleared whether you still see the custom setting or this section collapses and you see remember history.


If clearing cookies didn't work then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted.

You can use this button to go to the current Firefox profile folder:

You can possibly zoom out the about:preferences page via "View > Zoom" if you do not see the full content and aren't able to scroll the page. When all history setting are the default then you will have to use "Use custom settings for history" to be able to access all individual settings. If you clear the cookies via the Show Cookies button then the cookies should stay cleared whether you still see the custom setting or this section collapses and you see remember history. ----- If clearing cookies didn't work then it is possible that the cookies.sqlite file that stores the cookies got corrupted. *Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox