X
Tap here to go to the mobile version of the site.

Support Forum

Firefox refreshes the page whenever I try to use Google or Firefox search buttons.

Posted

Hence I can't do any web searching, but it displays no problem whatsoever if I click on a stored bookmark. This happens with any open tabs and the page is refreshed the instant any search button is used, whether there is an address or not. Can the refresh page feature be turned off?.

Hence I can't do any web searching, but it displays no problem whatsoever if I click on a stored bookmark. This happens with any open tabs and the page is refreshed the instant any search button is used, whether there is an address or not. Can the refresh page feature be turned off?.

Chosen solution

Hi donedo, Firefox should work fine with Google search. The only change was which company signed up to be the default search engine "out of the box."

Could you give an example of a search that gives the wrong results? Please give the full URL of the results page.

More generally:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Read this answer in context 2

Additional System Details

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 4.0; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) 82945G Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2772
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 01ad1028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 4-5-2005
  • driverDate2:
  • driverVersion: 6.14.10.4299
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
premm krishna shenoy 7 solutions 85 answers

We are sorry to hear that.As far I understand your question.This problem may have been due to meta tag of webpage.

<head> <meta http-equiv="refresh" content="600"></head>

The refresh page features comes with the webpage. Try typing about:preferences#advanced in the address bar and untick the "Warn me when websites try to redirect or reload the page" option.See the screenshot for clarity.

We are sorry to hear that.As far I understand your question.This problem may have been due to meta tag of webpage. <head> <meta http-equiv="refresh" content="600"></head> The refresh page features comes with the webpage. Try typing about:preferences#advanced in the address bar and untick the "Warn me when websites try to redirect or reload the page" option.See the screenshot for clarity.

Question owner

Thanks but it doesn't work, already tried that setting. However it doesnt automatically refresh in a New Tab, but there is either no response, or it searches forever, without any result, depending on the address evidently. And when using a new tab, to bring up Firefox home page, I get the error window " Content Encoding Error with "cannot load the page because it uses a different type of compression". I can however load any bookedmarked items without problem from any page.

Thanks but it doesn't work, already tried that setting. However it doesnt automatically refresh in a New Tab, but there is either no response, or it searches forever, without any result, depending on the address evidently. And when using a new tab, to bring up Firefox home page, I get the error window " ''Content Encoding Error'' with "cannot load the page because it uses a different type of compression". I can however load any bookedmarked items without problem from any page.
jscher2000
  • Top 10 Contributor
8888 solutions 72718 answers

There is a problem with the "Compatibility" setting in your Firefox desktop shortcut.

If you right-click the shortcut > Properties > Compatibility tab, you'll see that Firefox is set to run on a version of Windows older than Windows XP. That breaks Firefox, because Windows hides certain capabilities Firefox needs. Try to clear all settings on that tab so Firefox runs with the full capabilities of whatever version of Windows you have.

After saving that change, exit of Firefox and restart it again. That should fix the broken address and search bars, and perhaps other things.

Note: This suggestion is based on your Firefox reporting it runs on Windows NT 4.0 in the user agent string: Mozilla/5.0 (Windows NT 4.0; rv:38.0) Gecko/20100101 Firefox/38.0

There is a problem with the "Compatibility" setting in your Firefox desktop shortcut. If you right-click the shortcut > Properties > Compatibility tab, you'll see that Firefox is set to run on a version of Windows older than Windows XP. That breaks Firefox, because Windows hides certain capabilities Firefox needs. Try to clear all settings on that tab so Firefox runs with the full capabilities of whatever version of Windows you have. After saving that change, exit of Firefox and restart it again. That should fix the broken address and search bars, and perhaps other things. ''Note: This suggestion is based on your Firefox reporting it runs on Windows NT 4.0 in the user agent string:'' Mozilla/5.0 (Windows NT 4.0; rv:38.0) Gecko/20100101 Firefox/38.0

Modified by jscher2000

Question owner

sorry done that but doesn't help. I only have a 3 program choice win 95, win NT and win 2000, cannot delete or add, I've set it on Win2000 but its been on Win 95 for years with Firefox. A message window just came through about downloading a search fix program or link [I forget] Being desperate I clicked on it thinking it would go to my download file where I could investigate further, but nothing visual happened, the download file says no, and I can't find anything like it anywhere in the system. However I can now search from the home page without it refreshing itself. So thats good, but now the back button doesn't work, so I must return to start page and re-enter the address etc, if for instance I"m on page 2 of a document and want to read page 1 again it's a no go. Secondly I can;t bring up a new tab, doesn't work. Thirdly, some of the menu buttons don't work, options and addons for instance are a no go. So I've gained and lost. I've now got a pretty basic dull looking home page wherefrom I can bring up a web page from somewhere, but can't do much else with it, except keep using Internet Exp. Horrible but it works.

sorry done that but doesn't help. I only have a 3 program choice win 95, win NT and win 2000, cannot delete or add, I've set it on Win2000 but its been on Win 95 for years with Firefox. A message window just came through about downloading a search fix program or link [I forget] Being desperate I clicked on it thinking it would go to my download file where I could investigate further, but nothing visual happened, the download file says no, and I can't find anything like it anywhere in the system. However I can now search from the home page without it refreshing itself. So thats good, but now the back button doesn't work, so I must return to start page and re-enter the address etc, if for instance I"m on page 2 of a document and want to read page 1 again it's a no go. Secondly I can;t bring up a new tab, doesn't work. Thirdly, some of the menu buttons don't work, options and addons for instance are a no go. So I've gained and lost. I've now got a pretty basic dull looking home page wherefrom I can bring up a web page from somewhere, but can't do much else with it, except keep using Internet Exp. Horrible but it works.
cor-el
  • Top 10 Contributor
  • Moderator
17774 solutions 160764 answers

You need to remove all compatibility setting changes that you made.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

You need to remove all compatibility setting changes that you made. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.
jscher2000
  • Top 10 Contributor
8888 solutions 72718 answers

Helpful Reply

donedo said

I only have a 3 program choice win 95, win NT and win 2000, cannot delete or add

Uncheck the checkbox above that list. then you are not using any of those settings.

''donedo [[#answer-742072|said]]'' <blockquote> I only have a 3 program choice win 95, win NT and win 2000, cannot delete or add</blockquote> Uncheck the checkbox above that list. then you are not using any of those settings.

Question owner

Last night after unchecking the box in compatability, I did a restart but Firefox was still the same. But this morning I now have a back button that works, I now have new tab search, I now have a menu that works, addons and options and stuff. All good, however Firefox will only bring up results on certain pages, anything related with Google is a non event, like Google world news. Is this because Google and Firefox have fallen out. If so I'll leave it as a backup browser only.

Last night after unchecking the box in compatability, I did a restart but Firefox was still the same. But this morning I now have a back button that works, I now have new tab search, I now have a menu that works, addons and options and stuff. All good, however Firefox will only bring up results on certain pages, anything related with Google is a non event, like Google world news. Is this because Google and Firefox have fallen out. If so I'll leave it as a backup browser only.
jscher2000
  • Top 10 Contributor
8888 solutions 72718 answers

Chosen Solution

Hi donedo, Firefox should work fine with Google search. The only change was which company signed up to be the default search engine "out of the box."

Could you give an example of a search that gives the wrong results? Please give the full URL of the results page.

More generally:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Hi donedo, Firefox should work fine with Google search. The only change was which company signed up to be the default search engine "out of the box." Could you give an example of a search that gives the wrong results? Please give the full URL of the results page. More generally: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: "3-bar" menu button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or globe icon in the address bar > More Information > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help?

Question owner

Thanks to everyone who helped and a bit of clicking around this morning My Firefox browser is completely back to normal. Very happy me. Problems solved.

Thanks to everyone who helped and a bit of clicking around this morning My Firefox browser is completely back to normal. Very happy me. Problems solved.