Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website pop up windows no longer have upper left buttons to close them with

  • 3 replies
  • 2 have this problem
  • 38 views
  • Last reply by pdxjayhawk

more options

Recently, whenever a website has a link that opens in a new window the new windows open with no way to close them. The red, yellow and green buttons that normally appear in the top left hand corner allowing the window to be closed, minimized or expanded.

The only way to close the window is to quite Firefox entirely and re-start.

Firefox version 38.0 Mac OS X 10.10

All Replies (3)

more options

Can you associate this problem with using any "full screen" features, either for Firefox or for videos?

According to our support article "How to make Firefox and websites go full screen," on Mac, Command+Shift+f should switch in and out of full screen view. Does that do anything?

If not, do either of these work:

  • Command+n to launch a new window -- is it normal?
  • Command+w to close the tab that doesn't have a title bar -- will it close?
more options

Or perhaps it is this: there is a bug in Firefox 38 with the following combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link which launches the link in a new window (because the site coded the link with target="_blank")

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug:

(1) Use tabbed browsing (this is a checkbox under Preferences > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.

For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.

more options

Command+w did work.

Thanks!