Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is blocking Google voice plugin

  • 11 replies
  • 1 has this problem
  • 3758 views
  • Last reply by cor-el

more options

I can never get the ALLOW in the FF is blocking ...... bar as it only shows for a 1/4 second. So how can I get FF to allow the Google Voice window?

Chosen solution

It was something in cookies/chrome etc. between FF, Google, and MSsecurity. (Even Media Player was being blocked.)

First I only backed up just my bookmarks and PW's, and even unclicked all other/unknown files to a .PVC file. Next I uninstalled FF and all visible Google apps too, and went for a witch hunt of every single file, %appdata, program data, you name it pertaining to Google or Mozilla and deleted it. I read many log files in the process and saw dialog that G talk was denied for being "unsafe." but couldn't figure out which app generated it.

I restarted, did a disk clean, updated all and restarted again, and reinstalled FF. Still no luck, so did a Fresh Copy and deleted all the old data, restarted and voilá, all was back to what it was a week ago. (About 12 hours over 3 days later.) Thanks for all the suggestions!

Read this answer in context 👍 0

All Replies (11)

more options

Try setting the plugin to "Always Activate". Open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then on the right side you can adjust the default permission.

more options

Thank you, but the plugin is already set to always activate! But still I get that FF has blocked bar.... I have tried all sorts of updating and reinstalling, but I cannot get it unblocked. On W7, but I just fired up the old XP , didn't update it yet from a month ago and it all worked fine...

Modified by wdhc

more options

Hmm, this is a little complicated because if there is a site-specific block and Firefox is refreshing/redirecting away from the page, we might not be able to use the Page Info dialog to check/fix the permission.

Can you load any pages on the site where you see this "blocked" bar and then lose it? If so, check the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions

The list should show the "effective" permission for Google Voice on that specific site. Does it show Allow (or Use default with a gray dot for Allow)?

If the permission is right, then perhaps something else is blocked. Try setting allow for any plausible candidates here, such as Popup windows.

more options

My version (latest) of FF does not have a view for page permissions in any of the ways described above except for the last way. Permissions were granted. Deleting cookies did no good either.

My old XP I did not update as todays MS update was the cause of this misery, and all works fine on it. So somehow this is related to updates....

Restoring the W7 did no good. I am considering going back to a month old shadow copy and not updating anything anymore.

more options

Since the message appears so briefly, I wonder whether you could use a camera/phone to video it so you can freeze it and get the exact wording.

If you are thinking of using Windows' system restore feature, please make a backup of your Firefox settings (profile) folder first. System restore may roll back that folder or corrupt it. This article has suggestions on backups, but you also can just copy the entire folder to external media: Back up and restore information in Firefox profiles.

more options

See also:

  • Firefox > Options/Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:


You can inspect and manage the permissions for the domain in the currently selected tab:

  1. Click the "Site Identity Button" (globe/padlock) on the location/address bar
  2. Click "More Information" to open "Tools > Page Info" with the Security tab selected
  3. Go to the Permissions tab to inspect the currently used permissions
more options

Thank you for all your useful info, but I saw nothing changed/odd. The plot has thickened. It isn't just Google that suddenly has issues with FF, but also anything that wants identity verification, since Tuesdays MS updates. This included my ATT DSL provider, who would not give FF browsing signal, but let IE pass with no problem. My not updated XP has no problems. I did a Safe Mode restore to before this weeks updates, and am not using FF again for browsing but have to use IE for google log in.

So I will back up my saved bookmarks and PWs and uninstall FF as completely as I can, and start over again. I probably have Google crap to track down too, and evict. Thanks.

more options

wdhc said

It isn't just Google that suddenly has issues with FF, but also anything that wants identity verification, since Tuesdays MS updates. This included my ATT DSL provider, who would not give FF browsing signal, but let IE pass with no problem.

To put it in plainer terms, by identity verification, do you mean a login (username and password) or something more complicated? Or secure certificate errors?

more options

Chosen Solution

It was something in cookies/chrome etc. between FF, Google, and MSsecurity. (Even Media Player was being blocked.)

First I only backed up just my bookmarks and PW's, and even unclicked all other/unknown files to a .PVC file. Next I uninstalled FF and all visible Google apps too, and went for a witch hunt of every single file, %appdata, program data, you name it pertaining to Google or Mozilla and deleted it. I read many log files in the process and saw dialog that G talk was denied for being "unsafe." but couldn't figure out which app generated it.

I restarted, did a disk clean, updated all and restarted again, and reinstalled FF. Still no luck, so did a Fresh Copy and deleted all the old data, restarted and voilá, all was back to what it was a week ago. (About 12 hours over 3 days later.) Thanks for all the suggestions!

more options

Firefox ( and IE) started blocking the Google talk and video plugin AGAIN Help! How do I delete all personal data for settings, ID, etc. and start with a clean slate? The previous deletes don't work anymore. Why is there no way to see on FF when a plug in gets blocked?

Modified by wdhc

more options

You can check the status of plugins on the about:plugins page and in Firefox/Tools > Add-ons > Plugins.

Firefox shows a Lego block icon at the left end of the location/address bar in case a plugin is detected.