X
Tap here to go to the mobile version of the site.

Support Forum

How can I fix the "unresponsive script issue?"

Posted

Greetings fellow organisms and earthlings

       I have been having trouble lately with Firefox because it keeps crashing randomly and a warning box usually pops up saying "Warning! Unresponsive script. The script is busy"....blah blah blah etc. And it says it is the Shockwave FlashPlayer. I have tried a few things to fix this problem, too such as typing about:config in the web address bar up at the top, finding dom.max_script_run_time and changing the integer (number) to 20 instead of 10, I've tried disabling FlashPlayer safe mode, and I've also tried removing cookies and cache. None of these things seemed to help. Although changing the dom.max_script_run_time integer to 20 did prevent the "unresponsive script" warning from popping up, Firefox still acted the same way as if I didn't do anything. Someone please help me. I have had this problem for about 2 weeks now and it is starting to drive me crazy. It's hard to perform anything when FireFox keeps crashing every 10 seconds or so. All I ask is someone just give me a helpful answer to solve this problem, because I know I am definitely not the only one with this problem. I don't care how hard it is for me to fix it, just as long as I can. I know Mozilla isn't perfect, because no one is, but if teamwork is played out, solutions can be acquired. Thanks for all the help anyways. I'll try to stay updated to this problem. Thanks!
Greetings fellow organisms and earthlings I have been having trouble lately with Firefox because it keeps crashing randomly and a warning box usually pops up saying "Warning! Unresponsive script. The script is busy"....blah blah blah etc. And it says it is the Shockwave FlashPlayer. I have tried a few things to fix this problem, too such as typing about:config in the web address bar up at the top, finding dom.max_script_run_time and changing the integer (number) to 20 instead of 10, I've tried disabling FlashPlayer safe mode, and I've also tried removing cookies and cache. None of these things seemed to help. Although changing the dom.max_script_run_time integer to 20 did prevent the "unresponsive script" warning from popping up, Firefox still acted the same way as if I didn't do anything. Someone please help me. I have had this problem for about 2 weeks now and it is starting to drive me crazy. It's hard to perform anything when FireFox keeps crashing every 10 seconds or so. All I ask is someone just give me a helpful answer to solve this problem, because I know I am definitely not the only one with this problem. I don't care how hard it is for me to fix it, just as long as I can. I know Mozilla isn't perfect, because no one is, but if teamwork is played out, solutions can be acquired. Thanks for all the help anyways. I'll try to stay updated to this problem. Thanks!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.11
  • Battlelog Game Launcher (2.4.0)
  • GEPlugin
  • Google Update
  • Motive Management Plug-in for Mozilla Browsers
  • Motive Plugin for Mozilla Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • 5.1.40416.0
  • VLC media player Web Plugin 2.1.3
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

jscher2000
  • Top 10 Contributor
8707 solutions 71164 answers

Sounds like your Firefox has a pretty extreme case.

If you look at the script that the error messages say is running slowly, is there any pattern? Sometimes it is lots of different scripts, but sometimes they are all part of one add-on, for example.

You mentioned the Flash safe mode. Do you mean the protected mode feature? The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting for disabling it that is easier to try than the old method of editing the mms.cfg file:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Sounds like your Firefox has a pretty extreme case. If you look at the script that the error messages say is running slowly, is there any pattern? Sometimes it is lots of different scripts, but sometimes they are all part of one add-on, for example. You mentioned the Flash safe mode. Do you mean the protected mode feature? The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting for disabling it that is easier to try than the old method of editing the mms.cfg file: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''flash''' and pause while the list is filtered (C) Double-click the '''dom.ipc.plugins.flash.disable-protected-mode''' preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Question owner

I did try this, and it seemed to work, except Youtube is still kinda slow and it freezes from time to time. Thanks though!

I did try this, and it seemed to work, except Youtube is still kinda slow and it freezes from time to time. Thanks though!

Question owner

I still think there is something wrong though. Is there anything else that can help solve this issue for good?

I still think there is something wrong though. Is there anything else that can help solve this issue for good?
jscher2000
  • Top 10 Contributor
8707 solutions 71164 answers

Do you know whether you are using Flash or the HTML5 player on YouTube? You usually can tell by right-clicking the player and checking the last item on the short context menu. (Most Firefox users have been switched to HTML5, for which Firefox uses components of Windows to decode the MP4 stream.)

Do you know whether you are using Flash or the HTML5 player on YouTube? You usually can tell by right-clicking the player and checking the last item on the short context menu. (Most Firefox users have been switched to HTML5, for which Firefox uses components of Windows to decode the MP4 stream.)