Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do I tell Mozilla to allow access to a site that is using out-dated (no longer secure) TLS mechanisms

  • 4 replies
  • 13 have this problem
  • 120 views
  • Last reply by zackvancura

more options

mozilla won't allow me to access the website www.brightonbest.com.

Chosen solution

The site connects for me with a TLS 1.0 connection.

What are the TLS settings if you check the min and max prefs on the about:config page?

  • security.tls.version.min
  • security.tls.version.max
  • 1 means TLS 1.0, 2 means TLS 1.1, 3 means TLS 1.2

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Read this answer in context 👍 1

All Replies (4)

more options

It works for me in Firefox 38.0.5, but not in Firefox and Firefox 39 (current beta). It works in the current Nightly build as well, so I'm not sure what is going on here.

You can update to Firefox 38.0.5 for now to access the website.

  • Help >About.

You can find the full version of the current current Firefox release (38.0.1) in all languages and all operating systems here:

more options

I have updated to 38.0.5, still won't allow me access the website. I'm getting the same "secure connection failed" message.

You said you were able to access the web page, is it possible this has something to do with my CPU settings or firewall?

Can i tell Firefox to allow access to this site and ignore the warning?

more options

Chosen Solution

The site connects for me with a TLS 1.0 connection.

What are the TLS settings if you check the min and max prefs on the about:config page?

  • security.tls.version.min
  • security.tls.version.max
  • 1 means TLS 1.0, 2 means TLS 1.1, 3 means TLS 1.2

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Changing the TLS settings did the trick! Thanks very much for your help, it's truly appreciated.