X
Tap here to go to the mobile version of the site.

Support Forum

Firefox on windows 8.1 is autofilling a password field when autocomplete is off.

Posted

Hi there.

Firefox (Latest version) for windows is autofilling a password field, even with autocomplete turned off.

The HTML for the fields are as follows:

<input name="member_password1" autocomplete="off" type="password">
<input name="member_password2" autocomplete="off" type="password">
Leave password blank to autogenerate a password

In all other browsers this works fine, and the saved password is not added, but Firefox on Windows 8.1 this is being filled in automatically, with the users saved password.

Hi there. Firefox (Latest version) for windows is autofilling a password field, even with autocomplete turned off. The HTML for the fields are as follows: <input name="member_password1" autocomplete="off" type="password"> <br> <input name="member_password2" autocomplete="off" type="password"> <br> Leave password blank to autogenerate a password In all other browsers this works fine, and the saved password is not added, but Firefox on Windows 8.1 this is being filled in automatically, with the users saved password.

Chosen solution

Thanks - I'll see what I can find. Almost a shame that Mozilla simply ignores these fields though.

Such is life!

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

More Information

jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Yes, this is a change in Firefox 38. If the user has enabled the password manager, then Firefox will ignore autocomplete="off" when it finds a login form.

https://www.mozilla.org/firefox/38.0/releasenotes/

I'm not sure of the exact nature of your concern. For example, a user posted about how this is a problem for users who need to administer user credentials for others, since their own login gets filled (https://support.mozilla.org/questions/1063227). Unfortunately, the only workaround I know of is to delete the login so it can't be filled on any form on the relevant site.

Yes, this is a change in Firefox 38. If the user has enabled the password manager, then Firefox will ignore '''autocomplete="off"''' when it finds a login form. https://www.mozilla.org/firefox/38.0/releasenotes/ I'm not sure of the exact nature of your concern. For example, a user posted about how this is a problem for users who need to administer user credentials for others, since their own login gets filled ([https://support.mozilla.org/questions/1063227]). Unfortunately, the only workaround I know of is to delete the login so it can't be filled on any form on the relevant site.

Question owner

How then, should the fields be set up to force firefox to not autofill those fields?

I've since noticed that it is happening on Mac (I just had two usernames/passwords for the same site saved)

Case scenario: Add new user page with a field for Username and Password box. The Password box is then being auto-populated by the users saved passwords.

According to what you've said, the only way to stop this would be to completely turn off "Remember Passwords for Sites" option, unless there's some other HTML way that we can tell firefox that this field SHOULD NOT be getting auto-filled.

How then, should the fields be set up to force firefox to not autofill those fields? I've since noticed that it is happening on Mac (I just had two usernames/passwords for the same site saved) Case scenario: Add new user page with a field for Username and Password box. The Password box is then being auto-populated by the users saved passwords. According to what you've said, the only way to stop this would be to completely turn off "Remember Passwords for Sites" option, unless there's some other HTML way that we can tell firefox that this field SHOULD NOT be getting auto-filled.
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Stewart-Elvanto said

Case scenario:
Add new user page with a field for Username and Password box. The Password box is then being auto-populated by the users saved passwords.

According to what you've said, the only way to stop this would be to completely turn off "Remember Passwords for Sites" option, unless there's some other HTML way that we can tell firefox that this field SHOULD NOT be getting auto-filled.

No, you could keep the feature on but delete the saved password(s) for that site and not save any more for the site going forward.

I don't use this feature myself, but I have read that if you save two logins for the same site, Firefox shouldn't autofill the fields, but instead display available usernames in a drop-down when clicking in the username field. Not sure this will work, but if saving two fictitious logins will block the feature that might be a convenient workaround.

Regarding HTML changes, the new Google login form which asks for the username on a separate screen from the password has been successful in blocking the password manager from automatically logging users in. I haven't studied the mechanics of the form, but scripting definitely is used.

''Stewart-Elvanto [[#answer-735433|said]]'' <blockquote> Case scenario:<br> Add new user page with a field for Username and Password box. The Password box is then being auto-populated by the users saved passwords.<br><br> According to what you've said, the only way to stop this would be to completely turn off "Remember Passwords for Sites" option, unless there's some other HTML way that we can tell firefox that this field SHOULD NOT be getting auto-filled.</blockquote> No, you could keep the feature on but delete the saved password(s) ''for that site'' and not save any more for the site going forward. I don't use this feature myself, but I have read that if you save two logins for the same site, Firefox shouldn't autofill the fields, but instead display available usernames in a drop-down when clicking in the username field. Not sure this will work, but if saving two fictitious logins will block the feature that might be a convenient workaround. Regarding HTML changes, the new Google login form which asks for the username on a separate screen from the password has been successful in blocking the password manager from automatically logging users in. I haven't studied the mechanics of the form, but scripting definitely is used.

Chosen Solution

Thanks - I'll see what I can find. Almost a shame that Mozilla simply ignores these fields though.

Such is life!

Thanks - I'll see what I can find. Almost a shame that Mozilla simply ignores these fields though. Such is life!
cor-el
  • Top 10 Contributor
  • Moderator
16401 solutions 147970 answers

You can toggle signon.autofillForms to false to prevent Firefox from entering the name and password automatically.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can toggle signon.autofillForms to false to prevent Firefox from entering the name and password automatically. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config