Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox changing language of spellchecker in Gmail compose.

  • 8 replies
  • 4 have this problem
  • 62 views
  • Last reply by John99

more options

I realize this problem has been dealt with throughout the forums, but no one has presented an answer that has fixed it :(

Firefox is changing the spellchecker language when I want to compose a Gmail message.

--I have add-ons in Firefox of other language packs/dictionaries. --It's not Gmail doing this --I've changed spellchecker and intl.accept languages in about:config --I've deleted js preference files in Firefox --I've reinstalled Firefox --I've refreshed Firefox

NOTHING works, and I haven't found any of the same forum postings to be fixing this problem.

Please help. This is frustrating. How do I set a default language and not have to change it every bloody time I want to type a message?

Thank you!

All Replies (8)

more options

P.S. I've removed and re-added these other language add-ons, and that doesn't help either. I really want to keep them.

more options

What is the value of the lang attribute if you check this in the page source?

  • Firefox > Web Developer > Page Source
  • Tools > Web Developer > Page Source (Ctrl+U)
  • right-click on a web page and select View Page Source in the context menu

This forum shows for me:

Switching to another language like French would give this:

Firefox might switch to a different dictionary if one is installed.

more options

The only html attribute is "lang," and it in fact says "en."

more options

The language the spellchecker switches to is Spanish.

more options

well, also it's happening in facebook chat...so it's not a gmail thing :( WTF Firefox?

more options

We've seen in the past some cases where the dictionary got changed.

Are you clearing the Site Preferences in case you use "Clear history when Firefox closes" or clear history otherwise?

more options

I am not clearing site preferences. However, to experiment, I just cleared everything and restarted FF. I tried Gmail compose and FB chat and both of them were still on English (US). So it seems to jump dictionaries sometimes and sometimes maintain my preference?  :(

Thanks for your suggestions! I'll try out more if any come to your mind.

more options

brajawill said

Closing as a duplicate of

Hello,

I cannot find a solution anywhere in the support forums or by searching the web. The default language on my spellchecker keeps changing...all the time. I've tried many things, and nothing works. One person tried to help but stopped helping after a point. Here is my problem in detail: https://support.mozilla.org/en-US/questions/1064549

Why is this so hard, and why can no one seem to know what the problem is?  :(

Please help! How do I fix this? Thank you!

Brandon

John99 said

Closing as a duplicate of

FYI I also see apparently the same or a very problem.

I am currently using a Cannonical build of Fx 38 presumably en-US I have other languages available including English (United Kingdom)

Even within this text area my language as used and shown on right click will revert unpredictably back to en-us . The flip is not just at Firefox Restart it may not even require change of tab or reloading the tab. It has flipped part way through typing this message.

I have made no attempt to troubleshoot this issue. I have not checked with other languages. I currently have

  1. https://addons.mozilla.org/firefox/addon/english-gb-language-pack/
  2. https://addons.mozilla.org/en-US/firefox/addon/english-south-african-language/

installed. I will uninstall the 2nd one listed above, see if that makes a difference


Test: favourite favorite This is relatively recent, and only a minor irritation